ESA elettronica S.P.A. reserves the right to change the information contained in this document without notice. The information represents no obligation on the part of the company.

All products referred to are covered by the appropriate trademark and/or copyright legislation.
Before you read

Each reader of this manual can tailor the way its contents are read to his or her own preferred way of learning.

If you want to get to know first all the functions the VT offers you and then experiment by creating a project, you need simply follow the order of the chapters.

Alternatively, if you want to start creating a demonstration project immediately, analyzing the functions as they are met with, you need to proceed to “Chapter 3 -> VTWIN menus” and then jump directly to “Chapter 7 -> Using VTWIN”.

## Contents

### Foreword
- The manual ................................................................. F-1
- How can it help you? .................................................. F-1
- Conventions ............................................................... F-1

### Introduction
- What is VTWIN? ....................................................... I-1
- Requirements for displaying the Help on Line .............. I-1
- What is a project? ....................................................... I-1
- Type of project .......................................................... I-2
- Files generated by a VT project ................................... I-2
- Files generated by an ADT project .............................. I-3
- File architecture ....................................................... I-4

### Installing VTWIN
- Contents ........................................................................ 1-1
- HW requirements: minimum specifications ................... 1-2
- HW requirements: ideal specifications .......................... 1-2
- Installation procedure .................................................. 1-2

### Programming functions
- Contents ........................................................................ 2-1
- Field and Variable ..................................................... 2-2
- Positioning a field within the page ............................... 2-3
- Relationship between fields and variables .................... 2-4
- Relationship between exchange area and memory area 2-4
- List of functions .......................................................... 2-4

### VTWIN menus
- Contents ........................................................................ 3-1
- Configurator menu ..................................................... 3-2
- Editor menu ............................................................... 3-8

### The functions in detail
- Contents ........................................................................ 4-1
- Page ............................................................................. 4-3
- Multilanguage label .................................................... 4-4
- Multilanguage text ..................................................... 4-4
- Numerical field .......................................................... 4-5
- ASCII field .................................................................. 4-14
- Dynamic Text Field ..................................................... 4-14
- Bar field ....................................................................... 4-16
- Symbolic field ............................................................ 4-21
- Mobile symbolic field ................................................ 4-23
- Hour/Date field ............................................................ 4-27
- Trend ............................................................................ 4-29
- Touch Button ............................................................. 4-32
- Line ............................................................................. 4-32
- Rectangle ..................................................................... 4-32
- Ellipse ......................................................................... 4-33
- Arc .............................................................................. 4-33
- Bitmap Image ............................................................. 4-33
Variables ................................................................. 4-34
Variable groups .......................................................... 4-38
Page sequences ............................................................. 4-39
Memory areas ............................................................... 4-41
Exchange areas ............................................................ 4-42
Information Messages .................................................. 4-53
Alarms ......................................................................... 4-55
Touch button ................................................................. 4-58
Direct Commands .......................................................... 4-67
Text Lists ..................................................................... 4-70
Lists of images .............................................................. 4-71
Images ......................................................................... 4-72
Macro ........................................................................... 4-78
Pipelines ....................................................................... 4-79
Print page ..................................................................... 4-82
Header and footer ......................................................... 4-84
Report .......................................................................... 4-86
Trend buffer ................................................................. 4-88

Configurator menu in detail
Contents ........................................................................ 5-1
File ............................................................................... 5-2
Edit ............................................................................. 5-10
Tools ............................................................................. 5-10
View ............................................................................. 5-11
Options ......................................................................... 5-11
? .................................................................................. 5-11

Editor menu in detail
Contents .......................................................................... 6-1
Project ............................................................................ 6-2
Tools ............................................................................. 6-2
Object ............................................................................ 6-3
Fields ............................................................................ 6-3
Edit ............................................................................... 6-4
Page ............................................................................... 6-4
Configure ....................................................................... 6-6
Windows ......................................................................... 6-26
? .................................................................................. 6-26

Using VTWIN
Contents .......................................................................... 7-1
Terminology used ........................................................... 7-2
Forms assumed by the mouse pointer ......................... 7-2
Meaning of the Configurator menu icons ..................... 7-3
Meaning of the Editor menu icons......................... 7-4

Creating a project with VTWIN
Contents .......................................................................... 8-1
Creating the project ........................................................ 8-3
Project information ...................................................... 8-6
Setting project languages .......................................... 8-7
Project setup ................................................................. 8-10
Inserting variables ....................................................... 8-12
Compiling and transferring a project

Contents................................................................. 9-1
Compiling a project ............................................... 9-2
Transferring the project ......................................... 9-3

Creating and printing documentation

Contents................................................................. 10-1
Importance of documentation ................................. 10-2
Print the project.................................................... 10-2

Creating a back-up of the project

Contents................................................................. 11-1
Importance of a Back-up......................................... 11-2
How to create a Back-up......................................... 11-2

Defining the fonts

Contents................................................................. 12-1
Meaning of the icons used in the menus..................... 12-3
Personalizing a Font.............................................. 12-4

Free terminal

Contents................................................................. 13-1
Transfer of free terminal....................................... 13-2

ActiveX

Contents................................................................. 14-1
User application package...................................... 14-2

Technical support

Contents................................................................. 15-1
National Customer Care....................................... 15-2
National Product Returns...................................... 15-2
International Customer Care................................. 15-4
International Product Returns.............................. 15-4

Appendix A

Contents................................................................. AA-1
Project images - Graphic (Part 1 of 3)..................... AA-2

Index

................................................................. IA-1
Foreword

The programming manual is the same for all models of Video Terminal and for the different types of accessories, since there are no differences in the method of programming.

Video Terminals can be divided into two groups: those with a keyboard and those without, but equipped with a touch screen.

Most of the examples used in this manual refer to a Touch Screen product. With this type of Video Terminal there is no such thing as a page sequence (you will find an explanation of what these are further on); on the other hand, if you use a Video Terminal with a keyboard there will be page sequences.

The options given in the masks differ according to the type of Video Terminal, thus the same mask in one case contains the option Start up page, while in the other case the option is called Start Sequence.

The information contained in this manual refers to top of the range terminals. To check which functions a given VT has, consult the relevant Hardware Manual.

The manual is the tool that allows the user to create his or her own application packages for the VIDEO TERMINALS (VT) and for the accessories that can be connected, ADAPTERS (ADT), by using the VTWIN programming package.

How can it help you?

The manual contains all the functions, instructions, concepts and examples necessary for the user to learn quickly and easily.

Conventions

Below is a list of representational devices used in this manual together with their respective meanings:

- **File > Open**
  This style is used to indicate a menu option. It represents the complete path necessary for reaching the option required.

- **Label**
  This style is used to indicate a data input field.

- **[]**
  The contents are appear on the display.

- **✦**
  Indicates that this input field must be used.

- **☐**
  Identifies a key or touch button.

- **☎**
  Identifies an option within a window.
Identifies a folder.

Draws attention to essential points.
## Introduction

**What is VTWIN?**

VTWIN is a program that allows the user to create the application package required to work on the VT. It is easy to use and simple to understand.

VTWIN will only work in a **Windows 95/98/2000** or **Windows NT** environment.

**Requirements for displaying the Help on Line**

VTWIN contains an exhaustive Help on Line (HoL), **available in the future**, clarifying the vast majority of doubts that a user might have. To have the HoL on screen a Browser needs to have been installed on the Personal Computer (PC) to display pages in HTML format. (Typical Browsers: Internet Explorer, Netscape Communicator or equivalents.)

Currently VTWIN contains a HoL that does not require any special programs for displaying it.

**What is a project?**

The definition of the term project changes according to whether the product being used is a VT or ADT.

In the context of a VT, a PROJECT may be defined as a set of screens (defined later as PAGES) having the same dimensions as the display of the VT being used. All pages can be freely configured by the user, so as to be able to contain texts and/or the display/setting of process variables. The various pages configured in this way can be freely interconnected to create the best way for the user to navigate between them. Finally, every project can enable the user to create appropriate diagnostic comments in order to signal the occurrence of anomalous events in the process.

To sum up: a PROJECT can be considered as a more or less complex system of pages whose aim is to enable the handling and/or display of a productive process.

In the context of an ADT, a PROJECT may be defined as a set of variables arranged in groups (referred to later as **Groups of Variables**), which must be used by the applications created by the user to handle the variables (read/write) using a Personal Computer (see “Chapter 14 -> ActiveX“).
VTWIN allows the user to generate two types of project: one called “Single VT” and one called “ESA-NET network”. The difference between the two is simply that the former allows you to create projects for VTs and ADTs that are not connected as an ESA-NET network, while the latter allows you to create projects to be used by VTs and ADTs connected in a network. By connecting a number of VTs and ADTs as an ESA-NET network the information held in one of the devices connected directly to one of the participants can be shared by the remaining VTs and ADTs in the network (see Hardware Manual). One network project can be the source of one or more single projects (the maximum number being the number of terminals making up the network project) and, vice versa, several single projects can make up a single network project.

⚠️ The projects generated with the 2.xx versions of VTWIN and opened using version 3.xx are automatically duplicated in an equivalent format (.VTS).

Table 0.1 lists the extensions of the files generated by the VT project.

<table>
<thead>
<tr>
<th>Extension</th>
<th>Location</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>.VTS</td>
<td>Project directory</td>
<td>Single project file -- all the files needed for the project are obtained from this file. <em>Loss of this file will cause the project to be lost.</em></td>
</tr>
<tr>
<td>.VTN</td>
<td>Project directory</td>
<td>Network project file -- all the files needed for the project are obtained from this file. <em>Loss of this file will cause the project to be lost.</em></td>
</tr>
<tr>
<td>.OBJ</td>
<td>Project directory</td>
<td>Temporary file obtained by compiling the .vts or .vtn file containing the text part of the project. This file is generated each time the project is compiled; it is present only for the time needed to transfer the .bin file and is then incorporated in the project file.</td>
</tr>
<tr>
<td>.OBG</td>
<td>Project directory</td>
<td>Temporary file obtained by compiling the .vts or .vtn file containing the graphic part of the project. This file is generated each time the project is compiled; it is present only for the time needed to transfer the .bin file and is then incorporated in the project file.</td>
</tr>
<tr>
<td>.BIN</td>
<td>Main directory of VTWIN</td>
<td>File transferred to the VT. It is obtained following a command to transfer the project from the PC to the VT. It groups together the information contained in the .obj and .obg files. The file remains in existence only for the time needed for the transfer and is then automatically deleted.</td>
</tr>
<tr>
<td>.PRJ</td>
<td>Main directory of VTWIN</td>
<td>Temporary project file. A numerical file may be found with this extension if VTWIN has been closed incorrectly. <em>The file can be removed once VTWIN has been closed.</em></td>
</tr>
<tr>
<td>.BMP</td>
<td>Main directory of VTWIN</td>
<td>Temporary project file. A numerical file may be found with this extension if VTWIN has been closed incorrectly. <em>The file can be removed once VTWIN has been closed. (Before removing check that the file has not been created on purpose by the user.)</em></td>
</tr>
</tbody>
</table>
The removal of the .VTS or .VTN file will cause an irrevocable loss of the project.

Table 0.2 lists the extensions of the files generated by the ADT project.

<table>
<thead>
<tr>
<th>Extension</th>
<th>Location</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>.VTS</td>
<td>Project directory</td>
<td>Single project file -- all the files needed for the project are obtained from this file. Loss of this file will cause the project to be lost.</td>
</tr>
<tr>
<td>.VTN</td>
<td>Project directory</td>
<td>Network project file -- all the files needed for the project are obtained from this file. Loss of this file will cause the project to be lost.</td>
</tr>
<tr>
<td>.OBJ</td>
<td>PC_cmp directory</td>
<td>File to be transferred to the ADT. File obtained by compiling the .vts file or the .vtn file containing the text section of the project. This file is generated each time the project is compiled.</td>
</tr>
<tr>
<td>.FW</td>
<td>PC_cmp directory</td>
<td>File to be transferred to the ADT. File obtained by compiling the .vts file or the .vtn file containing the ADT operative system, and the drive associating ADT and device.</td>
</tr>
<tr>
<td>.CFG</td>
<td>PC_cmp directory</td>
<td>File obtained by compiling the .vts or .vtn file containing the information need for ADT to communicate with the PC. This file is generated each time the project is compiled.</td>
</tr>
</tbody>
</table>

The removal of the .VTS or .VTN file will cause an irrevocable loss of the project.
VTWIN, after it has been installed, creates a structure which we show below together with the contents of the various files.

- **Main directory**
- **Compiler files and PC <-> VT communication files.** These directories can be increased according to which products are supported.
- **System images for displaying VTWIN.**
- **Backup/Restore files from/for VT.**
- **Files needed to create fonts.**
- **VT operating system and drive associating VT and device.**
- **Contains the fonts supplied and those created by the user.**
- **Files needed to transfer free terminal protocol.**
- **Contains bitmap images that can be utilized by the user.**
- **Contains HoL.**
- **Contains the files for importing/exporting translations.**
- **Contains the files needed for printing.**
- **Contains the cover-page files for printing.**
- **Contains the print configuration.**
- **Files needed to generate and/or display a project.**
- **Page images.**
- **Contains examples of programming.**

These are the files enabling VTWIN to function. The loss or removal of one or more files makes it impossible to use the program.
Chapter 1  Installing VTWIN

## Contents

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>HW requirements: minimum specifications</td>
<td>1-2</td>
</tr>
<tr>
<td>HW requirements: ideal specifications</td>
<td>1-2</td>
</tr>
<tr>
<td>Installation procedure</td>
<td>1-2</td>
</tr>
</tbody>
</table>

This chapter is made up of a total of 2 pages.
### HW requirements: minimum specifications

For VTWIN to work properly the machine must be configured as follows:

- Processor: PENTIUM 16Mhz
- Operative system: Windows 95 / 98 / 2000 / NT 4.00 SP3 or later
- RAM memory: 32 Mbytes

### HW requirements: ideal specifications

For VTWIN to work at its best the machine must be configured as follows:

- Processor: PENTIUM 200Mhz or later
- Operative system: Windows 95 / 98 / 2000 / NT 4.00 SP3 or later
- RAM memory: 16 Mbytes

### Installation procedure

Insert the Cd-Rom in its drive; if on the PC you activate the function “Auto insert notification”; the presentation of VTWIN is displayed automatically; alternatively click on **Start > Run**…

Digit e:\setup.exe and confirm by pressing OK.

⚠️ **If the drive to be used is not “e:”, put in the appropriate letter.**

Follow the instructions on screen.
Chapter 2  Programming functions

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field and Variable</td>
<td>2-2</td>
</tr>
<tr>
<td>Positioning a field within the page</td>
<td>2-3</td>
</tr>
<tr>
<td>Relationship between fields and variables</td>
<td>2-4</td>
</tr>
<tr>
<td>Relationship between exchange area and memory area</td>
<td>2-4</td>
</tr>
<tr>
<td>List of functions</td>
<td>2-4</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 36 pages.
Field and Variable

Before dealing with the programming functions available, it is essential that certain fundamental concepts be defined. The programming packages often contain the terms FIELD and VARIABLE. In the case of Touch Screen models the term TOUCH BUTTON is also used. The example we give two casually chosen products to simplify the explanation of these concepts.

We use the word FIELD to signify an area of the page that can take on certain meanings. A field can be either STATIC or DYNAMIC. By static field we mean a field that does not change the display status in the page; by dynamic field we mean a field that changes the display status in the page as a function of the VARIABLE assigned to the device connected.

We use the word touch BUTTON to refer to a page area that can be assigned to and made to represent a virtual button to which particular functions can be attributed.

In the case of non-Touch Screen models, the equivalents of the touch buttons are the “F” and/or “E”-keys.
Positioning a field within the page

There is no particular problem with the positioning of a field within the page of a terminal when using a keyboard, whether in the case of a “Modify Field Enabled” or a read-only field. None of the above applies to models with a touch screen.

In the case of these latter models, the positioning of fields like “Modify Field Enabled” is of key importance, if we are to avoid errors being generated at the compilation stage.

Instead of a keyboard, touch screen models use a touch-sensitive screen, divided into rows and columns that between them constitute a Matrix. To be correctly placed with “Modify Field Enabled” there should be no overlapping of fields in the same touch-sensitive area.
The VARIABLE enables the user to assign a data in the device connected to a field.

Using THE MEMORY AREA the data in the connected device can be assigned to the EXCHANGE AREA of the VT.

The following pages illustrate by means of a tree the relationship between the principal objects, the elements associated with them respectively and the properties of these elements. In addition there is a page reference to where the reader can find the most useful explanation of their meaning.
<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dynamic text field</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>General options</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bit-wise protection</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bit number</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Password</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Threshold</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Type</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Threshold</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Foreground</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Background</td>
<td>Page 4-16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Preview</td>
<td>Page 4-16</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Modify field enabled</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bit-wise protection</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bit-wise protection</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bit number</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Password</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Threshold</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Type</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Threshold</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Foreground</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Background</td>
<td>Page 4-20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Preview</td>
<td>Page 4-21</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Bar field</td>
<td></td>
<td>General options</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Name</td>
<td>Page 4-21</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source</td>
<td>Page 4-21</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Left -&gt; Right</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Right -&gt; Left</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Top -&gt; Bottom</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bottom -&gt; Top</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Field index</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Mode</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Continuous read</td>
<td>Page 4-22</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------</td>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>One-shot read</td>
<td></td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td>Modify field enabled</td>
<td></td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td>Bit-wise protection</td>
<td></td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td>Bit-wise protection</td>
<td>Bit number</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td>Password</td>
<td></td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td>Threshold</td>
<td>Type</td>
<td>Page 4-22</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source</td>
<td>Page 4-23</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable</td>
<td>Page 4-23</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Threshold</td>
<td>Page 4-23</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Foreground</td>
<td>Page 4-23</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Background</td>
<td>Page 4-23</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Symbolic field</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>General options</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
<td></td>
<td>Page 4-23</td>
</tr>
<tr>
<td>Source</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Type</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Image lists</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Single bit</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Bit-group</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Value-structured</td>
<td></td>
<td></td>
<td>Page 4-24</td>
</tr>
<tr>
<td>Mode</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Programming functions

<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Image lists</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Single bit</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bit-group</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Value-structured</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td>Mode</td>
<td>Field index</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Continuous read</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>One-shot read</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modify field</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>enabled</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bit-wise protection</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bit number</td>
<td>Page 4-26</td>
<td></td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Trend</td>
<td></td>
<td>Format</td>
<td>Page 4-29</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text lists</td>
<td>Page 4-29</td>
</tr>
<tr>
<td></td>
<td>Trend</td>
<td>Name</td>
<td>Page 4-29</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Channels</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Trend buffer</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Number of samples</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Marker type</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Marker type</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Color</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Upper limit</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Upper limit</td>
<td>Page 4-30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Lower limit</td>
<td>Page 4-30</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------</td>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Touch buttons</td>
<td>Lower limit Color</td>
<td>Page 4-31</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Name</td>
<td>Page 4-32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Project touch buttons</td>
<td>Page 4-32</td>
</tr>
<tr>
<td></td>
<td>Line</td>
<td></td>
<td>Page 4-32</td>
</tr>
<tr>
<td></td>
<td>Rectangle</td>
<td></td>
<td>Page 4-33</td>
</tr>
<tr>
<td></td>
<td>Ellipse</td>
<td></td>
<td>Page 4-33</td>
</tr>
<tr>
<td></td>
<td>Arc</td>
<td></td>
<td>Page 4-33</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Bitmap images</td>
<td>Project images</td>
<td>Page 4-34</td>
<td></td>
</tr>
</tbody>
</table>

Variables

General options

- Name  Page 4-36
- Source  Page 4-36
- Data area  Page 4-36
- Type  Page 4-36
- Length  Page 4-37
- Signed  Page 4-37
- BCD  Page 4-37
- Address  Page 4-37

Limits and linear scaling
Variable groups

- Name
  - Page 4-39
- Group’s items
  - Page 4-39

Screen sequences

- Number
  - Page 4-40
- Name
  - Page 4-40
- Switch on led
  - Page 4-41
- Start/Stop sequence
  - Page 4-41
- Start/Stop sequence
  - Page 4-41
- Start page
  - Page 4-41
- Stop page
  - Page 4-41

Input limits
- Page 4-37
Linear scale
- Page 4-37

Object | Element | Property | Explanation
--- | --- | --- | ---
| | | Input limits | Page 4-37
| | | Linear scale | Page 4-37
| | Variable groups | Name | Page 4-39
| | | Group’s items | Page 4-39
| | Screen sequences | Number | Page 4-40
| | | Name | Page 4-40
| | | Switch on led | Page 4-41
| | | Start/Stop sequence | Page 4-41
| | | Start/Stop sequence
| | | Start page | Page 4-41
| | | Stop page | Page 4-41
<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory area</td>
<td></td>
<td>Random sequence</td>
<td>Page 4-41</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td>Name</td>
<td>Page 4-41</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td>Source</td>
<td>Page 4-42</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td>Data area</td>
<td>Page 4-42</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td>Length</td>
<td>Page 4-42</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td>Address</td>
<td>Page 4-42</td>
</tr>
<tr>
<td>Exchange area</td>
<td></td>
<td>Enabled</td>
<td>Page 4-52</td>
</tr>
<tr>
<td>Exchange area</td>
<td></td>
<td>Name</td>
<td>Page 4-52</td>
</tr>
<tr>
<td>Exchange area</td>
<td></td>
<td>Data area type</td>
<td>Page 4-52</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Refresh delay</td>
<td></td>
<td></td>
<td>Page 4-52</td>
</tr>
<tr>
<td>Memory area</td>
<td>Source</td>
<td></td>
<td>Page 4-52</td>
</tr>
<tr>
<td>Memory area</td>
<td></td>
<td></td>
<td>Page 4-53</td>
</tr>
<tr>
<td>Information</td>
<td>messages</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
<td></td>
<td>Page 4-53</td>
</tr>
<tr>
<td>Exchange area</td>
<td></td>
<td></td>
<td>Page 4-53</td>
</tr>
<tr>
<td>Bit number</td>
<td></td>
<td></td>
<td>Page 4-53</td>
</tr>
<tr>
<td>Message</td>
<td>Message</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Message</td>
<td>Dimension</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Message</td>
<td>Preview</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Message</td>
<td>Setting</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Help message</td>
<td>Font</td>
<td></td>
<td>Page 4-54</td>
</tr>
</tbody>
</table>
## Programming functions

<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help message</td>
<td>Help</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Help message</td>
<td>Preview</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Help message button</td>
<td>Go to page</td>
<td></td>
<td>Page 4-55</td>
</tr>
<tr>
<td>Help message button</td>
<td>Label</td>
<td></td>
<td>Page 4-55</td>
</tr>
<tr>
<td>Help message button</td>
<td>Preview</td>
<td></td>
<td>Page 4-54</td>
</tr>
<tr>
<td>Print options</td>
<td>Print message</td>
<td></td>
<td>Page 4-55</td>
</tr>
</tbody>
</table>

### Alarm

<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm</td>
<td>Name</td>
<td>Page 4-56</td>
</tr>
<tr>
<td>Alarm</td>
<td>Exchange area</td>
<td>Page 4-56</td>
</tr>
<tr>
<td>Alarm</td>
<td>Bit number</td>
<td>Page 4-56</td>
</tr>
<tr>
<td>Alarm</td>
<td>Alarm</td>
<td>Page 4-56</td>
</tr>
<tr>
<td>Alarm</td>
<td>Dimension</td>
<td>Page 4-57</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
</tr>
<tr>
<td>----------------</td>
<td>---------------</td>
<td>------------</td>
</tr>
<tr>
<td></td>
<td>Alarm Preview</td>
<td></td>
</tr>
<tr>
<td>Alarm Setting</td>
<td>Font</td>
<td></td>
</tr>
<tr>
<td>Alarm Help</td>
<td>Help</td>
<td></td>
</tr>
<tr>
<td>Alarm Help</td>
<td>Preview</td>
<td></td>
</tr>
<tr>
<td>Alarm Help button Go to page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alarm Help button Label</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alarm Help button Preview</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print options</td>
<td>Print alarm</td>
<td></td>
</tr>
<tr>
<td>Print options</td>
<td>Save in alarm buffer</td>
<td></td>
</tr>
</tbody>
</table>

Touch buttons

General options
<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Width</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Height</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Button label</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Button label</td>
<td>Page 4-60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Preview</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Border (Icon)</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Width</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Height</td>
<td>Page 4-59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Background image</td>
<td>Page 4-60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Background image</td>
<td>Page 4-60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fit button (Icon)</td>
<td>Page 4-60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Preview</td>
<td>Page 4-59</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
<td>Explanation</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------</td>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td>Page 4-70</td>
<td></td>
</tr>
<tr>
<td>Bit command</td>
<td>Bit number</td>
<td>Page 4-70</td>
<td></td>
</tr>
<tr>
<td>Value-structured command</td>
<td>Operator</td>
<td>Page 4-70</td>
<td></td>
</tr>
<tr>
<td>Value-structured command</td>
<td>Value</td>
<td>Page 4-70</td>
<td></td>
</tr>
</tbody>
</table>

Text lists

- Name | Page 4-71
- Values | Page 4-71
- Texts | Page 4-71
- List of selected texts | Page 4-71

Image lists

- Name | Page 4-71
- Images | Page 4-72
<table>
<thead>
<tr>
<th>Object</th>
<th>Element</th>
<th>Property</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Values</td>
<td>Page 4-72</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Image selected</td>
<td>Page 4-72</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Preview</td>
<td>Page 4-72</td>
<td></td>
</tr>
</tbody>
</table>

Images

<table>
<thead>
<tr>
<th></th>
<th>Name</th>
<th>Page 4-76</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File Name</td>
<td>Page 4-76</td>
</tr>
<tr>
<td></td>
<td>Directories</td>
<td>Page 4-76</td>
</tr>
<tr>
<td></td>
<td>List files of type</td>
<td>Page 4-76</td>
</tr>
<tr>
<td></td>
<td>Drive</td>
<td>Page 4-76</td>
</tr>
<tr>
<td></td>
<td>Preview</td>
<td>Page 4-76</td>
</tr>
</tbody>
</table>

Macros

<table>
<thead>
<tr>
<th></th>
<th>Name</th>
<th>Page 4-78</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
<td>----------</td>
</tr>
<tr>
<td></td>
<td>Mode</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Read and write by polling</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Read by polling and write on changes</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Read and write on command</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Polling rate</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Print page</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Use default settings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rows per page</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Columns per page</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Left margin</td>
<td></td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------</td>
<td>------------</td>
</tr>
<tr>
<td>Headers and footers</td>
<td>Name</td>
<td>Page 4-84</td>
</tr>
<tr>
<td></td>
<td>Use default</td>
<td>Page 4-85</td>
</tr>
<tr>
<td></td>
<td>settings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Printer</td>
<td>Page 4-85</td>
</tr>
<tr>
<td></td>
<td>Rows per page</td>
<td>Page 4-85</td>
</tr>
<tr>
<td></td>
<td>Rows per column</td>
<td>Page 4-85</td>
</tr>
<tr>
<td></td>
<td>Left margin</td>
<td>Page 4-85</td>
</tr>
<tr>
<td>Print report</td>
<td>Number</td>
<td>Page 4-87</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>Page 4-87</td>
</tr>
<tr>
<td></td>
<td>Start/Stop</td>
<td>Page 4-87</td>
</tr>
<tr>
<td></td>
<td>sequence</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Start/Stop</td>
<td>Page 4-87</td>
</tr>
<tr>
<td></td>
<td>sequence</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Start page</td>
<td>Page 4-87</td>
</tr>
<tr>
<td>Object</td>
<td>Element</td>
<td>Property</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>Trend buffer</td>
<td></td>
<td>Start/stop sequence</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Stop page</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Random sequence</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Page selected</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Use default settings</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Send Form-Feed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Heading</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Footer</td>
</tr>
<tr>
<td>General options</td>
<td></td>
<td>Number</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Name</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sample variable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source</td>
</tr>
</tbody>
</table>
### Object | Element | Property | Explanation
---|---|---|---
| Sample variable | Variable | | Page 4-90
| Mode | | | 
| Number of samples | | | Page 4-90
| Single sample on polling | | | Page 4-91
| Single sample on command | | | Page 4-91
| Block of samples on command | | | Page 4-91
| Polling rate | | | Page 4-91
| FIFO | | | Page 4-91
| Ignore exceeding samples | | | Page 4-91
Chapter 3  VTWIN menus

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurator menu</td>
<td>3-2</td>
</tr>
<tr>
<td>Editor menu</td>
<td>3-8</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 26 pages.
Before setting out the menus with their respective meanings, we need to establish that VTWIN consists of two parts: the first (Configurator) allows the operator to configure a single panel or the ESA-NET network, the other part (Editor) allows you to create the project real and proper. For this reason the menus are called for simplicity Configurator menu and Editor menu.

### Configurator menu

The following pages contain a table showing how the menus are nested and where to find the explanations that help interpret their meaning.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>New</td>
<td></td>
<td>Page 5-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>New project</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td></td>
<td>Page 5-9</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td></td>
<td>Page 5-9</td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td></td>
<td>Page 5-10</td>
</tr>
</tbody>
</table>
### Menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Page 5-10</td>
</tr>
</tbody>
</table>

### Edit

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Properties</td>
<td></td>
<td>Page 5-10</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
<td>Page 5-10</td>
</tr>
<tr>
<td></td>
<td>Rename</td>
<td></td>
<td>Page 5-10</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td></td>
<td>Page 5-10</td>
</tr>
</tbody>
</table>

### Tools

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Print...</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Print setting</td>
<td></td>
<td>Page 10-2</td>
</tr>
<tr>
<td></td>
<td>Pattern</td>
<td></td>
<td>Page 10-2</td>
</tr>
<tr>
<td></td>
<td>Preview</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
CAPITOLO 3
VTWIN menus

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Check</td>
<td>Page 10-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View</td>
<td>Page 10-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Change</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>Page 10-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Optional sections</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Available</td>
<td>Page 10-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selected</td>
<td>Page 10-3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Global setting</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cover included</td>
<td>Page 10-4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Index</td>
<td>Page 10-4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Info-project</td>
<td>Page 10-4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Comment sections</td>
<td>Page 10-4</td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>--------</td>
<td>------------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Search Help For...</td>
<td></td>
<td>Page 5-11</td>
</tr>
<tr>
<td></td>
<td>About...</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>System information</td>
<td></td>
<td>Page 5-11</td>
</tr>
<tr>
<td></td>
<td>Check installation</td>
<td></td>
<td>Page 5-11</td>
</tr>
</tbody>
</table>
Editor menu

The following pages contain a table showing how the menus are nested and where to find the explanations that help interpret their meaning.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Update</td>
<td></td>
<td>Page 6-2</td>
</tr>
<tr>
<td></td>
<td>Update and close</td>
<td></td>
<td>Page 6-2</td>
</tr>
<tr>
<td></td>
<td>Update public data</td>
<td></td>
<td>Page 6-2</td>
</tr>
<tr>
<td></td>
<td>Close</td>
<td></td>
<td>Page 6-2</td>
</tr>
<tr>
<td>Tools</td>
<td>Project compilation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------</td>
<td>-------------------------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Stop first error</td>
<td></td>
<td>Page 9-2</td>
</tr>
<tr>
<td></td>
<td>No stop</td>
<td></td>
<td>Page 9-2</td>
</tr>
<tr>
<td></td>
<td>Stop after N. errors</td>
<td></td>
<td>Page 9-2</td>
</tr>
<tr>
<td></td>
<td>Display warnings</td>
<td></td>
<td>Page 9-2</td>
</tr>
<tr>
<td></td>
<td>Output</td>
<td></td>
<td>Page 9-2</td>
</tr>
<tr>
<td></td>
<td>Project transfer</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Communication ports</td>
<td></td>
<td>Page 9-3</td>
</tr>
<tr>
<td></td>
<td>Baud rate</td>
<td></td>
<td>Page 9-3</td>
</tr>
<tr>
<td></td>
<td>Update terminal</td>
<td></td>
<td>Page 9-3</td>
</tr>
<tr>
<td></td>
<td>Update terminal Fw</td>
<td></td>
<td>Page 9-3</td>
</tr>
<tr>
<td></td>
<td>Update adapters</td>
<td></td>
<td>Page 9-4</td>
</tr>
<tr>
<td></td>
<td>Update adapters Fw</td>
<td></td>
<td>Page 9-4</td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Font</td>
<td>Font</td>
<td>Page 12-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dimension</td>
<td>Page 12-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Character overview</td>
<td>Page 12-2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Character management</td>
<td>Page 12-2</td>
<td></td>
</tr>
<tr>
<td>Backup/Restore</td>
<td></td>
<td>Page 6-2</td>
<td></td>
</tr>
<tr>
<td>Export translations</td>
<td></td>
<td>Page 6-3</td>
<td></td>
</tr>
<tr>
<td>Import transactions</td>
<td></td>
<td>Page 6-3</td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>None</td>
<td></td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td>Line</td>
<td></td>
<td></td>
<td>Page 7-7</td>
</tr>
<tr>
<td>Rectangle</td>
<td></td>
<td></td>
<td>Page 7-7</td>
</tr>
<tr>
<td>Ellipse</td>
<td></td>
<td></td>
<td>Page 7-7</td>
</tr>
<tr>
<td>Arc</td>
<td></td>
<td></td>
<td>Page 7-7</td>
</tr>
<tr>
<td>Bitmap images</td>
<td></td>
<td></td>
<td>Page 7-7</td>
</tr>
</tbody>
</table>
CAPITOLO 3
VTWIN menus

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td></td>
<td></td>
<td>Page 7-4</td>
</tr>
<tr>
<td>Fields</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td></td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td>Numerical</td>
<td></td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td>Ascii</td>
<td></td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td>Dynamic</td>
<td></td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td>Bar</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Symbolic</td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td></td>
<td>Mobile symbolic</td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td></td>
<td>Date</td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td></td>
<td>Trend</td>
<td></td>
<td>Page 7-6</td>
</tr>
<tr>
<td></td>
<td>Touch button</td>
<td></td>
<td>Page 7-7</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Menu Table

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Font choice</td>
<td></td>
<td>Page 7-5</td>
</tr>
<tr>
<td></td>
<td>Reverse</td>
<td></td>
<td>Page 7-5</td>
</tr>
<tr>
<td></td>
<td>Dimension</td>
<td>X1</td>
<td>Page 7-5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X2</td>
<td>Page 7-5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X4</td>
<td>Page 7-5</td>
</tr>
<tr>
<td></td>
<td>Zoom up</td>
<td></td>
<td>Page 7-4</td>
</tr>
<tr>
<td></td>
<td>Zoom down</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Menu | Option | Access to | Explanation
--- | --- | --- | ---
<p>|  | Language fonts | Page 6-12 |  |
|  | Project fonts | Page 6-12 |  |
| Project set-up |  |  |  |
|  | General |  |  |
|  | Edit mode idle timeout | Page 6-12 |  |
|  | Start-up sequence | Page 6-12 |  |
|  | Start page | Page 6-13 |  |
|  | Beep on screen touch | Page 6-13 |  |
|  | Enable screen saver | Page 6-13 |  |
|  | Screen saver delay | Page 6-13 |  |
|  | Alarms |  |  |
|  | Automatic change of context | Page 6-13 |  |</p>
<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Access to</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Automatic scrolling</td>
<td></td>
<td>Page 6-13</td>
</tr>
<tr>
<td></td>
<td>Autoscroll delay</td>
<td></td>
<td>Page 6-13</td>
</tr>
<tr>
<td></td>
<td>Beep on new alarm</td>
<td></td>
<td>Page 6-13</td>
</tr>
<tr>
<td></td>
<td>Ordering alarm buffer...</td>
<td></td>
<td>Page 6-13</td>
</tr>
<tr>
<td></td>
<td>Alarm signal position</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Data format</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Time format</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Messages</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Automatic scrolling</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Autoscroll delay</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Message signal position</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td></td>
<td>Data format</td>
<td></td>
<td>Page 6-14</td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Comment</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Number of characters</td>
<td>Page 6-25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Comment Variable</td>
<td>Page 6-25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Items</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Items Variable</td>
<td></td>
<td>Page 6-25</td>
</tr>
<tr>
<td></td>
<td>Infos</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Infos Time/Enable</td>
<td></td>
<td>Page 6-25</td>
</tr>
<tr>
<td></td>
<td>Infos Date/Enable</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Infos Checksum/Enable</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Infos No.Items/Enable</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Public data</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Windows</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Access to</td>
<td>Explanation</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Tile horizontal</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Tile vertical</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>?</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Index</td>
<td></td>
<td>Page 6-26</td>
</tr>
<tr>
<td></td>
<td>Search for help on...</td>
<td></td>
<td>Page 6-26</td>
</tr>
</tbody>
</table>
Chapter 4  The functions in detail

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>4-3</td>
</tr>
<tr>
<td>Multilanguage label</td>
<td>4-4</td>
</tr>
<tr>
<td>Multilanguage text</td>
<td>4-4</td>
</tr>
<tr>
<td>Numerical field</td>
<td>4-5</td>
</tr>
<tr>
<td>ASCII field</td>
<td>4-14</td>
</tr>
<tr>
<td>Dynamic Text Field</td>
<td>4-16</td>
</tr>
<tr>
<td>Bar field</td>
<td>4-21</td>
</tr>
<tr>
<td>Symbolic field</td>
<td>4-23</td>
</tr>
<tr>
<td>Mobile symbolic field</td>
<td>4-25</td>
</tr>
<tr>
<td>Hour/Date field</td>
<td>4-27</td>
</tr>
<tr>
<td>Trend</td>
<td>4-29</td>
</tr>
<tr>
<td>Touch Button</td>
<td>4-32</td>
</tr>
<tr>
<td>Line</td>
<td>4-32</td>
</tr>
<tr>
<td>Rectangle</td>
<td>4-33</td>
</tr>
<tr>
<td>Ellipse</td>
<td>4-33</td>
</tr>
<tr>
<td>Arc</td>
<td>4-33</td>
</tr>
<tr>
<td>Bitmap Image</td>
<td>4-33</td>
</tr>
<tr>
<td>Variables</td>
<td>4-34</td>
</tr>
<tr>
<td>Variable groups</td>
<td>4-38</td>
</tr>
<tr>
<td>Page sequences</td>
<td>4-39</td>
</tr>
<tr>
<td>Memory areas</td>
<td>4-41</td>
</tr>
<tr>
<td>Exchange areas</td>
<td>4-42</td>
</tr>
<tr>
<td>Information Messages</td>
<td>4-53</td>
</tr>
<tr>
<td>Alarms</td>
<td>4-55</td>
</tr>
<tr>
<td>Touch button</td>
<td>4-58</td>
</tr>
<tr>
<td>Direct Commands</td>
<td>4-67</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 92 pages.
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Lists</td>
<td>4-70</td>
</tr>
<tr>
<td>Lists of images</td>
<td>4-71</td>
</tr>
<tr>
<td>Images</td>
<td>4-72</td>
</tr>
<tr>
<td>Macro</td>
<td>4-78</td>
</tr>
<tr>
<td>Pipelines</td>
<td>4-79</td>
</tr>
<tr>
<td>Print page</td>
<td>4-82</td>
</tr>
<tr>
<td>Header and footer</td>
<td>4-84</td>
</tr>
<tr>
<td>Report</td>
<td>4-86</td>
</tr>
<tr>
<td>Trend buffer</td>
<td>4-88</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 92 pages.
Page

By *Page* we mean an ensemble of data, labels and/or graphic items that make up the visual aspect of the screen as defined by the user and displayed on the VT.

Pages can be of two types: Text and Graphic (in the case of VTs that provide this facility). The first type of page, as implied by the name, only allows the use of alphanumeric characters and symbols; with the other type of page, however, images and drawings can also be used.

The maximum number of pages that can be created depends on the type of VT being used (See relevant Hardware manual).

Each page has the following Attributes:

- **Page number**
  A progressive number identifying a page in the list.
- **Name of page**
  A name indicating the function of a page so that it can be easily recognized.
- **Refresh time**
  This is the time which elapses between one read of the information by the device and the next.
- **Page help**
  Supplementary information of help to the user and visible on the VT.
- **Edit mode**
  Allows the user to access automatic setting of the field following the one currently being set (applicable only to VTs with keyboard).

A list follows of the elements that can be inserted in a page:

- Multilanguage label
- Numeric field
- ASCII field
- Dynamic text field
- Bar field
- Symbolic field
- Mobile symbolic field
- Hour/Date field
- Trend
- Touch button
- Line
- Rectangle
- Ellipse
- Arc
- Bitmap image

⚠ **These elements have been listed in the same order as they appear in the VTWIN menu.**
A **Multilanguage label** is a series of characters referred to as a String, whose definition together with the textual information contained in it is in the language that has been selected.

The field **Multilanguage label** cannot be displayed with a transparent background.

A **Multilanguage label** field can be displayed in Reverse (the background and foreground colors are inverted).

The minimum resolution for positioning the label depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel
- Text terminals -> 1 character

The field **Multilanguage Label** can have assigned to it any of the fonts in that language (see “Chapter 6 -> Project language”).

More simply, the **Multilanguage label** can be defined as a text that can be displayed automatically in the language selected in the project.

When the F12 is pressed while in the edit phase a chart appears showing the characters belonging to the font in use.

All textual information contained in a project has, for each language configured (see “Chapter 6 -> Project language”) a string of characters that defines how such information should be represented. From now on all textual information of this type is called a Multilanguage text, while the string of characters is called the **Translation**.

For each Multilanguage text you have to define a number of **Translations** equal to the number of languages configured using the project. (Below we show how to introduce these translations).

Example.

In a page dedicated to plant pressure control a multilanguage label has been defined that says what the page deals with and which functions as the title of the page.

In Italian this label corresponds to the text “PRESSIONE”, while in English it corresponds to the text “PRESSURE”.

---

**Multilanguage label**

**Multilanguage text**
Numerical field

A **Numerical Field** is defined as one permitting the representation of a variable in a numerical format.

**Numerical Fields** are dynamic fields relating to a numerical variable.

**Numerical Fields** can be represented in binary, decimal, hexadecimal and floating point formats.

**Numerical Field** can be displayed with a transparent background.

A **Numerical field** can be displayed in Reverse (the background and foreground colors are inverted).

A **Numerical Field has a Threshold** parameter, making it possible to change the background and/or foreground colors using variables in the connected device.

The minimum resolution for positioning the field depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel
- Text terminals -> 1 character
Numerical fields have various parameters that have to be compiled; some of these are obligatory (✱), while others depend on what the user needs to have represented. The parameters are as follows:

- **General options.**

  - **Name:**
    
    Name defining the field. It is advisable to assign a name that helps the programmer recognize it and its contents.

  - **Comment:**
    
    A comment can be assigned. If possible it should be the full explanation of the function of the field and its contents, but it can also be an alphanumeric character sequence.

  - **Source:**
    
    The origin can be determined of a variable on the device or a data memory variable or another kind of variable. (See Page 4-34 -> “Variables”).

  - **Variable (✱):**
    
    This is the Leading zeros variable to which the field relates.

  - **Leading zeros:**
    
    This parameter determines whether always to display the number of digits defined or not to display the significant digits if their value is equal to zero.

    **Example.**

    Number of digits set = 6, value of data 100.

    - ![Leading zeros](✓) Display format: 000100
    - ![Leading zeros](☐) Display format: 100

  - **Visible digits:**
    
    This is the number of digits to be displayed. Usually the number of digits is chosen on the basis of the value that the variable can assume the value.
Example.

If the variable reaches a value of up to 9999, just set the number of digits visible at 4; if a lower number of characters (3) is set, the leftmost digit is not displayed.

Let us assume that the value is 2450; with the Visible digits parameter set at 4, the number displayed will be 2450; if, on the other hand, the Visible digits parameter is set at 3, the number displayed will be 450.

Numerical format:

You can determine whether to display the field in binary, decimal, hexadecimal or floating point.

Example.

The value of the data in binary format is 100011. The screen will show:

<table>
<thead>
<tr>
<th>Format</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary</td>
<td>100011</td>
</tr>
<tr>
<td>Decimal</td>
<td>35</td>
</tr>
<tr>
<td>Hexadecimal</td>
<td>23</td>
</tr>
</tbody>
</table>

The floating point format, as the name implies, makes it possible to display values without predetermining the position of the decimal point, this adapting itself to the value to be displayed.

The floating point format is nothing other than the representation of the result of a calculation executed within the VT using a variable (whole number) of the connected device and the linear scaling of the VT (see Page 4-37 -> “Linear scaling:“).

This format is only valid in Read mode, in Write a whole value is discarded in any case.

The floating point format is very useful when the VT has connected to it a device which does not only use whole numbers for data exchange, but also numbers in a table.

⚠️ We advise limiting the use of this function to applications like that illustrated in the following example.

Example.

Let us suppose we re connecting a device dedicated to controlling the
frequency of a motor, and that the display of this device shows the value of the frequency using a non-whole number (0.125Hz), but in reality the frequency value is a whole number (1Hz). In other words, the device carries out a multiplication between the real value and 0.125.

To achieve the same kind of data display on the VT terminal, just set the linear correction as follows:

Minimum on terminal (on display) = 0.125  
Maximum on terminal (on display) = 1250  
Minimum in device = 1  
Minimum in device = 1000

⚠️ The possibility of setting minimum and maximum values with a decimal point depends, as far as the linear scale is concerned, on the type of VT being used (See Hardware Manual).

Truncated digits:

You can declare how many digits will not be displayed on the right side of the field (less significant digits).

Example.

The value of the data in the device is 200. Depending on the number of digits truncated, the screen will show:

0 truncated digits -> 200  
1 truncated digit -> 20  
2 truncated digits -> 2

⚠️ In the case of write data the comprehensive value of the truncated digits is sent to the device.

Truncated digits: 1  
Value set in VT: 30  
Value transferred to device: 300

Format:

This defines the way a field is represented. One or more separating characters can be inserted between the digits; all characters are accepted but only one type of character for any given format.

Separation characters are not admissible in the numerical format Floating Point.
Example.

The value of the data is 25467; the value displayed is as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>######</td>
<td>25467</td>
</tr>
<tr>
<td>###.##</td>
<td>254.67</td>
</tr>
<tr>
<td>#:##:##</td>
<td>2:54:67</td>
</tr>
</tbody>
</table>

Preview:

Shows how the field will appear on the terminal.

Mode.

Field Index:

For the sequence followed by the cursor positioning itself on the settable data. The positioning follows an ascending order, that is, from the lowest index to the highest.
The key to the order is Index - Row - Column.

Example.

We enter 16 read/write data items from DATA 1 to DATA16, and assign indices as follows:

<table>
<thead>
<tr>
<th>Data</th>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data</th>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>3</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
</tr>
<tr>
<td>11</td>
<td>5</td>
</tr>
<tr>
<td>12</td>
<td>5</td>
</tr>
<tr>
<td>13</td>
<td>6</td>
</tr>
<tr>
<td>14</td>
<td>7</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>16</td>
<td>1</td>
</tr>
</tbody>
</table>
The cursor positions will be in the following order:

Data 1-3-5 (Index 0)  Data 2-16 (Index 1)
Data 4-6-7-8 (Index 2)  Data 9 (Index 3)
Data 10-15 (Index 4)  Data 11-12 (Index 5)
Data 13 (Index 6)  Data 14 (Index 7)

Continuous read:

This parameter must be selected when you need to display the real value of a given magnitude moment by moment. When this option is chosen, the variable assigned to the field is continuously read and the field thereby continuously updated.

⚠️ Remember that the continuous read mode means that the VT is continuously engaged in sending requests to the device attached.

The interval between one request and another depends on the value set for the Refresh time (See Page 4-3 -> “Refresh time“) and is the same for all the fields in the page.

Example.

You need to control a plant with magnitudes that vary continually: temperature measurements, pressure measurements, numbers of products, the position of a trolley etc. To have the information displayed correctly you need to select continuous read.
One-shot read:

This parameter must be chosen only when there is no need to show the real value of a given measurement moment by moment. When this option is chosen, the variable assigned to the field is read only once; the read occurs when the page containing the field assigned to this variable is displayed.

Example.

If a page contains fields that are not conditionable by the plant process (see set-point settings, timer settings, etc.) the “One-shot read” mode must be used.

<table>
<thead>
<tr>
<th>Instant</th>
<th>Device</th>
<th>Display VT</th>
</tr>
</thead>
<tbody>
<tr>
<td>t0</td>
<td>123</td>
<td>123</td>
</tr>
<tr>
<td>t1</td>
<td>124</td>
<td>124</td>
</tr>
<tr>
<td>t2</td>
<td>125</td>
<td>125</td>
</tr>
</tbody>
</table>

Where t0 is the moment the page is first displayed.

Modify field enabled:

This parameter determines whether the field should be read only or read/write. With a read/write field a device variable can be set using the VT.

Bit-wise protection:

This function is valid only for settable fields, that is, for read/write fields. Using this parameter it can be established whether the field is write-protected, that is, whether or not its value can be varied using the VT. Usually this facility is used to protect important data in the device connected from the risk of overwriting it with wrong values introduced by unauthorized personnel, or to stop the value being changed as a result of a particular situation within the production process. The protection mechanism functions by setting the bit assigned to the value 0 to make it possible to change the data and to the value 1 if the data is to remain unmodifiable. It is the job of the device connected to manage the protection bits using the command area. (See Page 4-42 -> “Exchange areas”).
Bit number:

It is possible to decide which bit will function as field protection.

Example.

Let us take 4 fields, for the sake of simplicity numbered from 1 to 4; we assign protection bit number 0 to fields 1 and 2, bit number 1 to field 3 and no protection to field 4.

Field 4 is always modifiable as it is never subject to protection.

Password:

This makes it possible to assign a level of protection to the field, linked to the introduction of a security code. (See “Chapter 6 -> Password”)

Threshold.

Type:

This allows you to assign the type of threshold required: none, single or double.

Example.

Suppose we wish to display the temperature value of a blast furnace in a steelworks such that the color of the temperature displayed changes as its value changes, specifically: black when the tempera-
ture is normal (0-2000°C), yellow when the temperature is too high (2001-2500°C) and red when the temperature level is critical (> 2501 °C); the background should be white in all cases. To achieve this the type to be chosen is “double threshold”, which makes it possible to set the variable for controlling the color.

Source:

See Numerical Field Page 4-6.

Variabile (✤):

See Numerical Field Page 4-6.

Threshold:

This allows you to assign the threshold value beyond which the foreground and/or background colors should change. The thresholds intervene when the value of the variable is greater than the value set.

Example.

Basing ourselves on the preceding example (Page 4-12 -> “Type:“), the values to be set are: threshold #1: 2000, threshold #2: 2500.

Foreground:

This allows you to assign the threshold value beyond which the foreground and/or background colors should change. The thresholds intervene when the value of the variable is greater than the value set.

Example.

Basing ourselves on the preceding example (Page 4-12 -> “Type:“), the values to be set are: threshold #1: 2000, threshold #2: 2500.

Background:

This allows you to assign the background colors for the numerical data to coincide with the change in the value of the threshold variable.

Example.

Basing ourselves on the same example (Page 4-12 -> “Type:“) the color to be set to obtain the desired effect is white for the first, second and third areas.
An ASCII Field is defined as one permitting the representation of a variable in alphanumeric format.

ASCII Fields are dynamic fields relating to a string variable.

ASCII Fields can be represented only in ASCII format.

An ASCII Field cannot be displayed with a transparent background.

An ASCII Field can be displayed in Reverse (with background and foreground colors inverted).

A ASCII Field has a Threshold parameter, making it possible to change the background and/or foreground colors using variables in the connected device.

The minimum resolution for positioning the label depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel
- Text terminals -> 1 character

The ASCII Field can have assigned to it any of the fonts in that language (see “Chapter 6 -> Project language”).

ASCII Fields have various parameters that have to be compiled; some of these are obligatory (❖), while others depend on the representation needs of the user. The parameters are as follows.

- General options.
  - Name:
    
    See Numerical Field Page 4-6.
  
  - Comment:
    
    See Numerical Field Page 4-6.
Source:

See Numerical Field Page 4-6.

Variable (✤):

See Numerical Field Page 4-6.

Length:

The length of the string or, more simply, the number of characters in the field can be determined.

Format:

The format corresponding to the Length is shown in characters.

Example.

<table>
<thead>
<tr>
<th>Length</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>$$$$$$$$$$</td>
</tr>
</tbody>
</table>

Preview:

See Numerical Field Page 4-9.

Mode

Field Index:

See Numerical Field Page 4-9.

Continuous read:

See Numerical Field Page 4-10.

One-shot read:

See Numerical Field Page 4-11.

Modify field enabled:

See Numerical Field Page 4-11.

Bit-wise protection:

See Numerical Field Page 4-11.
Bit number:

See Numerical Field Page 4-12.

Password:

See Numerical Field Page 4-12.

Threshold.

Type:

See Numerical Field Page 4-12.

Source:

See Numerical Field Page 4-13.

Variable (✤):

See Numerical Field Page 4-13.

Threshold:

See Numerical Field Page 4-13.

Foreground:

See Numerical Field Page 4-13.

Background:

See Numerical Field Page 4-13.

Preview:

See Numerical Field Page 4-14.

A **Dynamic Text Field** is that field which permits the representation of binary data in a text format.

A **Dynamic Text Field** is a dynamic field that relates to a numerical variable. Text is displayed by interpreting the value of a variable or the state of one or more of its bits corresponding to a text list. (See Page 4-70 -> “Text Lists”).
The text list corresponding to the variable could contain more elements than the variable itself can represent.

If the value of the variable corresponding to the text list does not identify a valid text, a series of [!] characters appears on the display.

A **Dynamic Text Field** cannot be displayed with a transparent background.

A **Dynamic Text Field** can be displayed in Reverse (with background and foreground colors inverted).

A **Dynamic Text Field** has a **Threshold** parameter, making it possible to change the background and/or foreground colors using variables in the connected device.

The minimum resolution for positioning the field depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel
- Text terminals -> 1 character

A **Dynamic Text Field** can be linked to a list in three different ways:

- Assigned to the numerical value of a given variable
- Assigned to a single bit of a given variable
- Assigned to a group of bits of a given variable

**Assigned to the numerical value of a given variable:**

The value (in binary or BCD) of the variable assigned to the text list is used to determine which text to display. The value 0 is **inadmissible**.

**Example.**

Take a list of 8 texts (from Text 1 to Text 8). If the value of the variable assigned to the list is 5, then Text 5 will appear on the display; if the variable has a value of 8, then Text 8 will appear, while if the variable has a value over 8 the display will show [!!!!!!!]. In the case of a read/write Dynamic Text field, then setting Text 3 would write the value 3 to the variable.

**Assigned to a single bit of a given variable:**

Only one bit of the variable assigned to the text list is used to determine which text to display. If the field is settable, updating the bit
within the variable modifies also changes the state of the bits not involved.

⚠️ It is advisable to use different variables for each dynamic text within the same page.

Example.

Take a list of 8 texts (from Text 1 to Text 8) and relate to it bit 0 of the assigned variable; when the state of the bit is 0 the display shows Text 1, when the state of the bit is 1 Text 2 is displayed. The texts from Text 3 to Text 8 are not handled. In the case of a read/write dynamic field, setting Text 1 would reset the bit assigned within the variable; if Text 2 is set the bit assigned within the variable is set. All the other non-involved bits are reset!!!

Assigned to the bit group of a given variable:

A group of bits of the variable assigned to the text is used to determine which text to display. The variable must have just one bit at 1 and all the others at 0 (with more than one bit at 1 the text assigned to the highest bit is displayed; with all bits at 0 a series of characters [ !!! ] is displayed). With a settable dynamic field, the selection and successive confirmation of a text causes the assigned bit to change from status 0 to status 1 and the remaining bits of the variable to be automatically reset. This type of dynamic field can be compared to a rotating selector with a certain number of positions, where the number of positions is the number of bits selected.

Example.

Take a list of 8 texts (from Text 1 to Text 8) and assign to it the group of bits from bit 4 to bit 11 of the variable assigned. When the status of bit 4 is 1 Text 1 appears on the display, when the status of 5 is 1 Text 2 appears and so on for all the other bits of the group. If all the bits are at 0 the display shows [ !!!!!!! ]. If, on the other hand, all the bits are at 1, the text corresponding to the value of the highest bit (Text 8) is displayed. In the case of a read/write dynamic field, the selection of Text 1 causes bit 4 of the variable to pass to logical status 1, while the choice of Text 3 would cause bit 7 to be set. All other bits not involved are set at 0!!!

A Dynamic Text field has assigned to it various parameters that have to be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are as follows.

❖ General options.
Name:

See Numerical Field Page 4-6.

Comment:

See Numerical Field Page 4-6.

Source:

See Numerical Field Page 4-6.

Variable:

See Numerical Field Page 4-6.

Text lists (✤):

It is possible to select which text list to assign to a variable.

☐ Type.

Type:

It is possible to choose the mode of assigning a dynamic text.

First bit (✤):

Indicates the first bit assigned to the list of texts in Bit Group of Single Bit mode.

Last bit:

Indicates the last bit assigned to the text list in Bit Group mode. Within the variable, this bit must be more significant than the First Bit.

☐ Mode.

Field Index:

See Numerical Field Page 4-9.

Continuous read:

See Numerical Field Page 4-10.
One-shot read:

See Numerical Field Page 4-11.

Modify field enabled:

See Numerical Field Page 4-11.

Bit-wise protection:

See Numerical Field Page 4-11.

Bit number:

See Numerical Field Page 4-12.

Password:

See Numerical Field Page 4-12.

Threshold.

Type:

See Numerical Field Page 4-12.

Source:

See Numerical Field Page 4-13.

Variable (✤):

See Numerical Field Page 4-13.

Threshold:

See Numerical Field Page 4-13.

Foreground:

See Numerical Field Page 4-13.

Background:

See Numerical Field Page 4-13.
A **Bar Field** is defined as one permitting the representation of a variable in a bar graph format.

**Bar Fields** are dynamic fields relating to a numerical variable.

**Bar Fields** can be represented in a bottom -> top, left -> right, top -> bottom or right -> left direction.

A **Bar Field** cannot be displayed with a transparent background.

A **Bar Field** can be displayed in Reverse (with background and foreground colors inverted).

A **Bar Field** has a **Threshold** parameter, making it possible to change the background and/or foreground colors using variables in the connected device.

The minimum resolution for positioning the field depends on the type of VT being used. That is:

- VT555W and VT310W -> 1 pixel
- Other graphic terminals -> 1 pixel

A **Bar Field** has various parameters that have to be compiled; some of these are obligatory (✤), while others depend on the representation needs of the user. The parameters are as follows.

☐ General options.

Name:

See Numerical Field Page 4-6.

Comment:

See Numerical Field Page 4-6.

Source:

See Numerical Field Page 4-6.
Variable (❖):  

This is the variable of the device connected to which the field relates; minimum and maximum limiting values must be assigned to this variable.

Screen:

Use this to choose how the bar is to be displayed.  
(Left -> Right, Right -> Left, Top -> Bottom, Bottom -> Top)

Field Index:

See Numerical Field Page 4-9.

☐ Mode.

Continuous read:

See Numerical Field Page 4-10.

One-shot read:

See Numerical Field Page 4-11.

Modify field enabled:

See Numerical Field Page 4-11.

Bit-wise protection:

See Numerical Field Page 4-11.

Bit number:

See Numerical Field Page 4-12.

Password:

See Numerical Field Page 4-12.

☐ Threshold.

Type:

See Numerical Field Page 4-12.
Source:

See Numerical Field Page 4-13.

Variable (✦):

See Numerical Field Page 4-13.

Threshold:

See Numerical Field Page 4-13.

Foreground:

See Numerical Field Page 4-13.

Background:

See Numerical Field Page 4-13.

Preview:

See Numerical Field Page 4-14.

Symbolic field

A Symbolic field is that field which allows the user to represent binary data as an image (dynamic bitmap). Everything we have said about Dynamic Text fields applies to this type of field, apart from the fact that if the value of the variable assigned to the list of images (see Page 4-71 -> “Lists of images”) does not identify a valid image, the display will show the word ‘ERROR’.

Even if the examples given are still conceptually valid, we should now refer to images and no longer to texts.

☐ General options.

Name:

See Numerical Field Page 4-6.

Comment:

See Numerical Field Page 4-6.
Source:

See Numerical Field Page 4-6.

Variable:

See Numerical Field Page 4-6.

Lists of images (:flex):

Allows you to select which list of images to assign to the variable.

☐ Type.

Type:

Allows you to select the how the dynamic image is to be displayed.

First bit:

See Dynamic text field Page 4-19.

Last bit:

See Dynamic text field Page 4-19.

☐ Mode.

Field Index:

See Numerical Field Page 4-9.

Continuous read:

See Numerical Field Page 4-10.

One-shot read:

See Numerical Field Page 4-11.

Modify field enabled:

See Numerical Field Page 4-11.

Bit-wise protection:

See Numerical Field Page 4-11.
Bit number:

See Numerical Field Page 4-12.

Password:

See Numerical Field Page 4-12.

A **Mobile Symbolic Field** is a field that enables you to represent binary data as images (dynamic bitmaps); in addition, using a variable in the connected device, it allows the image to be moved to an preselected by the user.

With a **Mobile Symbolic Field** there can be no transparency, so the area to which the image is moved cannot contain background images.

All explanations regarding **Dynamic Text Fields** applies equally to **Mobile Symbolic Fields**, except that if the value of the variable assigned to the list of images (see Page 4-71 -> “Lists of images“) does not identify a valid image, the screen displays the message ‘**ERROR**’.

Although the examples given are still conceptually valid, it is necessary to refer to images here and not texts.

☐ General options.

Name:

See Numerical Field Page 4-6.

Comment:

See Numerical Field Page 4-6.

Source:

See Numerical Field Page 4-6.

Variable:

See Numerical Field Page 4-6.

☐ Type.
Image list (:flexed_hand):  
You can select which list of images to assign to the variable.

Type:  
You can choose the type of dynamic image.

First bit:  
See Dynamic text field Page 4-19.

Last bit:  
See Dynamic text field Page 4-19.

Mode.

Field Index:  
See Numerical Field Page 4-9.

Continuous read:  
See Numerical Field Page 4-10.

One-shot read:  
See Numerical Field Page 4-11.

Modify field enabled:  
See Numerical Field Page 4-11.

Bit-wise protection:  
See Numerical Field Page 4-11.

Bit number:  
See Numerical Field Page 4-12.

Password:  
See Numerical Field Page 4-12.
Movement.

Movement directions:

This parameter determines the direction of the movement of the dynamic symbol: horizontally and vertically, only horizontally or only vertically.

Source (Horizontal variable):

This parameter allows you to set the origin -- either device or data memory -- of the variable for moving the image horizontally. (see Page 4-34 -> “Variables”).

Variable (Horizontal variable) (✤):

This is the variable referred to by the field.

Source (Vertical variable):

This parameter allows you to establish the origin -- either device or data memory -- of the variable for moving the image vertically. (see Page 4-34 -> “Variables”).

Variable (Vertical variable) (✤):

This is the variable referred to by the field.

Hour/Date field

The Hour/Date field is used to display the time and the date.

The Hour/Date field is a non-editable field relating to the clock and calendar inside the VT.

An Hour/Date Field cannot be displayed with a transparent background.

An Hour/Date Field can be displayed in Reverse (with background and foreground colors inverted).

The minimum resolution for positioning the field depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel
- Text terminals -> 1 character

The Hour/Date field can be displayed in the form of Time short, Time
long, Date and Day of the week.

Time short:

The time is shown in the form ##:##. This type of display exists in two different formats.

24 hour format HH:MM

HH -> 00 … 23 Hour
MM -> 00 … 59 Minutes

12 hour format HH:MMx

HH -> 01 … 12 Hour
MM -> 00 … 59 Minutes
x -> a ; p

Where [ a ] is the abbreviation of the word antemeridian which means before midday (00:00 to 11:59), while [ p ] is the abbreviation of the word post-meridian which means after midday (12:00 to 23:59).

Time long:

Conceptually this is just like Time short but allowing in addition seconds to be displayed (HH:MM:SS or HH:MM:SSx).

Date:

Is represented as ###/####. This type of display exists in two different formats.

Format DD/MM/YYYY

DD -> 01… 31 Day
MM -> 01…12 Month
YYYY -> n…2096 Year

Format MM/DD/YYYY

The same as the previous format but with the inversion of the position of DD and MM.

Day of the week:

The day of the week is displayed. This type of display exists in two
different formats.

Format 1:

Shows the days of the week in numerical format from 0 to 6 (0=Sunday … 6=Saturday).

Monday Format:

Shows the days of the week taking textual information from a list of assigned dynamic texts. The list starts from Sunday and ends with Saturday. If the list is not compiled in the way described the display of the days will be wrong.

A Trend is that field that allows a variable to be represented in graphic format, showing the pattern of the value of a variable over time. The individual graph line related to a variable’s value is called the Channel. A Trend may contain more than one channel (see Hardware Manual).

A Trend Field is a dynamic field that relates to a numerical variable.

A Trend Field can be represented in linear mode [~], one pixel point [•], an X point [X], a + point [+], X and + points [X+] and an O point [O].

A Trend Field cannot be displayed with a transparent background.

A Trend Field can be displayed in Reverse (with background and foreground colors inverted).

The minimum resolution for positioning the field depends on the type of VT being used. That is:

- VT555W, VT300W and VT310W -> 1 character
- Other graphic terminals -> 1 pixel

The Trend Field has various parameters that must be compiled; some of these are obligatory (+), while others depend on the representation needs of the user. The parameters are as follows.

Name:

See Numerical Field Page 4-6.
Comment:

See Numerical Field Page 4-6.

Channels:

It is possible to specify the number of channels to display in a trend. (Regarding the maximum number of channels see Hardware Manual). The channel called Reference channel determines the number of readings of all the channels.

Trend buffer (✦):

This allows one of the trend buffers present in the project to be assigned.

Number of samples:

Determines the number of values to be shown at the same time in the trend.

Marker type:

This determines the way the trend is displayed: linear mode [ ~ ], one pixel point [ • ], an X point [ X ], a + point [ + ], X and + points [ ✦ ] and an O point [ ◻ ].

Color (Marker type):

Determines the color for representing the channel.

Upper limit:

Allows the operator to fix the upper limit of the channel, beyond which the display is truncated (see following example).

Color (Upper limit):

 Defines the color for that part of the channel that exceeds the upper limit (see following example).

Lower limit:

Allows the operator to fix the lower limit of the channel, below which nothing is displayed (see following example).
Color (Lower limit):

Defines the color for that part of the channel that exceeds the lower limit (see following example).

Example:

Suppose we have a single-channel trend that displays the trend buffer of a variable having a value between 0 and 1024. The channel is represented using a black line, below the lower limit of the trend (fixed at a value of 128) it is green, while above the upper limit (fixed at a value of 896) it is yellow. (In the example the number of samples is omitted because it is irrelevant to the understanding of limits).

⚠️ The color change at the limits will not be visible if the variation in value between one sample and another is not such as to generate a sufficiently long segment or, alternatively, if one of the two values that might generate the segment lies on the limit.
Touch Button

A **Touch Button** is the name given to that field that permits the user to create on the screen a predefined rectangular form in which an identifying label or image can be introduced; this field can also have functions (Page 4-61 -> “Functions assignable to F and/or E keys and to touch buttons:“) or direct commands (Page 4-67 -> “Direct Commands”) assigned to it. For minimum resolution see Page 4-58 -> “Touch button”.

**Touch Buttons** have various parameters assigned to them which must be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are listed below.

Name:

See Numerical Field Page 4-6.

Comment:

See Numerical Field Page 4-6.

Project touch buttons (✤):

A button to be inserted in the page can be chosen from those in the list of touch buttons.

Line

A **Line** is an unbroken succession of pixels (points) that give rise to a linear form, so a line cannot be curved.

A **Line** is a static field and is not assigned to any variable in the device.

**Lines** can be in any direction, horizontal, vertical or oblique; the minimum
resolution needed for positioning and drawing them is 1 pixel.

A Line cannot exceed the area of display.

**Rectangle**

A Rectangle is an unbroken succession of pixels that gives rise to a quadrilateral figure.

A Rectangle is a static field and is not assigned to any variable in the device.

The minimum resolution needed for positioning and drawing a Rectangle is 1 pixel.

The dimensions of the Rectangle cannot exceed the area of display.

A Rectangle can have assigned to it an infill attribute.

**Ellipse**

An Ellipse is an unbroken succession of pixels that gives rise to a circular form.

An Ellipse is a static field and is not assigned to any variable in the device.

The minimum resolution needed for positioning and drawing an Ellipse is 1 pixel.

The dimensions of the Ellipse cannot exceed the area of display.

An Ellipse can have assigned to it an infill attribute.

**Arc**

An Arc is an unbroken succession of pixels that gives rise to a curve.

An Arc is a static field and is not assigned to any variable in the device.

An Arc can be in any direction, horizontal, vertical or oblique; the minimum resolution needed for positioning and drawing it is 1 pixel.

An Arc cannot exceed the area of display.

**Bitmap Image**

A Bitmap Image is a field relating to a graphic image.

A Bitmap Image is a static field and is not assigned to any variable in the device.
A Bitmap Image has assigned to it various parameters that must be compiled. These parameters are listed below.

Project image:

Used to insert images contained in the list of images (Page 4-71 -> “Lists of images”).

**Variables**

A **Variable** is an object allowing you to assign to a dynamic a data contained in the device connected.

There are two types of variable: one a string variable (generally used for exchanging textual information with the device) and a numerical variable (that can be of the type “fixed point” or “floating point” and is used for exchanging values).

**String variables:**

This type of variable allows the user to display a set of alphanumeric characters.

Remember that an Ascii character occupies 8 bits (1 Byte) of a register, so it is necessary to bear in mind the number of registers necessary to display the number of characters set.

**Example.**

A string variable of 8 characters is defined.

Given that each character is composed of 8 bits, 64 bits (8 bits x 8 characters) will be needed. If the register in the device connected is formed of only 16 bits, 4 registers will be necessary; if, on the other hand, the device contains 32 bit registers, 2 registers will be necessary.

**VTWIN will not check for overlaps of the addresses of the devices used for defining the variables.**

**Fixed Point or Entire Variables:**

This type of variable, as its name implies, can be represented either with the decimal point in a pre-fixed position or without a decimal point, irrespective of the value displayed.

**Example.**
Let us suppose we want to insert a variable having the format of 2 digits before the decimal point and 2 digits after it: ##.##

The values are displayed as follows:

<table>
<thead>
<tr>
<th>Value</th>
<th>Displayed form</th>
</tr>
</thead>
<tbody>
<tr>
<td>4567</td>
<td>45.67</td>
</tr>
<tr>
<td>23567</td>
<td>35.67</td>
</tr>
<tr>
<td>1000</td>
<td>10.00</td>
</tr>
<tr>
<td>53</td>
<td>00.53</td>
</tr>
</tbody>
</table>

Floating Point Variables:

This type of variable, as its name implies, can be represented with the decimal point in a non-pre-fixed position, the position varying according to the value of the data held by the device. The format accepted depends on what has been defined (4 bytes). The display resolution depends on the resolution of the calculation by the device.

The display format is decimal (123) not scientific (1.23E2).

Example.

Let us suppose that we want to insert a variable with a 6 character display format: ######

The values are displayed as follows:

<table>
<thead>
<tr>
<th>Value</th>
<th>Displayed form</th>
</tr>
</thead>
<tbody>
<tr>
<td>23567</td>
<td>23567</td>
</tr>
<tr>
<td>23567</td>
<td>2356.7</td>
</tr>
<tr>
<td>235.67</td>
<td>235.67</td>
</tr>
<tr>
<td>2.3567</td>
<td>2.3567</td>
</tr>
</tbody>
</table>

The **Variable** of a terminal can also be shared with other terminals; this means that the information contained in a device directly connected to a VT can be displayed and/or edited by other VTs too, provided they are connected in an ESA-NET network (see Hardware Manual).

The **Variable** shared in this way is called Public Variable (see “Chapter 6 -> Public data”). The maximum number of public variables per terminal is 128.

A **Variable** is referred to as a Remote Variable if declared on one terminal but belonging to another. All this is possible as long as you are in the con-
A remote variable does not exist physically until it is declared on the other terminal as well.

The remote variable is nothing other than a Public Variable used by other terminals before being declared as such (see “Chapter 6 -> Public data”).

The variable has assigned to it various parameters that must be compiled; some are mandatory (●), others depend on the representation needs of the user. The parameters are listed below.

✍ General options.

Name:

Name that defines the variable. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the variable and its meaning, but it can also be an alphanumeric character sequence.

⚠️ The comment is not given in the duplication phase of the variable.

Source:

This determines to which device to assign the variable.

Data Area:

This determines which area of the device is assigned to the variable (e.g.: Counter, Flag, Input, Output, Register, Timer). The list of data areas depends on the type of device selected.

Type:

This selection determines the display mode of the data area: Bit, Byte, Word, Dword, String, Floating point. The display mode
depends on the device selected.

Length:

This defines the number of characters making up the string and thus determines the number of bytes of the variable

VTWIN does not check for congruence between the Length of the field and the Length of the string.

With sign:

This parameter defines whether a minus sign will be shown for negative values in the display or not. Plus signs are not shown.

Example.

Four-digit variable with sign (5 digits in total): for the value 1234 the display will show 1234; for the value -1234 it will show -1234.

BCD:

Allows the content of the variable to be shown in BCD format.

Address (✤):

This field determines the address of the data chosen. The address type depends on the type of device connected.

Example.

<table>
<thead>
<tr>
<th>Data chosen</th>
<th>-&gt; Register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address allowed by the device</td>
<td>-&gt; 0-100</td>
</tr>
<tr>
<td>Address chosen</td>
<td>-&gt; 25</td>
</tr>
</tbody>
</table>

Limits and linear scaling.

Input limits:

Used to assign to the variable whether there will be an input limit or not; in the affirmative case the value of the minimum and maximum admissible limits must be defined.

Linear scaling:

Using this parameter a display value can be attributed that is different from the value actually contained in the device.
Example.

Suppose we have a variable bearing the value of an analogical input connected to a pressure transducer: the value possible run from -2048 to 2047. It is awkward to display this value because in reality the pressure read by the manometer runs from 0 to 10Bars, making it impossible for the user to establish the correct value without carrying out conversion calculations. To avoid these calculations, just set the required parameters.

In the example used the following settings have been made:

Minimum on terminal (on display) = 0
Maximum on terminal (on display) = 10
Minimum in device = -2048
Maximum in device = 2047

If these parameters are inserted the terminal can calculate a linear interpolation between the values registered by the device and those to be displayed on the terminal.

It follows from the diagram above that the value 0 registered by the device will be displayed on the terminal as 5.

Linear scaling will be active in two directions if the “Input Enabled” parameter has been selected. To set the value 2 using the terminal means writing the value 819 to the device.

In addition, Linear scaling functions as a result of extrapolation: in the example in question the value 4095 read from the device will be displayed as 20 by terminal.

A **Group of Variables** may be defined as a set of variables that can be read/written individually or as a block, either synchronously or asynchronously (for more details see HoL).

A **Group of Variables** may be also composed of public variables.

The **Group of Variables** of an adapter cannot be shared with other adapters or terminals. This means that the information contained in the group can neither be displayed nor modified even by other ADTs or VTs connected in
an ESA-NET network (see Hardware Manual).

The Group of Variables has assigned to it various parameters that have to be compiled; some of them are obligatory (♣), others depend on what the user needs to represent. The parameters in question are listed below.

Name (♣):

Name with which the group is defined. It is advisable to assign a name that makes it easy for the programmer to recognize and understand the significance of the group.

Elements of the group:

You can specify which of the declared variables must be included in the group.

Page sequences

Video pages in non-Touch Screen products must be input in a sequence to be able to be used.

⚠️ If the pages are not input in the right sequence the display must be managed by the device connected, using the command area.

A Page Sequence is defined as one or more interrelated pages. The pages are grouped logically; the purpose of sequences is to be able to display topics distributed over different pages by means of change page.

For a project to make sense there needs to be at least one page sequence defined as Start-up Sequence.

There are three ways of calling up a sequence: by assigning the command to a , by using a command from the device connected or, alternatively, as a start-up sequence when the VT is switched on.

Page Sequences on video can be classified as Start/Stop and as Random Sequences.

Start/Stop Sequences:

This type of sequence must have the Start and Stop Pages indicated. The page number of the start page must be lower than that of the stop page; not all the pages in the interval between start and stop need to be present, but at least one must be for this type of sequence to make sense. Entering the sequence, the first page displayed is that identified as the Start page, then, when a Change Page request is made, the page displayed is the one with the nearest page number. The display
order is cyclical, that is, when the last page is reached it starts from the first again and vice versa.

Example.

Imagine a Start/Stop Sequence 1-7, with pages 1 3 4 7 defined, and assuming the currently displayed page to be 4, when the Change Page request is made in one direction (up) page 7 will be displayed, in the other direction (down) the page will be 3.

Random Sequences:

In this type of sequence pages can be put in any order. There must be at least one page for this type of sequence to make sense. Entering the sequence, the first page displayed is the first page in the list, irrespective of the value of the number. The page displayed when Change Page is requested is the nearest in the page list. The display order is cyclical, that is, when the last page is reached it starts from the first again and vice versa.

Example.

Imagine a Random Sequence 9-1-5-7, and assuming the currently displayed page to be 4, when the Page Up request is made page 5 will be displayed; if the Page Dn request is made the page will be 9.

Page Sequences has assigned to it various parameters that must be compiled; some are mandatory (✪), others depend on the representation needs of the user. The parameters are listed below.

Number:

This is the identifying number of the sequence.

Name:

Name that defines the sequence. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the sequence and its meaning, but it can also be an alphanumeric character sequence.
Switch-on led:

The switching on (or not) of the green led of any of the F and/or E.

Start/Stop Sequence:

Allows this type of sequence to be selected.

Random Sequence:

Allows this type of sequence to be selected.

Start Page ( ):

Active only if Start/Stop Sequence has been selected: allows the start page of the sequence to be specified.

Stop Page ( ):

Active only if Start/Stop Sequence has been selected: allows the stop page of the sequence to be specified.

Page Selected:

Active only if Random Sequence has been selected: allows the page to be inserted in the sequence to be specified.

Memory areas

Memory area is the name given to an uninterrupted zone of memory, defined within the connected device.

Memory areas are necessary if you wish to use the Data exchange area, for example, the message area, alarm area, etc.

The Memory areas can be declared as Public and/or Remote Areas (See Page 4-34 -> “Variables“ and “Chapter 6 -> Update Public data“).

The Memory area has assigned to it various parameters that must be compiled; some are mandatory ( ), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name that defines the area. It is wise to assign a name that helps the programmer recognize it and identify its contents.
Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the area and its meaning, but it can also be an alphanumeric character sequence.

Source:

You can specify which device to assign the area to.

Data area:

The user can specify which data area of the device is to be defined. The list of data areas depends on the type of device chosen.

Length (✤):

Specifies how many elements should make up the memory area.

⚠️ The length always refers 16bit registers.

Address (✤):

This field is used to define the address of the data chosen. The address type depends on the type of device connected.

Example.

<table>
<thead>
<tr>
<th>Data chosen</th>
<th>Register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address allowed by the device</td>
<td>0-100</td>
</tr>
<tr>
<td>Address chosen</td>
<td>25</td>
</tr>
</tbody>
</table>

Exchange areas

The device exchanges information with the VT by means of variables used separately in different pages or by using the Exchange Areas.

The Exchange areas are structures containing information; which type of information depends on the model of VT being used and relate to the device connected.

These areas are exchanged periodically with the device. Conceptually these areas can be divided into read areas and write areas. The read areas are updated with the expiry of a time set by the programmer and are divided into a Message Area and a Command Area, the latter being in turn subdivided into:
• External leds command area (Fixed light)
• External leds command area (Blinking light)
• Internal red leds command area (Fixed light)
• Internal red leds command area (Blinking light)
• Internal green leds command area (Fixed light)
• Internal green leds command area (Blinking light)
• Function command area

![It is easier to manage the leds using the leds command areas.](image)

The write area updates the device connected only when there is a change of status of area in the VT; this area is called the **Status Area** and is divided into:

• Terminal status area (exchanged every 3-5 seconds independently of the variation in its status)
• Internal status area
• External status area
• Internal status area (Real Time)
• External status area (Real Time)
• Internal led status area
• External led status area
• Recipe status area
• Printer command status area
• Command response status area
• Trend status area

![The detailed significance of the various words and commands depend on the type of VT being used; thus for information not given here, see relevant Hardware Manual.](image)

**Message area:**

This area is used by the VT to acquire events occurring in the plant and detected by the device (e.g. a photocell has been intercepted, a thermal protection device has intervened).

The message area can be assigned directly either to the device’s input area or its data area.

It is the message area that defines the registers for controlling the **Information** and **Alarm messages** (See Page 4-53 -> “Information Messages” and Page 4-55 -> “Alarms”); the length in words of the areas depends on the VT being used.
Command area:

This area is used by the device connected to make the VT carry out certain functions and/or commands.

External leds command area (fixed light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>EXTERNAL LED COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>EXTERNAL LED COMMAND</td>
</tr>
</tbody>
</table>

External leds command area (blinking light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>EXTERNAL LED COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>EXTERNAL LED COMMAND</td>
</tr>
</tbody>
</table>

Internal red leds command area (fixed light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>INTERNAL RED LED COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>INTERNAL RED LED COMMAND</td>
</tr>
</tbody>
</table>

Internal red leds command area (blinking light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>INTERNAL RED LED COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>INTERNAL RED LED COMMAND</td>
</tr>
</tbody>
</table>

Internal green leds command area (fixed light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).
Internal green leds command area (blinking light):

This area consists of 2 words in binary code that define which led is to be commanded (0 = off, 1 = on).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>INTERNAL GREEN LED COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>INTERNAL GREEN LED COMMAND</td>
</tr>
</tbody>
</table>

Function command area:

This area is composed of 4 fixed words (numbered from 0 to 3). Word 0 defines the command that the VT has to carry out, words 1 to 3 serve as parameter words. The functions and/or commands are contained in the VT and are identified by a numerical code and by parameters.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>PARAMETER 1</td>
</tr>
<tr>
<td>2</td>
<td>PARAMETER 2</td>
</tr>
<tr>
<td>3</td>
<td>PARAMETER 3</td>
</tr>
</tbody>
</table>

To make the VT carry out an action, the device must first prepare the parameters related to the action by writing them in the appropriate word, then write the code for the action in the corresponding word.

⚠️ **The parameter words must be written first to ensure that there are no losses of information.**

Seeing that the VT is aware of having to carry out an action when it finds a value other than 0 in word 0, writing the parameters after the command you risk a situation where the VT reads the 4 words before the device has read all the parameters. The consequence would be that data is lost or a wrong action is carried out.

At this point, finding a value other than 0 in the command word, the VT realizes that the device is making a request and so reads the 4 words, then it interprets the command, carries it out and sets the command word back to 0.

The device must interpret this resetting as meaning that another command can be sent.
The status area of the terminal is used to monitor what is happening between the VT and the device.

An example.

You want to set the date in the VT as 27 September 1997. First of all you need to determine the command to use on the basis of the list of commands set out in the relevant Hardware Manual: this is command no. 17.

COMMAND “17”: SETDATE

The command SETDATE has 2 parameters and produces an updating of the VT’s calendar in line with the data sent by the device. The command does not need a response. The format of the command sent by the device is as follows:

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>SETDATE</td>
</tr>
<tr>
<td>1</td>
<td>GG MMM</td>
</tr>
<tr>
<td>2</td>
<td>AAA AA</td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>

Where:
GG = day (in BCD)
MMM = month (in BCD)
AAAA = year (in BCD, 4 digits)

First of all, the necessary parameters are set:

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>27 09</td>
</tr>
<tr>
<td>2</td>
<td>19 97</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
</tr>
</tbody>
</table>

After entering the parameters we write the command code:

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>17</td>
</tr>
<tr>
<td>1</td>
<td>27 09</td>
</tr>
<tr>
<td>2</td>
<td>19 97</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
</tr>
</tbody>
</table>

The VT reads the words, executes the command and puts the
command word back to 0 to indicate to the device that the operation has been completed.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>STATUS WORD</td>
</tr>
<tr>
<td>1</td>
<td>SEQUENCE IDENTIFIER</td>
</tr>
<tr>
<td>2</td>
<td>PAGE IDENTIFICATION</td>
</tr>
<tr>
<td>3</td>
<td>FIELD IDENTIFIER</td>
</tr>
</tbody>
</table>

Status area:

This area is used by the VT to inform the device of any change that has occurred in the operational status of the VT or in response to a request command coming from the device connected. The VT writes each area the moment there is any change in the information contained in it.

Status area of terminal:

This area consists of 4 fixed words (numbered 0 to 3). Word 0 is coded in binary and defines the status of the VT; word 1 contains the sequence number that appears on the display if the active context is that of Project pages; word 2 contains the page number that appears on the display if the active context is that of Project pages; word 3 is in binary and contains the active context of the VT in the event that Project pages is not active.

Example.

As in the previous case, the user wants to set the VT date at 27 September 1997. First of all, the user must determine which command to use: this command is 17.

See Page 4-46 -> “COMMAND “17”: SETDATE“
Let us suppose that the device writes the wrong command code (for example 170) in the command word.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>170</td>
</tr>
<tr>
<td>1</td>
<td>27 09</td>
</tr>
<tr>
<td>2</td>
<td>19 97</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
</tr>
</tbody>
</table>

The VT reads the words, realizes that the command code is wrong and sets the corresponding words in the status area in the following manner.

<table>
<thead>
<tr>
<th>COMMAND AREA</th>
<th>STATUS AREA</th>
</tr>
</thead>
<tbody>
<tr>
<td>WORD NUMBER</td>
<td>WORD NAME</td>
</tr>
<tr>
<td>170</td>
<td>00000000000010000</td>
</tr>
<tr>
<td>27 09</td>
<td>N.U.</td>
</tr>
<tr>
<td>19 97</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0000000000000001</td>
</tr>
</tbody>
</table>

Bit 4 of the STATUS WORD is put at 1 to indicate that the command has not been carried out: the device, interpreting this diagnostic data, must conclude that the previous command has not been successfully executed and that the command must be repeated sending the correct code.

Status area for internal LEDs:

This area is composed of 4 words. These words are in binary code and define the status of the LEDs. The area is exchanged with the device the moment there is any change in the information contained in it.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>GREEN LED STATUS WORD</td>
</tr>
<tr>
<td>1</td>
<td>GREEN LED STATUS WORD</td>
</tr>
<tr>
<td>2</td>
<td>RED LED STATUS WORD</td>
</tr>
<tr>
<td>3</td>
<td>RED LED STATUS WORD</td>
</tr>
</tbody>
</table>

Status area for external LEDs:

This area is composed of 2 words. These words are in binary code and define the status of the LEDs. The area is exchanged with the
device the moment there is any change in the information contained in it.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>STATUS WORD</td>
</tr>
<tr>
<td>1</td>
<td>STATUS WORD</td>
</tr>
</tbody>
</table>

Status area for recipes:

This area is composed of 1 fixed word. This word is in binary code and defines the status of the recipe transmission carried out by active synchronized transfer. (See “Chapter 6 -> Synchronized recipe transmission:”).

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>RECIPES STATUS WORD</td>
</tr>
</tbody>
</table>

Status area for internal keys:

This area is composed of 6 words. These words are in binary code and define the status of the pressed keys. The entire area is exchanged with the device when a key is pressed.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>1</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>2</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>3</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>4</td>
<td>FUNCTION KEYS STATUS</td>
</tr>
<tr>
<td>5</td>
<td>FUNCTION KEYS STATUS</td>
</tr>
</tbody>
</table>

⚠️ If more than two keys are pressed simultaneously, the VT no longer perceives the change of state and the area is thus not updated.

The operative keys status area is updated with the bit corresponding to the last key pressed, while the functional keys status area is updated with both bits.

Status area for external keys:

This area is composed of 2 words. These words are in binary code and define the status of the pressed keys. The entire area is exchanged with the device when a key is pressed.
If more than two keys are pressed simultaneously, the VT no longer perceives the change of state and the area is thus not updated.

The status area for external keys is updated with both bits.

Status area for internal keys (Real Time):

This area is composed of 6 words. These words are in binary code and define the status of the pressed. The area is exchanged with the device when a is pressed or released.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>1</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>2</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>3</td>
<td>OPERATIVE KEYS STATUS</td>
</tr>
<tr>
<td>4</td>
<td>FUNCTIONAL KEYS STATUS</td>
</tr>
<tr>
<td>5</td>
<td>FUNCTIONAL KEYS STATUS</td>
</tr>
</tbody>
</table>

If more than two keys are pressed simultaneously, the VT no longer perceives the change of state and the area is thus not updated.

The operative keys status area is updated with the bit corresponding to the last key pressed, while the functional keys status area is updated with both bits.

Status area for external keys (Real Time):

This area is composed of 2 words. These words are in binary code and define the status of the pressed. The area is exchanged with the device when a is pressed or released.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>EXTERNAL KEYS STATUS</td>
</tr>
<tr>
<td>1</td>
<td>EXTERNAL KEYS STATUS</td>
</tr>
</tbody>
</table>

If more than two keys are pressed simultaneously, the VT no longer perceives the change of state and the area is thus not updated.
not updated. The above is not relevant if the driver with I/O extension is used (for example, VT160W I/O); in this case all the keys can be pressed simultaneously.

The status area for external keys is updated with both bits, or, in the case of a driver with an I/O extension with all the bits of the keys pressed.

Printer status area:

This area is composed of 2 words. These words are in binary code and define the status of the printer connected. The area is exchanged with the device when there is at least one variation in it. The area is sent to the device before confirming the active print command.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>ASP STATUS</td>
</tr>
<tr>
<td>1</td>
<td>LPT STATUS</td>
</tr>
</tbody>
</table>

Trend status area:

This area is composed of 1 word. These words are in binary code and define the status of the trend. The area is exchanged with the device when there is at least one variation in it.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>TREND STATUS</td>
</tr>
</tbody>
</table>

Command response area:

This area is composed of 4 fixed words. (numbered from 0 to 3). Word 0 defines the command that the VT must execute, word 1 to 3 are identified as parameter words.

<table>
<thead>
<tr>
<th>WORD NUMBER</th>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>COMMAND</td>
</tr>
<tr>
<td>1</td>
<td>PARAMETER 1</td>
</tr>
<tr>
<td>2</td>
<td>PARAMETER 2</td>
</tr>
<tr>
<td>3</td>
<td>PARAMETER 3</td>
</tr>
</tbody>
</table>

Example:

If you want to ask the VT the time, the appropriate command to use is no. 14.
(To understand how to give a command to the VT see example Page 4-46 -> “COMMAND “17”: SETDATE”).

The VT clock indicates 13:26:35.

Once the command has been executed the VT answers to the question

```
COMMAND AREA

<table>
<thead>
<tr>
<th>NAME OF WORD</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>14</td>
<td></td>
</tr>
</tbody>
</table>
```

```
COMMAND RESPONSE AREA

<table>
<thead>
<tr>
<th>NAME OF WORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>14</td>
</tr>
<tr>
<td>13 26 35</td>
</tr>
</tbody>
</table>
```

Each *Exchange area* has associated to it several parameters that must be compiled; some of them are mandatory (✶), others depend on the user’s needs. They are as follows:

**Enabled:**

Activates the data exchange. (Compiling the registers does not automatically activate the data exchange).

**Name:**

The name is that which defines the area. It is advisable to assign a name that makes it easier for the programmer to recognize and understand its significance.

**Type of data area:**

Used to choose which area of the list is to be configured.

**Refresh time:**

This determines the time that must elapse between one update of the exchange information and another.

**Source:**

The user can define which device to assign the data exchange area to.
Memory area:

One of the available memory areas can be assigned.

Information Messages are texts displayed when the device registers an event and communicates it to the VT using the message input area (See Page 4-43 -> “Message area:”). The VT prepares a display context appropriate for messages.

An Information Message can contain a Message Field (See Page 4-54 -> “Information Message field:“): this permits the numerical display of the magnitude that has triggered the event of the message. Depending on the model being used, the date and time of the arrival of the message can be given too.

Information Messages can be displayed using any of the project fonts.

When required, the messages can be displayed in rotation automatically (See “Chapter 6 -> Automatic scrolling:“), otherwise the scrolling requires the appropriate (See relevant Hardware Manual); the display order of the messages is chronological, that is, in order of arrival.

Information Messages have assigned to them various parameters that must be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name defining the message. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the sequence and its meaning, but it can also be an alphanumeric character sequence.

Exchange area (✤):

Used to assign the data exchange area. (See Page 4-42 -> “Exchange areas“).

Bit number (✤):

Indicates the bit to which the information message should be related. (The message is activated when the bit specified is put at status 1).
(See Page 4-42 -> “Exchange areas“).

ค่าใช้ Message.

Message (✧):

The message to be displayed is edited.

Dimension:

This enables you to establish the size of the character used to display the message.

Preview:

Shows what the message will look like on the display of the VT.

Information message field.

Information Message field:

With this you can assign the numerical variable to be displayed, which contains the value of the measurement that has activated the message.

Example.

Safety pressure exceeded.

4000

Help message.

Help Message:

Use this to edit the text of the help page.

Font:

Used to choose the font assigned to the language in which the text is displayed.

Preview:

Shows what the help page will look like on the display of the VT.

Alarm help button.
Go to page number:

Makes it possible to call up a page by pushing a button.

Button label:

Used to label the □ used to call up a page assigned to it.

Preview:

Shows what the button will look like on the display of the VT.

Print options.

Print Message:

The Information Message is printed as it arrives.

**Alarms**

*Alarms* are texts displayed when the device registers an event and communicates it to the VT using the alarm input area (See Page 4-43 -> “Message area:”). The VT prepares a display context appropriate for alarms.

*Alarms* function in accordance with ISA-1A norms that require the operator to acknowledge the alarm before deactivating it.

An *Alarm* can contain an Alarm Field (See Page 4-57 -> “Alarm field:”): this permits the numerical display of the value that has triggered the event of the message.

When displaying alarms, the VT, besides displaying the descriptive message, gives the date and time for the received event, the departed event and the acknowledged event. Display modes vary with the model of terminal used. If the size of the display permits, all this information is shown in the same page, otherwise more than one page is used.

The *Alarms* have a history file containing the events that have occurred and giving, when set, the date and time of reception [ > ], acknowledgment [ # ] and departure [ < ]. The character in square brackets indicates how these are represented on screen.

Once the history buffer is full, new alarms are no longer added until it is emptied. (See Page 4-43 -> “Message area:“).

The events stored in the history buffer can be displayed in chronological order from the most recent to the earliest or viceversa. (See “Chapter 6 -> Ordering alarm buffer starting from most recent alarm:“). The number of alarms depends on the type of VT. (See Hardware Manual).
If the dimensions of the display allow, the date and time are given in the same page as the alarm, otherwise on further pages.

An *Alarm* can be displayed in any project font. When required the alarms can be displayed automatically in rotation (see “Chapter 6 -> Automatic scrolling:”), otherwise they are scrolled using the appropriate (see relevant Hardware Manual); the alarms are displayed in chronological order.

Any alarm can have a related Help Page.

As with *Alarms* the related Help Pages can be displayed in any project font. A Help page can recall a project page when a is pressed bearing a label defined by the user (Touch Screen models only).

The *Alarms* have assigned to them various parameters that must be compiled; some are mandatory ( ), others depend on the representation needs of the user. The parameters are listed below.

**Name:**

Name defining the alarm. It is wise to assign a name that helps the programmer recognize it and identify its contents.

**Comment:**

A comment can be assigned which, if possible, should be a complete explanation of the function of the alarm and its meaning, but it can also be an alphanumeric character sequence.

**Exchange area ( ):**

Used to assign the data exchange area. (See Page 4-42 -> “Exchange areas”).

**Bit number ( ):**

Indicates the bit to which the alarm must relate. (The alarm is activated when the bit specified is put at 1).

(See Page 4-42 -> “Exchange areas”).

☐ Alarm.

**Alarm ( ):**

The alarm to be displayed is edited.
Dimension:

Used to establish the size of the character with which to display the alarm.

Preview:

Shows what the alarm will look like on the display of the VT.

☐ Alarm field.

Alarm field:

With this you can assign the numerical variable to be displayed, which contains the value of the measurement that has activated the message.

Example.

Safety pressure exceeded.
4000

☐ Alarm help.

Alarm Help:

Used to edit the Help Page text.

Font:

Use this for choosing the font with which to display the text.

Preview:

Shows what the Help Page will look like on the display of the VT.

☐ Alarm help button.

Go to page number:

Allows a page to be called up by pressing a button.

Button label:

Allows you label the ☐ used to call up the page assigned to it.
Preview:

Shows what the button will look like on the display of the VT.

Print options.

Print alarm:

The alarm is printed as it arrives.

Insert in history buffer:

Used to insert the alarm in the alarm history buffer.

**Touch button**

A *Touch Button* is the name given to that field that permits the user to create on the screen a predefined rectangular form in which an identifying label or image can be introduced; this field can also have functions and/or commands assigned to it.

The minimum dimension for a *Touch button* is one key-space.

A key-space is the minimum dimension and/or the minimum distance in pixels between one *Touch button* and another. This dimension depends on the type of VT and is one of the characteristics of the touch screen used. (See Hardware Manual - Technical characteristics of Touch screens).

A *Touch Button* has a *Threshold* parameter, making it possible to change the background and/or foreground colors using variables in the connected device, in addition to making it possible to hide and/or disable the button.

The minimum dimension required for inserting a text in a *Touch button* with a surround is:

- VT555W -> 2x2 key-sizes
- VT565W -> 2x3 key-sizes
- VT585W -> 2x3 key-sizes

A password level can be assigned to a *Touch Button*.

*Touch Buttons* have assigned to them various parameters that must be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are listed below.

General options.
Name:

Name defining the button. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the message and its meaning, but it can also be an alphanumeric character sequence.

Password:

See Numerical Field “Chapter 6 -> Password“.

Preview:

Used to see what the button will look like.

Border:

Used to specify whether the border of the button is to be displayed.

Width:

The width of the button is specified.

Height:

The height of the button is specified.

Function:

One of the functions listed below can be assigned to the touch button. (See Page 4-61 -> “Functions assignable to F and/or E keys and to touch buttons:“)

Definition of function (%):

Specifies the operational mode of the function selected.

Example. If the function “macro” is chosen, the parameter allows you to establish which macro to activate.
Object:

Further sub-list in the specified function.

☐ Button label.

Button label (знак):

Used to insert a multilanguage label identifying the button.

☐ Background image.

Background image:

Used to insert a background image identifying the button.

Fit button:

Used to automatically adapt the dimensions of the image to those of the button. The proportions of the image can be altered if required.

☐ Threshold variable.

Source:

See Numerical Field Page 4-13.

Variable (знак):

See Numerical Field Page 4-13.

☐ Threshold.

Type:

See Numerical Field Page 4-12.

Threshold:

See Numerical Field Page 4-13.

Foreground:

See Numerical Field Page 4-13.
Background:

See Numerical Field Page 4-13.

Image:

Used to assign the images for displaying the background of the button to change in line with the value of the threshold variable.

Hide:

Used to make the button invisible and inactive.

Disable:

Used to make the button inactive but still visible.

Preview:

See Numerical Field Page 4-14.

For non-touch screen models F and certain E. Functions can be assigned to the F and/or E and as in the case of touch buttons functions can be assigned. F and E are configurable using Page > Definition of internal keys and Page > Definition of external keys (see “Chapter 6 -> Internal keys definition”), or else by clicking directly on the of the page of VTWIN displayed in the foreground.

Functions assignable to F and/or E keys and to touch buttons:

The following functions are not assignable to any device variable but perform predefined tasks.

None:

No local function attributed, therefore use global configuration.

Disable key:

Disables the .

Sequence:

Used to call up the assigned sequence.
Go to page:

Used to call up a defined page from amongst those contained in the project.

Macro:

Used to assign a macro to a specified button. (See Page 4-78).

Internal Command: PASSWORD - Modify password

This is used to edit all the passwords, displaying for this a series of appropriate pages. (See “Chapter 6 -> Password”)

Internal Command: PASSWORD - Login password

Used to enter the mode for setting the password relating to the entire project. If the password inserted is contained in the list of VT passwords, then access is given to data protected by passwords of a lower level; alternatively, if the password is wrong a message is displayed and you remain on the same level as before. (See “Chapter 6 -> Password”)

Example.

Given that there are 10 levels of password from 0 (supervisor) to 9 and assuming a page containing 10 items of data each protected by a password such that Data item 1 -> Level 0 and Data item 10 -> Level 9, if the password corresponding to level 4 is inserted at the time of the login request, you will have the possibility of editing data items 5 to 10, while if you try to edit a higher level a data item with a higher level of password a new password is requested.

Internal Command: PASSWORD - Logout password

Used to restore the original level of the password, annulling the function of login password. If the logout page has been defined, after the user’s confirmation response to the system’s message, the VT passes to the defined page. (See “Chapter 6 -> Password”)

Internal Command: PIPELINE - Run pipeline

Enables you to have the specified pipeline executed. (See Page 4-79 -> “Pipelines”).
Internal Command: PRINT - Hardcopy

Used to print out what appears on the display.

Internal Command: PRINT - Print alarm history

Used to print history buffer of alarms.

Internal Command: PRINT - Printer form feed

Causes a sheet to be expelled from the printer whether it is fully printed, partly printed or completely blank.

Internal Command: PRINT - Put total sheet number to 0

Used to reset all the counters of printed pages.

Internal Command: PROJECT - Change language

Use this to change the current project language, substituting one of those declared. The new language remains active even after a new start-up until the language is changed again. (Except in the case of VT50-VT60)

Internal Command: PROJECT - Clear trend buffer

Used to reset to zero the values acquired in whatever mode. (See Page 4-88 -> "Trend buffer").

Internal Command: PROJECT - Display page directory

This displays a system page with all the pages of the project listed. From this page can be selected the page to be displayed.

Internal Command: PROJECT - Display project information

This displays the project information page.

Internal Command: PROJECT - Display sequence directory

This displays a system page with a list of all the sequences programmed. From this page can be selected the sequence to be called up.

Internal Command: PROJECT - Next Page

Used to call up the first page found with a higher number than
the one displayed. (It does not need to be consecutive).

Internal Command: PROJECT - Page Help

Used to call up Page Help.

Internal Command: PROJECT - Previous Page

Used to call up the first page found with a lower number than
the one displayed. (It does not need to be consecutive).

Internal Command: PROJECT - Quit project

Allows you to exit from project and then enter the program-
ning page.

Internal Command: PROJECT - Read trend sample

Used to acquire a reading of the channel(s) of all the trends
defined with the mode Single Sample on Command. (See Page
4-29 -> “Trend”).

Internal Command: PROJECT - Read trend block

Used to acquire an entire block of readings saved in the device
connected, being readings of all the trends defined with mode
Block of Readings on Command. (See Page 4-29 -> “Trend”).

Internal Command: PROJECT - Service Page

Used to call up the status page of the drive; from this point on
it is possible, by pressing the allotted button, to enter programming
mode; from this page you can accede to the contrast control,
and the regulation can be effected by pressing the same option
then using the arrow-up and arrow-down buttons. When this
has been done, all the settings can be saved using the appro-
priate button. If, on the other hand, the date and time are pressed,
you enter date and time setting mode by means of the appro-
priate button.

Internal Command: PROJECT - Show alarms history

Allows the alarm buffer to be shown on the display.

Internal Command: PROJECT - Start trend

Used to start the reading of the channel(s) of all the trends
defined with the mode Single automatic sample. The VT setting is active reading. (See Page 4-29 -> “Trend”).

Internal Command: PROJECT - Stop trend

Used to stop the reading of the channel(s) of all the trends defined with the mode Single automatic sample. The VT setting is active reading. (See Page 4-29 -> “Trend”).

Internal Command: RECIPE - Delete recipe

Enables you to delete the recipe specified directly from the VT memory. This is a non-confirm function. If the recipe to be deleted does not exist, a message appears to inform you. (See “Chapter 6 -> Data memory structure”).

Internal Command: RECIPE - Display recipe directory

This displays a system page with all the pages in the memory listed. From this page can be selected the recipe to be displayed or transferred to the device.

Internal Command: RECIPE - Load recipe from memory

Enables you to load a recipe data from the memory of the VT and display it. (See “Chapter 6 -> Data memory structure”).

Internal Command: RECIPE - Send recipe to device

Used to transfer a recipe directly from the VT memory to the device connected. In the event that the recipe to be transferred is not in the archive, a message is displayed. (See “Chapter 6 -> Data memory structure”).
Internal Command: RECIPE - Send recipe from video buffer to device

Used to transfer the recipe being displayed on the VT to the device connected. (See “Chapter 6 -> Data memory structure”).

Internal Command: RECIPE - Save recipe from device in data memory

Use this to transfer a recipe directly from the device connected to the VT memory. If a recipe you try to save already exists the VT displays a message of confirmation for the overwrite. (See “Chapter 6 -> Data memory structure”).

Internal Command: RECIPE - Save recipe from device in the video buffer

Used to transfer a recipe directly from the device connected onto the VT display. (See “Chapter 6 -> Data memory structure”).

Internal Command: RECIPE - Save recipe in data memory

Allows a recipe on the display to be saved in the VT memory. If a recipe you try to save already exists the VT displays a message of confirmation for the overwrite. (See “Chapter 6 ->...
Data memory structure").

Set bit status permanently:

Puts a bit permanently at 1.

Resets bit permanently:

Puts a bit permanently at 0.

Sets the bit in real time:

Puts the bit at 1 as long as the □ is depressed.

Resets the bit in real time:

Puts the bit at 0 as long as the □ is depressed.

Inverts the value of the bit:

Inverts the status of a bit (from 1 -> 0 and vice versa) each time the □ key is pressed.

Value-structured direct command:

Changes the value of a given variable.

Report:

Permits the related report to be printed.

Direct Commands

Using a Direct Command the value of a variable can be changed the moment the □ assigned to the direct command is pressed. A project can have any number Direct Commands configured and these can be assigned to a button.

A Direct Command is always assigned to a numerical variable.

Direct Commands are classifiable into Bit-structured Direct Commands and Value-structured Direct Commands.
Bit-structured Direct Commands:

Bit-structured Direct Commands allow you to change a single bit of a numerical variable.

Value-structured Direct Commands:

Value-structured commands allow you to change the value of a numerical variable by means of forcing a constant or operating mathematical calculation. Value-structured direct commands affect the entire value of the assigned numerical variable. The commands that are admissible are:

ADD Command

When the □ is pressed, the value specified is added to that of the variable assigned and the result is written to the device connected.

Example.

Value of the variable 120, value specified 45. After pressing the □, the value 165 is transferred to the device.

SUBTRACT Command

When the □ is pressed, the value specified is subtracted from that of the variable assigned and the result is written to the device connected.

Example.

Value of the variable 120, value specified 45. After pressing the □, the value 75 is transferred to the device.

AND Command

When the □ is pressed an AND logical operation is performed between the decimal value specified and that of the variable assigned and the result is written to the device connected.

Example.

Value of the variable 120, converted into binary format 1111000; value specified 45, converted into binary format 101101. After pressing the □ the value 101000 is transferred to the device, converted into decimal 40.
OR Command

When the  is pressed an OR logical operation is performed between the decimal value specified and that of the variable assigned and the result is written to the device connected.

Example.

Value of the variable 120, converted into binary format 1111000; value specified 45, converted into binary format 101101. After pressing the  the value 1111101 is transferred to the device, converted into decimal 125.

XOR Command

When the  is pressed an XOR logical operation is performed between the decimal value specified and that of the variable assigned and the result is written to the device connected.

Example.

Value of the variable 120, converted into binary format 1111000; value specified 45, converted into binary format 101101. After pressing the  the value 1010101 is transferred to the device, converted into decimal 85.

SET Command

When the  is pressed the variable is overwritten with a prefixed value.

Example.

Value of variable 120, value specified 45. After pressing the  the value 45 is transferred to the device.

Direct commands have assigned to them various parameters that must be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name defining the direct command. It is wise to assign a name that helps the programmer recognize it and identify its contents.
Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the direct command and its meaning, but it can also be an alphanumeric character sequence.

Source:

Used to specify which device to assign direct commands to.

Variable (✤):

This is the variable on which the direct command operates.

Bit:

If set, the direct command is bit-structured.

Bit number (✤):

Determines the bit number of the numerical variable specified on which the direct command operates.

Value:

If set, the direct command is value-structured.

Operation:

Defines the value-structured command desired.

Value:

The value of the operand is assigned.

Text Lists

The Text Lists function is used in the project to make a symbolic text correspond to the value of a numerical variable.

The text lists serve to construct the Dynamic Texts. (See Page 4-16 -> “Dynamic Text Field“)

Each text list contains status texts that, in general, are used to indicate the operational status of a plant or a component of a plant. A text list must contain at least two texts. A text may be composed of a series of spaces. A text may appear in any project font.
Lists of Texts have assigned to them various parameters that must be compiled; some are mandatory (✦), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name defining the text list. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the text list and its meaning, but it can also be an alphanumeric character sequence.

Values:

Used to assign the value to the variable for displaying the text associated in list, in the event that this type of value-structured dynamic text is used.

Texts:

Shows the texts contained in the list.

List of texts selected (✦):

Used to edit the texts to be put on the list.

Lists of Images

The Lists of Images function is used in the project, like that for texts, to make an image correspond to the value of a numerical variable.

The image lists serve to construct the Dynamic Bitmaps.

An image list must contain at least two images.

Lists of Images have assigned to them various parameters that must be compiled; some are mandatory (✦), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name defining the image list. It is wise to assign a name that helps the programmer recognize it and identify its contents.
Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the image list and its meaning, but it can also be an alphanumeric character sequence.

Valori:

Used to assign the value to the variable for displaying the image associated in list, in the event that this type of value-structured image list is used.

Images (✤):

Shows the images contained in the list.

image selected:

Used to add images to the list.

Preview:

Displays the image to be added.

Images

Before proceeding with the explanation, it is necessary to point out that what is presented in this paragraph depends on the type of terminal being used and on its hardware revisions. (see Table 4.3 on page 77)

Project Images are graphic images used in the project to draw backgrounds or to be associated to buttons, lists of images, etc.

Project Images can be created with a graphic editing program (E.g. Paint) and may be monochromatic, scale of grey (16 greys), 16 colors or 256 colors.

Project Images with a number of colors in excess of those supported by the terminal in use are automatically resampled to reduce and adapt the colors (“dithering”).

Using “dithering” excellent results can be obtained if the number of colors of the image is reduced from 16.8 million (24bits) or 65,536 (16bits) to 256 colors. A further reduction in the number of colors may alter the image substantially.

If the terminal used does not support 256 colors, it may prove necessary to generate the images that have the correct number of colors, in order to avoid their degenerating in the importation phase.
The Palette of the monochromatic images must be made up as follows:

Bit at 1 -> White
Bit at 0 -> Black

If the settings of the gray tones of the gray scale images are not as follows, these images will not be displayed properly on the VT.

⚠️ If the image displayed on the VT has grays that are slightly different from those displayed on VTWIN, you are advised to use the contrast control on the terminal. (See Hardware Manual).

<table>
<thead>
<tr>
<th>Color in VTWIN</th>
<th>Red (R)</th>
<th>Green (G)</th>
<th>Blue (B)</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLACK</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>WHITE</td>
<td>2</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>GRAY</td>
<td>3</td>
<td>17</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>34</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>51</td>
<td>51</td>
</tr>
<tr>
<td></td>
<td>6</td>
<td>68</td>
<td>68</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>85</td>
<td>85</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>102</td>
<td>102</td>
</tr>
<tr>
<td></td>
<td>9</td>
<td>119</td>
<td>119</td>
</tr>
<tr>
<td></td>
<td>10</td>
<td>136</td>
<td>136</td>
</tr>
<tr>
<td></td>
<td>11</td>
<td>153</td>
<td>153</td>
</tr>
<tr>
<td></td>
<td>12</td>
<td>170</td>
<td>170</td>
</tr>
<tr>
<td></td>
<td>13</td>
<td>187</td>
<td>187</td>
</tr>
<tr>
<td></td>
<td>14</td>
<td>204</td>
<td>204</td>
</tr>
<tr>
<td></td>
<td>15</td>
<td>221</td>
<td>221</td>
</tr>
<tr>
<td></td>
<td>16</td>
<td>238</td>
<td>238</td>
</tr>
</tbody>
</table>

Color images must be set using DOS 16 color Palette if the program used permits; otherwise personalize the colors as follows to have the correct display on the VT.

⚠️ If the image displayed on the VT has slightly different colors from those displayed on VTWIN, we advise adjusting the contrast of the terminal. (See Hardware Manual).
The **Project Images** have a series of functions dedicated to image handling before the definitive importation into VTWIN. These functions are:

**Compression in the terminal:**

Used to transfer images to the terminal in compressed graphic format. The compression reduces a given image’s occupation of the terminal’s graphic memory by up to 55%.

⚠️ **Compression entails an increase in the refresh time of the image in the terminal of up to 3 times that necessary for a non-compressed image. Roughly speaking, between 0.5 seconds and 1.5 seconds are needed to refresh an image of 640x480 pixels.**

**Re-load:**

Updates the representation of the original image by reloading it from the source disk.

### Table 4.2: RGB setting for color matching (Mix 0 - 255)

<table>
<thead>
<tr>
<th>Color in VTWIN</th>
<th>Red (R)</th>
<th>Green (G)</th>
<th>Blue (B)</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLACK</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>WHITE</td>
<td>2</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>DARK RED</td>
<td>3</td>
<td>128</td>
<td>0</td>
</tr>
<tr>
<td>DARK GREEN</td>
<td>4</td>
<td>0</td>
<td>128</td>
</tr>
<tr>
<td>DARK YELLOW</td>
<td>5</td>
<td>128</td>
<td>128</td>
</tr>
<tr>
<td>DARK BLUE</td>
<td>6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>DARK VIOLET</td>
<td>7</td>
<td>128</td>
<td>0</td>
</tr>
<tr>
<td>DARK CYAN</td>
<td>8</td>
<td>0</td>
<td>128</td>
</tr>
<tr>
<td>DARK GRAY</td>
<td>9</td>
<td>128</td>
<td>128</td>
</tr>
<tr>
<td>LIGHT GRAY</td>
<td>10</td>
<td>192</td>
<td>192</td>
</tr>
<tr>
<td>LIGHT RED</td>
<td>11</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>LIGHT GREEN</td>
<td>12</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>LIGHT YELLOW</td>
<td>13</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>LIGHT BLUE</td>
<td>14</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>LIGHT VIOLET</td>
<td>15</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>LIGHT CYAN</td>
<td>16</td>
<td>0</td>
<td>255</td>
</tr>
</tbody>
</table>
Cut-out tool:

Allows you to select a part of the image, automatically eliminating the remaining parts.

Re-size:

Allows you to modify the dimensions of the image before it is inserted in VTWIN. This function has a number of subfunctions:

Adapt image to screen:

Allows you automatically to adapt the dimensions of an image to those of the display.

Maintain proportions:

Allows you to maintain the proportions of the image during re-sizing.

Type of resizing:

Allows you to establish which type of algorithm to use for re-sizing the image.

Dimensions:

Allows you to set the new dimensions of the image.

Zoom:

Allows you to enlarge or reduce the image being displayed.

Filters:

Allows you to apply certain filters to improve the display of the image to be imported.

*Project Images* can have their dimensions changed even after being imported into VTWIN, by selecting the image and pulling its corners (image stretching).

*Stretching entails an increase in the refresh time of the image in the terminal of up to twice that necessary to refresh a similar re-sizing in the VTWIN. Roughly speaking, between 0.5 seconds and 1.0 second are needed to refresh an image of 640x480 pixels.*
The minimum resolution for positioning *Project Images* is 1 pixel.

*Project Images* have assigned to them various parameters that must be compiled; some are mandatory (✩), others depend on the representation needs of the user. The parameters are listed below.

**Name:**

Name defining the image. It is wise to assign a name that helps the programmer recognize it and identify its contents.

**Comment:**

A comment can be assigned which, if possible, should be a complete explanation of the function of the image and its meaning, but it can also be an alphanumeric character sequence.

**File Name (✩):**

Indicates the name of the source image prior to its being imported into VTWIN.

**Directories:**

Indicates the directory on disk where the source image is located.

**List Files of Type:**

Indicates the format possible for the source image.

**Drive:**

Indicates the physical unit where the source image is located.

**Preview:**

Displays the image that is to be inserted.

The table below lists the different graphic possibilities of VTWIN associating them with the terminals and their various revision.
Table 4.3: Graphic functions correlated with hardware revisions of the VT.

<table>
<thead>
<tr>
<th>FUNCTIONS</th>
<th>VIDEO TERMINALS</th>
<th>VT 300 W</th>
<th>VT 310 W</th>
<th>VT 320 W</th>
<th>VT 330 W</th>
<th>VT 555 W</th>
<th>VT 585 W</th>
<th>VT 595 W</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rev. 1</td>
<td>Rev. 2</td>
<td>Rev. 3</td>
<td>Rev. 4</td>
<td>Rev. 1</td>
<td>Rev. 2</td>
<td>Rev. 3</td>
<td>Rev. 4</td>
</tr>
<tr>
<td>16 Colours</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>256 Colours</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Stretching image</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Compression image</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>BMP image format</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>JPG image format</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Dithering</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
</tbody>
</table>

Note: JPG, CMP, ICO, CUR, PCX, PCD, FFX, DIC, TIF, WMF, EMF, XPM, IFF, PMB, JBG, PSD, PNG, TGA, EPS, RAS, WPG, PCT.

-- : not available

⚠ Images in TIFF format must not be compressed.
Macro

This makes it possible to group together a number of internal functions and/or Direct commands to be carried out in sequence.

**Macros** are subject to the following limitations.

- The following functions and Direct commands cannot be inserted:
  - Direct command “Set bit as real time”
  - Direct command “Reset bit as real time”
  - Function “Page list”
- The function “Exit from project” can be inserted only as a last-placed function.
- The functions “Change page” and “Change sequence” can be inserted only as last-placed functions.

**Macros** have assigned to them various parameters that must be compiled; some are mandatory (✱), others depend on the representation needs of the user. The parameters are listed below.

Name:

Name defining the macro. It is wise to assign a name that helps the programmer recognize it and identify its contents.

Comment:

A comment can be assigned which, if possible, should be a complete explanation of the function of the macro and its meaning, but it can also be an alphanumeric character sequence.

Function List (✱):

Indicates the list of functions covered by the macro.

Function:

Used to choose the functions to include in the function list.
(See Page 4-61 -> “Functions assignable to F and/or E keys and to touch buttons:”).

Function Specification:

Specifies the parameter of a generic function.

Example.

If a macro function has been selected, this makes it possible to establish which macro to activate.
Object:

Further sub-list within the function specified.

Pipelines

The **Pipeline** function allows an exchange of information between the different devices via the VT.

The **Pipeline** function can be used with the devices connected to any of the serial ports available on the VT.

When the VT is switched on, the **Pipelines** are always active, each with its own mode of operation.

**Pipelines** see to the conversion of the format between source variables and destination variables using the following criteria:

- If the source variable has limits and/or mathematical correction assigned to it, these are ignored.
- If the destination variable has limits assigned, no value can be written other than those. In particular if the value to be written is lower than the lowest limit the lowest limit is written; if the value to be written is above the upper limit the upper limit is written. In all other cases the value is written without changes.
- If the destination variable has a mathematical correction assigned, this is applied before the value is written. Before writing, also check that the value is admissible within the limits (if any). If not, proceed as indicated in the previous paragraph.
- If the source variable is in word form and the destination in byte form, the value written will only be valid if the value contained in the source variable is such as to be completely containable within the byte; the sign is also counted.
- If the dimension of the destination variable is greater than that of the source variable, any value read will be correctly sent to the destination device.
- If the source variable has a sign (For example, -52) and the destination variable has no sign a 0 will be written. If, on the other hand, the source value is a positive number, the source value will be written with no variation.
- If the dimension of the source variable is greater than that of the destination variable, only that part of the value that can be contained within the destination variable is written. There follow some examples of source variables in word format, destination variables in bytes:
If the source variable is in floating point format and the destination variable is numerical only the whole numbers will be written, bearing in mind the preceding point.

If the source variable is numerical and the destination variable is in floating point format, the entire number will be written.

If the source variable is in ASCII and the destination variable is either numerical or in floating point format, the numerical equivalent of the ASCII value is written to the numerical variable. If the ASCII data is in alphabetical form, the value written to the numerical/floating point variable has no sense.

If the source variable is numerical and the destination variable is in ASCII, a string with the numerical value is written. If the length of the ASCII variable is such as not completely to contain the number, the string will contain characters that have no sense.

### Pipelines

Pipelines can be defined with the following read/write modes:

- Read and write by polling
- Read by polling and write with each change
- Read and write by command

**Read and write by polling:**

The VT reads the source variable at constant, preset time intervals (from 100ms to 10h), the write of the destination variable occurs immediately after each read.

**Read by polling and write with each change:**

The VT reads the source variable at constant, preset time intervals (from 100ms to 10h), while the writing of the destination variable only occurs if the value read from the source variable is different from the preceding one. If the value has changed the writing will take place immediately after the read.

The values read from the source variable are saved in the VT in a single buffer (see Hardware Manual) appropriate for all pipelines.

Every pipeline occupies at least 2 bytes; in the case of pipelines with string variables count 1 byte for each character with rounding up to a full word (5 characters occupy 3 words).
Read and write by command:

The VT reads a source variable and writes the associated destination variable after each internal command or by means of data exchange. (See Page 4-42 -> “Exchange areas”).

The **Pipeline** function has assigned to it various parameters that must be compiled; some are mandatory (✤), others depend on the representation needs of the user. The parameters are listed below.

- General options.
  - Number:
    - Indicates the identifying number of the pipeline.
  - Name:
    - Name defining the pipeline. It is wise to assign a name that helps the programmer recognize it and identify its contents.
  - Comment:
    - A comment can be assigned which, if possible, should be the explanation in full of the function and the meaning, but may also be an alphanumeric sequence of characters.
  - Source (source variable):
    - You can specify from which device to read the variable.
  - Variable (source variable) (✤):
    - You can specify to which variable to assign the pipeline.
  - Source (destination variable):
    - You can specify to which device to write the variable.
  - Variable (destination variable) (✤):
    - You can specify to which variable to assign the pipeline.

- Mode.
Read/write:
You can specify which mode to use.

Polling time:
Allows the time interval between one read and the next to be specified.

**Print page**
Before defining what a print page is, we have to make clear in advance that when we speak of a page we do not mean the physical sheet issuing from the printer, but an ensemble of lines that comprise “logical” page. Page counters relate to this type of page and not to physical sheets. For example, let us suppose we have a printer which uses sheets with a printable area of 80 rows; if in the definition of the page we declare that the page is composed of 40 rows, the sheet will take up 2 pages and the counter will register 2 even if physically it was all printed on one sheet.

The diagram below illustrates the relationship between a “logical” page and a physical sheet or print report.

*A Print Page* is a collection of fields that determine the aspect of the document as defined by the user and that can be sent to a printer directly connected to the VT.
Pages cannot contain graphical elements like images and drawings.

⚠️ Only text printing is possible and standard ESA fonts must be used; customized fonts can cause faulty representation in the printing.

Pages have various Attributes, namely:

• **Number**
  A progressive number identifying a page in the list.

• **Name**
  A name to define the page so as to make its function easy to recognize.

• **Uses predefined parameters**
  Used to determine whether the print parameters need to be specified in the page or whether the general parameters of the project should be accepted.

• **Rows per Page**
  Used to determine the number of printable rows per page if the predefined parameters are not used.

• **Columns per Page**
  Used to determine the number of printable columns per page if the predefined parameters are not used.

⚠️ Once the print page has been created, any change in this parameter means the user must modify all the multilanguage labels with a number of columns in excess of the number now set.

• **Left Margin**
  Used to determine the width in numbers of characters of the margin per page if the predefined parameters are not used.

⚠️ The left margin is added to the number of columns per page, thus: page width = number of columns + left margin.

All the elements that can be included in a text page can be used in a print page. (See Page 4-3 -> “Page”)

The dynamic fields inserted in a page are automatically limited to read-only fields, so it is not possible to vary data in this type of page.

Elements inserted in a print page assume new attributes called **Print Attributes** which are:

• **Next page**
  Makes it possible to go to the next page and then print the field with the attribute active.
• Bold
  Permits the field to be printed in bold.
• Underlined
  Permits the field to be printed in underline.
• Barred
  Permits the field to be printed in barred script.
• Italics
  Permits the field to be printed in italics.
• Code 1
  Configurable by the user.
• Code 2
  Configurable by the user.
• Code 3
  Configurable by the user.
• Code 4
  Configurable by the user.
• Code 5
  Configurable by the user.
• Code 6
  Configurable by the user.

These attributes are activated by selecting the object and clicking on Edit > Print Attributes

**Header and footer**

The **Header and Footer** are a collection of fields determining the aspect of the top and bottom of the page as defined by the user.

Headers and footer are assigned to a print page.

The header is printed once only at the top of the page.

The footer is printed once only at the bottom of the page.

Headers and footers **cannot** contain graphical elements like images and drawings.

When the header and footer are declared for one printer they cannot be assigned to another printer; if necessary they can be duplicated. (If assigned to the printer connected to the ASP port they cannot also be assigned to the printer connected to the LPT port.)

Header and footer have various Attributes, namely:

• Name
  Name to define the header and footer so as to make the recognition of their function easier.
- Use predefined parameters
  Makes it possible to choose whether the print parameters must be specified in the header and footer or whether to accept the general parameters of the project.
- Printer
  Use this to select the printer from among those defined in the project, to which to assign the header and footer.
- Rows per Page
  Used to determine the number of printable rows per page if the predefined parameters are not used.
- Columns per Page
  Used to determine the number of printable columns per page if the predefined parameters are not used.
- Left Margin
  Used to determine the number of characters making up the width of the left margin per page if the predefined parameters are not used.

The following objects can be put into headers and footers:

- Alarms history sheet number
- Alarms sheet number
- General sheet number
- Hardcopy sheet number
- Report sheet number
- Date/Time field
- Multilanguage label

The above-listed objects, applied to the header and footer assume the same attributes as those applied to the print page. (See Page 4-3 -> “Page”)

These objects are inserted using the Numerical Field and then selected from the list of the source variable.

Page number of alarm history file:

  Is the number of pages printed in a historic alarm buffer; it is reset to zero with each new printing.

Page number of alarms:

  Is the number of pages of alarms printed; it is reset to zero with each new printing.

General page number:

  Is the total number of pages printed; it is reset to zero each time the VT is switched on or by using the appropriate function or when the
device sends the relevant command using the command area.

Hardcopy page number:

Is the number of hardcopy pages.

Report page number:

Is the number of pages contained in a report; it is reset to zero with each new printing.

Date/Time field

See Page 4-27 -> “Hour/Date field”

Multilanguage Label

See Page 4-4 -> “Multilanguage label”

Report

Report is a function that allows the creation of a “relationship” between the single print pages to the point of forming a single document.

This function allows one of the headers and footers defined in the project to be assigned to the pages.

There is only one header and footer for any given Report.

A project may consist of more than one Report.

The same page can be part of more than one report.

Reports can be sent to only one printer (ASP or LPT).

Reports can be classified into Reports with pages in Start/Stop Sequence or in Random Sequence.

Start/Stop Sequences

For this type of sequence the first and last pages must be indicated. The number of the Start Page must be lower than the number of the Stop Page. It is not necessary for all the pages in the interval between Start and Stop to be present, but at least one must otherwise this type of sequence would not make sense.
Random Sequences:

In this type of sequence, the pages can be put in any order. At least one page must be present for this type of sequence to make sense.

*Reports* have assigned to them various parameters that must be compiled; some are mandatory (✦), others depend on the representation needs of the user. The parameters are listed below.

**Number:**

Indicates the identifying number of the report.

**Name:**

Name defining the report. It is wise to assign a name that helps the programmer recognize it and identify its contents.

**Comment:**

A comment can be assigned which, if possible, should be a complete explanation of the function of the report and its meaning, but it can also be an alphanumeric character sequence.

**Start/Stop Sequence:**

Allows this kind of sequence to be selected.

**Random Sequence:**

Allows this type of sequence to be selected.

**Start Page (✦):**

Active only if a start/stop sequence has been chosen: allows the first page in the sequence to be specified.

**Stop Page (✦):**

Active only if a start/stop sequence has been chosen: allows the last page in the sequence to be specified.

**Page selected:**

Active only if a random sequence has been chosen: allows the selection of pages in the sequence to be specified.
Use predefined settings:

Used to choose whether the print parameters must be specified in the report or whether the general parameters of the project are accepted.

Send Form-feed at the end of the page/footer:

When this box is selected the page can change even if it is not full.

Header:

With this one of the headers present in the project can be assigned to the report.

Footer:

With this one of the footers present in the project can be assigned to the report.

⚠️ A print report can contain only one header and only one footer, valid for all pages.

**Trend buffer**

With the **Trend buffer** you can assign to the channel of a trend the variable to be kept under control and represented.

The **Trend buffer** variable can be read in three modes:

- Single sampling on polling
- Single sampling on command
- Block of sampling on command

Single sampling on polling:

The VT reads the variable (acquires a sample) at regular predetermined intervals (from 500ms to 24h).

Single sampling on command:

The VT acquires the sample after each internal command or by way of the data exchange. (See Page 4-42 -> “Exchange areas“).

Block of sampling on command:

The VT reads a block of readings acquired by and saved in the connected device. It is the job of the device to acquire the readings of the variable. A sample - irrespective of the format of the memory area:
Bit, Byte, Word - occupies a minimum of 4Bytes (or 8Bytes if the memory area of the device is in DoubleWord format. This function is recommended when the variation in the value of the variable happens very quickly (>1sec.).

The values acquired are saved in the Trend buffer, a buffer inside the VT. The length of the buffer may vary, being definable according to the number of samples to be saved; each sample occupies 4Bytes, and the total quantity of memory available is related to the type of VT being used (see Hardware Manual). The greater the number of samples, the more detailed the graphic representation of the channel.

When the Trend buffer is full two procedures are possible:

- FIFO (First In - First Out)
- Ignore exceeding samples

FIFO (First In - First Out):

Using this method, the buffer, when full, automatically eliminates the samples one at a time as and when new samples arrive, starting with the first saved.

Example.

Suppose there are 10 samples. The diagram below shows how the individual samples behave within the buffer.

Ignore exceeding samples:

With this procedure, once the buffer is full, any new samples are not saved; the buffer can be emptied either by using of an internal command or by using the data exchange (See Page 4-61 -> “Functions assignable to F and/or E keys and to touch buttons:“ e Page 4-42 -> “Exchange areas“)
The *Trend buffer* function has assigned to it various parameters that must be compiled; some are mandatory (✗), others depend on the representation needs of the user. The parameters are listed below.

- General options.
  - **Number:**
    - This indicates the identifying number of the trend buffer.
  - **Name:**
    - Name defining the trend buffer. It is wise to assign a name that helps the programmer recognize it and identify its contents.
  - **Comment:**
    - A comment can be assigned that should, if possible, be a full explanation of the function and meaning, but could also be an alphanumeric character sequence.
  - **Source:**
    - It is possible to specify the device to which to assign the trend buffer.
  - variable(✗):
    - This parameter has two different meanings, depending on the sampling mode used. Using Automatic Single Sampling and Single Sampling on Command, it defines which of the device’s variables must be checked, while using Block of Readings on Command, it defines the starting variable of the block within the device in which the samples have been saved.
    - **Example.**
      - Suppose the variable VAR1 is assigned to register R100, the block in which the sample is saved will start from register R100.
  - **Mode.**
    - **Number of samples:**
      - This parameter has two different meanings, depending on the sampling mode used. Using Automatic Single Sampling and Single Sampling on Command, it defines the number of samples (and thus the area of memory occupied) to be saved in the VT at the same time,
while using Block of Readings on Command, it defines the length of the block within the device in which the samples have been saved.

Example.

Suppose we wish to define a number of samples equal to 60; using a device with 32 bit registers where each sample will occupy 8 Bytes (1 complete register), 480 Bytes (8x60) will be needed, that is, 60 registers. If the block starts from R100, it will run from R100 to R160.

Sampling mode:

The sampling mode can be specified (See Page 4-88 -> “Trend buffer”).

Polling rate:

This function allows the user to define the interval between one reading and the next.

Queue type:

The user can define how samples in excess of the length of the buffer should be treated. (See Page 4-89 -> “FIFO (First In - First Out)”).
### Chapter 5  Configurator menu in detail

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>5-2</td>
</tr>
<tr>
<td>Edit</td>
<td>5-10</td>
</tr>
<tr>
<td>Tools</td>
<td>5-10</td>
</tr>
<tr>
<td>View</td>
<td>5-11</td>
</tr>
<tr>
<td>Options</td>
<td>5-11</td>
</tr>
<tr>
<td>?</td>
<td>5-11</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 12 pages.
The menu options listed below do not function if the project under consideration is opened (using the project editor). Save and close.

**File**

*New…*

Use this to create a new project. By choosing this you automatically open the following mask:

1) Enables you to create a Single VT project.

2) Enables you to create an Adapter project.

3) Enables you to create a project in the ESA-NET network.

Select one icon or the other.

Click on Ok.

If you wish to open a recent project, select the Recent; the following mask will be displayed.

The list of available projects is displayed.

Select the one required.

Click on Ok.

**Project for Single VT:**

After selecting the icon Single VT in the above image and confirming the choice with OK, recall the project configurator mask set out below.
The parametrization masks common also to the ESA-NET network project will only be shown in the phase of the opening of the Single VT project.

1) All the devices that can be included in a project are listed.

2) The devices included in a project are listed.

A new project is always generated with a VT50; there are two ways of changing it:

a) Select the icon on the Project side, then click on Tools>Convert, and choose the VT you want in the list provided. Confirm with Ok.

b) Select the icon on the Project side, click on , then select a new VT on the Device side and drag it to the Project side.

One by one select all the devices to be connected to the VT. Drag them from the Device side to the port where they are to be connected (eg. MSP, ASP, LPT) on the Project side.

To display and/or edit the parameters of the devices and/or communication ports of a project, select the icon required and then click on Edit>Property; the masks listed below appear.
Should the device not hook up, it means that it is not support by that port.

The “Device Parameters” mask is not set out here as it varies according to the device connected.

1) The name assigned to the printer connected appears.
2) The type of printer connected appears.
3) The comment is assigned.
4) Print parameters are displayed.

Click on Attributes; the following mask appears.

(2) Name:
   Name of the code to be sent to the printer; if possible use a name that identifies its function.

(2) Activation:
   Command for activating the attribute.
(2) Deactivation:

Command for deactivating the attribute.

(2) Preview:

This allows you to personalize the form of the preview of the action commanded. This becomes useful when the personalized code has to be identified within a given context.

Define the preview.

Click on Ok.

Click on Update to confirm changes.

Click on Ok.
(1) Automatic CR/LF:

If the printer is equipped with this function, it can handle the command “new line” after a given number of columns, otherwise the VT assumes this role.

(1) Delay after CR (msec):

Time to wait until the carriage re-assumes a rest position before the VT is used to send a command or character.

(1) Timeout (msec):

Delay that elapses between one sent given by and the next.

Adapter project:

The procedure for creating this is the same as for “Single VT project”; the only difference is in the type of device to be used: not a VT but a PC plus ADT.

As already outlined, access the following mask, convert from VT to PC and connect an adapter or select the Adapter icon and confirm the choice with OK (see Page 5-2).
Now select the device to be connected to the PC and drag it onto the ADT (see Page 5-2).

**ESA-NET network project:**

After selecting the ESA-NET network icon in figure on Page 5-2, and confirmed the choice with OK, the project configurator mask shown below is recalled.

⚠️ For the parametrization masks common also to the Single VT project see Page 5-2.
Note that VTWIN automatically connects to the serial port marked to be preferred for connection to the ESA-NET network. (For the selection criteria see Hardware Manual, “Network connections”). If necessary, you can change the type of serial port to be used. The illustration below shows the connection of the VT190W within an
Select the FIELD NETWORK port of the VT; click on it; the network is now disconnected.

Select the device from the Devices side and drag it onto the FIELD NETWORK port.

Select the MSP port and click on it.

The connection with the ESA-NET network has been re-established via the MSP serial port.

To display and/or edit the parameters of the devices and/or communication ports of a project, see Single VT project Page 5-2.

1) Display the communication speed.

2) Display the type of device connected.

3) Network address assigned (different for each participant).

4) Displays the VT assigned to a given network address.

Open…

Used to call up an existing project.

Save

Used to save the currently displayed configuration on disk.
Save as…

Used to save under a different name the configurations currently being worked on.

Exit

Used to abandon VTWIN.

Edit

Properties…

Used to display and/or edit the properties (name and comment) of a VT within the project.

Edit

Used to access the project editor where it is possible to create and edit a project.

Rename

Used to re-name the project(s).

Delete

Used to delete a given project from the archive.

⚠️ The project is IRREVOCABLY deleted.

Tools

Print…

See “Chapter 10 -> Creating and printing documentation“.

Convert…

Used to convert one type of VT, contained in the project, into another (E.g. from VT170W to VT190W).

⚠️ Changing the type of VT or the type of device connected may lead to the loss of data or graphics.

Import...

Used to import a Single VT project into an ESA-NET network project and/or an Adapter project.
Export...

Used to export a Single VT project from an ESA-NET network project and/or an Adapter project.

⚠️ An Adapter project can only be used to be imported into another ESA-NET network project. It cannot be used as a single Adapter project.

View

List labels

Used to activate or deactivate the display of the labels bar.

Devices

Used to activate or deactivate the display of the devices column.

Status bar

Used to activate or deactivate the display of the status bar.

Options

VTWIN Language

Used to display the mask containing the various languages in which VTWIN can be displayed.

? Contents

Used to call up the index of all the subjects contained in the Help on Line.

Search Help For...

Used to call up a mask for finding a particular subject.

About...

Used to call up a mask where System information and Installation control can be found: the former gives information on the machine where VTWIN has been installed, the second has information on the installation of VTWIN.
Chapter 6  Editor menu in detail

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>6-2</td>
</tr>
<tr>
<td>Tools</td>
<td>6-2</td>
</tr>
<tr>
<td>Object</td>
<td>6-3</td>
</tr>
<tr>
<td>Fields</td>
<td>6-3</td>
</tr>
<tr>
<td>Edit</td>
<td>6-4</td>
</tr>
<tr>
<td>Page</td>
<td>6-4</td>
</tr>
<tr>
<td>Configure</td>
<td>6-6</td>
</tr>
<tr>
<td>Windows</td>
<td>6-26</td>
</tr>
<tr>
<td>?</td>
<td>6-26</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 26 pages.
Project

* **Update**

Used to save project being displayed on disk.

⚠️ **This function temporarily saves the information on disk; to save the project effectively everything needs to be saved using the Configurator menu** (See “Chapter 5 -> Save”).

* **Update and close**

Same function as *Update*, but together with the closure of the project.

* **Update Public data**

Used to save public data on disk making them available to other participants in the ESA-NET network.

⚠️ **This function temporarily saves the information on disk; to save the project effectively everything needs to be saved using the Configurator menu** (See “Chapter 5 -> Save”).

* **Close**

Used to quit the project currently being displayed without saving it.

Tools

* **Compile project**

See “Chapter 9 -> Compiling and transferring a project”

* **Download project**

See “Chapter 9 -> Compiling and transferring a project”

* **Font editor**

See “Chapter 12 -> Defining the fonts”

* **Backup/Restore**

Used to recover (Backup) from a VT the recipes and/or the project and to transfer (Restore) them/it to one or more panels. The files are saved on disk; the recovered files cannot be edited.
Export translations

This function allows all the texts to be translated to be exported using a VT. All this is exported using a formatted text file. This file is editable using a text editor, with the help of which the translations necessary to the project.

⚠️ To generate the file all that is needed is to have set a project language, but to assign translations you must set at least two languages (See Page 6-8).

⚠️ The reference language in the file must never be changed, otherwise the file cannot be imported.

⚠️ The exported file must then be reimported into the same project.

⚠️ In the editing phase be careful that the format of the file is not ruined, otherwise certain texts may be lost or it may become impossible to reimport the file.

⚠️ The mother tongue texts must not be changed, otherwise it will be impossible to reimport them.

Import translations

This function allows all the texts that have been previously exported using a formatted file to be imported to a VT.

⚠️ The file must be generated using the Export translations function and then modified.

⚠️ The mother tongue cannot be imported. Files exported with other projects cannot be imported.

Object

The content of this menu is explained on “Chapter 7 -> Meaning of the Configurator menu icons”, where the corresponding VTWIN icons are also shown.

Fields

The content of this menu is explained on “Chapter 7 -> Meaning of the Configurator menu icons”, where the corresponding VTWIN icons are also shown.
Edit

Setting

Used to activate changes in the properties of a selected element.

Multi-language definition

Used to edit the translations of a selected multi-language label.

The other parts of this menu are explained on “Chapter 7 -> Meaning of the Configurator menu icons”, where the corresponding VTWIN icons are also shown.

Create macro field

This allows several fields to be grouped together as if they were one. This function applies to numeric fields. To be able to create a macro field the individual component fields must be settable; the read-only fields are automatically excluded from the selection. The purpose of the macrofield is to write the fields in the device simultaneously.

An example.

Suppose we want to create a macro field composed of 3 individual fields 1-2-3; the fields 1 and 3 are writable while field 2 is read-only. If all three fields are selected then field 2 although selected will not form part of the macro field.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Macro field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field 1</td>
<td>Field 1</td>
</tr>
<tr>
<td>Field 2</td>
<td></td>
</tr>
<tr>
<td>Field 3</td>
<td>Field 3</td>
</tr>
</tbody>
</table>

Delete owner macro field

When an individual field is selected, the macro field can be broken up into its component individual fields.

Select owner macro field

When an individual field is selected, the other individual fields that form part of the same macro field are highlighted.

Page

Pages data

Used to display the cross-reference between fields and pages. The type of order can be chosen: by page or by data. While the first lists all the pages
and shows which variable is contained in them, the second lists all the variables and shows which page they are contained in.

**Internal keys definition**

Used to define the link between an F and a function, which is will be valid only for the page being displayed. This association has priority over a global reconfiguration. To define the function double-click on the desired displayed in the list. (See also “Chapter 4 -> Touch button“).

**External keys definition**

As for global internal . The external are called E .

**Copy to clipboard**

Used to save the graphic or text page being displayed in VTWIN onto the Windows clipboard so that it can later be pasted into another image editor program (e.g. Paint).

**Axes origin**

This menu contains a sub-menu set out below.

- **Set:**
  
  Used to define and display (by means of a intersecting co-ordinates) the X, Y coordinates of the zero point relative to the page’s absolute zero.

- **Reset:**
  
  Used to reset the relative zero point, setting the X, Y coordinates to coincide with the absolute zero of the page.

- **Visible:**
  
  Used to enable or disable the function Axes origin without losing the co-ordinates of the relative zero.
Configure

Password

The VT offers 10 Password levels from 0 to 9, used to restrict access to the system to a limited number of operators.

Each Password is composed of a maximum of 6 numerical characters. It is not necessary to compile the Passwords in order of level; they can be programmed at the user’s discretion (for example, level 0, 4, 9 while the others are not programmed).

Identical Passwords cannot be entered; level 0 gives the highest level of security (supervisor).

The Password has various parameters that must be compiled; some of these are obligatory (✤), others depend on what the user needs to have represented. The parameters are listed below.

Logout timeout:

This indicates the time (expressed in minutes) after which, if no ✕ has been pressed, the VT abandons the password level that has been activated. The time is the same for all levels. This parameter is enabled when the time is set to any value other than zero.

Logout page/sequence:

Identifies which page (in touch screen models) or which sequence (in non-touch-screen models) to display after carrying out the logout operation. This parameter can be enabled by entering a value in the appropriate box.

Password levels:

Used to select the level to which you wish to assign a password.

Name (✤):

The name defines the level. It is advisable to assign a name that makes it easier for the programmer to recognize and understand its significance.

Password (✤):

This is the numerical code that identifies the password. Giving the appropriate command you can change the passwords directly using the VT. (See “Chapter 4 -> Internal Command: PASS-WORD - Modify password“.)
Internal keys global definition

Used to define the association between F and function, that will be valid for the entire project irrespective of the page being displayed. This correspondence remains valid so long as the F are not reconfigured locally page by page, in which case the priority passes to the local reconfiguration. To define the function double-click on the desired F shown in the list. (See also “Chapter 4 -> Touch button”).

External keys global definition

As for Internal F global definition. The External F are referred to as E F.

System messages

In certain situations the various messages displayed by the VT can be changed (For example: if the password entered is incorrect, the message “Password not correct”). System messages are multi-language texts and can be translated.

Image memory area

Used to display the value of the total graphic memory of the panel being used and the value of the part currently occupied by the images; in addition it can be used to determine a posteriori whether the images contained in VTWIN are to be sent to the panel in compressed format or not. For the criterion governing the choice of compression see “Chapter 4 -> Images”.

Project information

Used to input project-related information that can be printed and/or displayed on screen.

• Created on
• Modified on
• Date of last compilation
• Created using VTWIN version
• Version of firmware necessary

The F listed below can be set by the user:

• Name of project
• Version of project
• Author
• Company
• Comment
$Project$ language

As already mentioned, VTWIN makes it possible to create multilanguage projects. This means that with an appropriate command the display of a given project on screen will change in accordance with the language chosen. The language change occurs provided that the user has defined the languages into which the project must be translated.

The first language in the list is taken as the mother tongue (M.-t.), that is the language in which things are normally displayed. If the project languages are not set, the project is treated as monolingual and it will not be possible to assign any translation and the display will always be in the mother tongue (M.-t.).

The various languages can be displayed using different fonts, that is with different graphical attributes from the characters themselves.

Two families of characters are available: the first uses VTWIN-native fonts (we will continue to call these native fonts); the second, to create an font image in VTWIN, uses as a point of departure the fonts contained in Windows (we shall call these Windows-based fonts).

Native fonts alone have the advantage of being customizable by the user (see “Chapter 12 -> Defining the fonts”) but their resolution is low, whereas Windows-based fonts have the advantage of both high visual quality and an extensive range of fonts.

Windows-based fonts can only be fonts of 256 characters; fonts with a higher number of characters cannot be supported.

Families of fonts cannot be mixed in a project: either only native fonts are used or only Windows-based fonts.

The number of characters that can be written using Windows-based fonts does not depend on the type of terminal (see Hardware Manual) but rather on the dimensions of the font used. Two different types of font may have different lengths even with the same dimensions and number of characters.

Example.

In a VT585W a multilanguage label can contain up to 80 characters (using native fonts). Given that a character occupies 8x16 pixels, the area occu-
pied is 8 pixels by 80 characters (640 pixels) wide and 16 pixels by 1 row (16 pixels) high. Using the same criterion, a similar calculation can be made for all terminals.

⚠️ With Windows-based fonts functions X1, X2 and X4 have no effect.

In accordance with the type of VT used, VTWIN creates a list of the fonts it has available.

The number of fonts depends on the type of panel used and on the family of fonts chosen. Up to 4 different fonts can be chosen with text panels using native fonts (Windows-based ones are not supported); for graphic panels see the following table.

<table>
<thead>
<tr>
<th>Table 6.1: Fonts correlated to the hardware revisions of the VT with which they can be used.</th>
</tr>
</thead>
<tbody>
<tr>
<td>FONTS</td>
</tr>
<tr>
<td>VIDEO TERMINALS</td>
</tr>
<tr>
<td>Rev. 1</td>
</tr>
<tr>
<td>Native</td>
</tr>
<tr>
<td>Windows-based</td>
</tr>
</tbody>
</table>

Note:
1 - Limited by memory

The fonts chosen become the active project fonts and can be used for editing texts in various languages. If no font is selected, the font used is that imposed by the system itself.

Example:

Let us suppose that our intention is to create a project in three languages (Language 1 to Language 3) and that the VT in use allows you to use the 10 fonts listed in the table below (the fonts used in the example have no relation to those really in existence).
Table 6.2: Font.

<table>
<thead>
<tr>
<th>Fonts available</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>System font</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 1</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 2</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 3</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 4</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 5</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 6</td>
<td>ABχΔ αβχδ 1234</td>
</tr>
<tr>
<td>Font 7</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 8</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Font 9</td>
<td>ABχΔ αβχδ 1234</td>
</tr>
<tr>
<td>Font 10</td>
<td>ABCD abcd 1234</td>
</tr>
</tbody>
</table>

We now assign 4 project fonts

<table>
<thead>
<tr>
<th>Fonts available</th>
<th>Project fonts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font 1</td>
<td>Font 1</td>
</tr>
<tr>
<td>Font 2</td>
<td></td>
</tr>
<tr>
<td>Font 3</td>
<td>Font 6</td>
</tr>
<tr>
<td>Font 4</td>
<td></td>
</tr>
<tr>
<td>Font 5</td>
<td>Font 10</td>
</tr>
<tr>
<td>Font 6</td>
<td>Font 6</td>
</tr>
<tr>
<td>Font 7</td>
<td>Font 7</td>
</tr>
<tr>
<td>Font 8</td>
<td></td>
</tr>
<tr>
<td>Font 9</td>
<td></td>
</tr>
<tr>
<td>Font 10</td>
<td>Font 10</td>
</tr>
</tbody>
</table>

We now assign project fonts to the various languages using a different order each time:

<table>
<thead>
<tr>
<th>Lang. 1 (M.-t.)</th>
<th>Project font</th>
<th>Language font</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Font 1</td>
<td>Font 1</td>
</tr>
<tr>
<td></td>
<td>Font 6</td>
<td>Font 6</td>
</tr>
<tr>
<td></td>
<td>Font 7</td>
<td>Font 7</td>
</tr>
<tr>
<td></td>
<td>Font 10</td>
<td>Font 10</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Language 2</th>
<th>Project font</th>
<th>Language font</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Font 1</td>
<td>Font 7</td>
</tr>
<tr>
<td></td>
<td>Font 6</td>
<td>Font 10</td>
</tr>
<tr>
<td></td>
<td>Font 7</td>
<td>Font 1</td>
</tr>
<tr>
<td></td>
<td>Font 10</td>
<td>Font 6</td>
</tr>
</tbody>
</table>
Note that the order of the font varies with the language: this is very important, because the association between the fonts and the various languages is related to its position in the list.

⚠️ A variation in the order of the language fonts or the elimination of font will change what is displayed with regard to all the translations/labels in all the languages.

<table>
<thead>
<tr>
<th>1° Font</th>
<th>2° Font</th>
<th>3° Font</th>
<th>4° Font</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABCD abcd 1234</td>
<td>ABΧΔ αβχδ 1234</td>
<td>ABCD abcd 1234</td>
<td>ABCD abcd 1234</td>
</tr>
<tr>
<td>Lang. 2 -&gt; Font 2</td>
<td>Lang. 2 -&gt; Font 10</td>
<td>Lang. 2 -&gt; Font 1</td>
<td>Lang. 2 -&gt; Font 6</td>
</tr>
<tr>
<td>ABCD abcd 1234</td>
<td>ABCD abcd 1234</td>
<td>ABCD abcd 1234</td>
<td>ABΧΔ αβχδ 1234</td>
</tr>
<tr>
<td>Lang. 3 -&gt; Font 1</td>
<td>Lang. 3 -&gt; Font 10</td>
<td>Lang. 3 -&gt; Font 6</td>
<td>Lang. 3 -&gt; System font</td>
</tr>
<tr>
<td>ABCD abcd 1234</td>
<td>ABCD abcd 1234</td>
<td>ABΧΔ αβχδ 1234</td>
<td>ABCD abcd 1234</td>
</tr>
</tbody>
</table>

The mother tongue can be changed at any time by moving one of the languages to the head of the list.

The languages have associated to them various parameters that must be compiled (✤); some are mandatory, others depend on the user’s needs. The parameters are those listed below.
Language (✤):

Displays the languages in which the project can be displayed. the first on the list, as already mentioned, is considered to be the mother tongue.

Language fonts (✤):

Used to add project fonts. This parameter has other functions, which we list below:

Type of font:

Used to choose the family of font, native or Windows-based.

Project fonts:

Used to create the list of project fonts.

Available fonts:

Displays the fonts that can be used as project fonts.

Preview:

Displays the form of the font selected.

Project fonts:

Used to assign the font to the language to be displayed.

Project settings

The general project settings listed below can be entered in this menu.

☐ General options.

   Edit-mode idle timeout:

   This indicates the time the terminal will remain idle in edit-mode before returning to display mode.

   Start up sequence:

   This indicates the first sequence to be displayed on switching on.
Start page:

This indicates the first page to be displayed on switching on.

Beep when screen/key is pressed:

Used to enable an acoustic signal when the Touch Screen or a (with keyboard models) is pressed.

Enable screen saver:

The CCFL backlit display lamp of the VT automatically switches off after a given period; to switch on again touch the Touch Screen display or (in the case of keyboard models) a.

Screen saver delay:

Determines the time after which the display lamp automatically goes off, if the screen saver has been activated.

Alarms.

Automatic change of context:

Used to move automatically into the alarms display page when an alarm is detected.

Automatic scrolling:

All the alarms present are displayed automatically in rotation.

Autoscroll delay:

Determine the interval between displaying one alarm and the next.

Beep on new alarms:

Used to make the VT emit an acoustic signal to announce the arrival of new alarm.

Ordering alarm buffer starting from most recent alarm:

Allows the display of the events contained in the history buffer for alarms in chronological order from the most recent to the earliest.
Alarm signal position:

Used to determine where on the display the alarm signal should appear.
(Touch Screen models only).

Date format:

The user can impose the format of the date to be displayed with alarms.

Time format:

The user can impose the format of the time to be displayed with alarms.

Messages.

Automatic change of context:

Used to move automatically into the messages display page when an alarm is detected.

Automatic scrolling:

All the messages present are displayed automatically in rotation.

Message signal position:

Used to determine where on the display the message signal should appear.
(Touch Screen models only).

Date format:

The user can impose the format of the date to be displayed with messages.

Time format:

The user can impose the format of the time to be displayed with messages.

Print settings

These allow the user to configure the print parameters valid for the entire project. This is active only if a printer has been declared in the project.
The parameters must be confirmed at least once to activate them.

Printer:

Used to select a printer out of those declared in the project.

Send Form-Feed at the end of the page/footer:

When this function is enabled, the sheet is expelled even if incompletely filled.

Rows per page:

This indicates the number of rows that make up a page.

Columns per page:

This indicates the number of columns that make up a page.

Left margin:

This indicates the number of columns to leave blank starting from the left of the sheet.

Header:

Allows the user to choose one out of those declared in the project.

Footer:

Allows the user to choose one out of those declared in the project.

Use default settings:

Used to establish whether the project’s global parameters will be used or new ones entered for the specific application.
(This is contained in the Alarms/Messages, Alarm history buffer, Hardcopy, Report).

Import/Export

This menu contains a secondary menu which is set out below.

Header/Footer:

Used to import or export a header and footer into/from a project, so as to be able to use them in other projects.
Data memory structure

To explain what the data memory is it is necessary to give some examples.

Imagine we need to have a production cycle involving a range of different products. In such a case, each product differs from another because, although they have the same process parameters (ingredients), their quantities differ.

A set of parameters together with the quantities related to a given product are referred to as a Recipe. Different process parameters are called "recipe data". Let us look at an example of hot pressing.

Parameters affecting the process (ingredients):

- temperature of upper die
- temperature of lower die
- pressure at bite
- bite time

The situation is described without the aid of the data memory.

In the VT various pages (one for each product) are programmed, each of which contains the values relating to the product.

The number of bits we reserve in the device connected is equal to the number of ingredients multiplied by the total number of products.

<table>
<thead>
<tr>
<th>Device</th>
<th>VT</th>
</tr>
</thead>
<tbody>
<tr>
<td>R 100</td>
<td>lower temperature product A</td>
</tr>
<tr>
<td>R 101</td>
<td>upper temperature product A</td>
</tr>
<tr>
<td>R 102</td>
<td>pressure product A</td>
</tr>
<tr>
<td>R 103</td>
<td>time product A</td>
</tr>
<tr>
<td>R 104</td>
<td>lower temperature product B</td>
</tr>
<tr>
<td>R 105</td>
<td>upper temperature product B</td>
</tr>
<tr>
<td>R 106</td>
<td>pressure product B</td>
</tr>
<tr>
<td>R 107</td>
<td>time product B</td>
</tr>
<tr>
<td></td>
<td>.................................................................</td>
</tr>
<tr>
<td></td>
<td>.................................................................</td>
</tr>
<tr>
<td>R n</td>
<td>lower temperature product Z</td>
</tr>
<tr>
<td>R n+1</td>
<td>upper temperature product Z</td>
</tr>
<tr>
<td>R n+2</td>
<td>pressure product Z</td>
</tr>
<tr>
<td>R n+3</td>
<td>time product Z</td>
</tr>
<tr>
<td></td>
<td>.................................................................</td>
</tr>
<tr>
<td></td>
<td>.................................................................</td>
</tr>
</tbody>
</table>
Note here the considerable quantity of data memory used and a certain degree of complication in creating the program for the device used to handle the pointers for selecting on the basis of the product concerned the part of the data to refer to.

The data memory of the VT, however, enables you to save the various quantities of ingredients for each product and reduce the number of data used in the device to the same as the number of ingredients.

In the VT you can program a single page containing the data to be stored in the data memory. This data refers to the ingredients used. The association of the set of quantities of the ingredients for each product is effected via a recipe identifying code.

Access to the VT data memory is given via a special instrument called “video buffer”: the data can be displayed within the page or accessed directly by the device.

Now that we have explained the significance of the concepts data memory and recipe, we can proceed to introduce two examples; the first shows the minimum structure of a recipe, the second shows a recipe uses the extended structure.

Example of a recipe with a minimum structure.

For a recipe to have sense, it must be composed of an alphanumeric variable that unequivocally identifies it, which, as we have already see, is known as the Code (no two recipes can be introduced with the same code), and a numerical or alphanumeric variable that identifies the “ingredients” of the recipe.

The recipe code can be made up of from 2 to 40 characters.

<table>
<thead>
<tr>
<th>Code</th>
<th>-&gt; String Variable</th>
<th>-&gt; 2 - 40 Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data 1</td>
<td>-&gt; Numerical Variable or String</td>
<td>-&gt; Data</td>
</tr>
</tbody>
</table>

If the recipe code and the data are substituted with values the result is the recipe.
Example of recipe with extended structure.

(A device with 32-bit registers is used. 12 data to be displayed in decimal are inserted in the recipe.)

The recipe created in the preceding example can be completed with other elements that make it richer in information for the user and that make it possible to permit the flow of data in the course of transfer to the device.

Besides the code an alphanumeric variable for the recipe comment is introduced.

Too comment too, like the code, may be composed of from 2 to 40 characters.

A recipe can contain the date and the time, in BCD format, of the last edit (only if the VT used has a clock and calendar), the checksum or control sum (calculated by taking the binary sum of all the bytes making up the recipe structure, excluding the checksum) and the number of data sent.

The recipe can be transmitted in synchrony with the device (see Page 6-21).

The elements described above might not be assigned to a variable of the device, but defined only in the VT. The definition in the VT must be used only if there is no need to give the information to the connected device.

Besides the variables listed above, the number of recipe ingredients increases.

⚠️ A project may contain just one recipe structure; the maximum length depends on the type of VT (See Hardware Manual).

Example of a recipe structure.

<table>
<thead>
<tr>
<th>Code</th>
<th>String Variable</th>
<th>-&gt; 2 - 40 Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>String Variable</td>
<td>-&gt; 2 - 40 Characters</td>
</tr>
<tr>
<td>Data 1</td>
<td>Numerical Variable or String</td>
<td>-&gt; Data</td>
</tr>
<tr>
<td>Data 2</td>
<td>Numerical Variable or String</td>
<td>-&gt; Date of last edit 16Bit</td>
</tr>
<tr>
<td>Data n</td>
<td>Numerical Variable or String</td>
<td>-&gt; Time of last edit 16Bit</td>
</tr>
<tr>
<td>DD MM</td>
<td>Numerical Variable</td>
<td>-&gt; No. of data sent 16Bit</td>
</tr>
<tr>
<td>YY YY</td>
<td>Numerical Variable</td>
<td>-&gt; Checksum of data 16 Bit</td>
</tr>
<tr>
<td>HH MM</td>
<td>Numerical Variable</td>
<td>-&gt;</td>
</tr>
<tr>
<td>No. of data sent</td>
<td>Numerical Variable</td>
<td>-&gt;</td>
</tr>
<tr>
<td>CKLow CKHigh</td>
<td>Numerical Variable</td>
<td>-&gt;</td>
</tr>
</tbody>
</table>
A recipe is always made up of a fixed part and a variable part. The variable part is always that containing the data or ingredients of the recipe.

<table>
<thead>
<tr>
<th></th>
<th>Fixed part</th>
<th>Variable part</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DD MM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YY YY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>HH MM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>No. of data sent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CKLow CKHigh</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To continue with the example: the values that the various elements of the recipe can assume are inserted.

Example of Checksum calculation.

Make the binary sum of all the bytes except those of the variable containing the checksum value. The recipe code is composed of a string variable up to 20 characters.
20 characters in length; the content of this variable is COMPOSTO01, so to make the calculation you have to add up all the bytes.

**CODE**

MIX01 String Variable 20 Characters 20 x 1Byte = 20Byte

M1X01 nil nil nil nil nil nil nil nil Ascii

4D 49 58 30 31 0 0 0 0 0 0 0 0 0 0 0 0 Hex

14F -> Sum total in Hex

We proceed in the same way for the comment. The comment of the recipe is also composed of a string variable up to 20 characters in length. The content of this variable, in our example, is EXPERIMENTAL; in this case too you have to find the sum of all the bytes.

**COMMENT**

EXPERIMENTAL String Variable 20 Characters 20 x 1Byte = 20Byte

EXPERIMENTAL nil nil nil nil nil nil nil Ascii

45 58 50 45 52 49 4D 45 4E 41 4C 0 0 0 0 0 0 0 0 Hex

38E -> Sum total in Hex

We proceed with the calculation of data 1. Data 1 of the recipe is composed of a 32-bit numerical variable, the content of this variable is 10; in this case too you have to find the sum of all the bytes.

**DATA 1**

10 Numerical Variable 32 Bits 32Bit / 8Bit = 4Bytes

A 20 20 20 Hex

6A -> Sum total in Hex
The same calculation must be carried out for the entire recipe structure.

Once the total has been obtained item by item calculate the sum of all the totals.

Synchronized recipe transmission:

When you decide to send a recipe from the VT to the device, it is likely that the device will not be ready to receive the recipe, and so will need a signal from the VT to get ready to receive before transmission starts. This procedure is called Synchronized Recipe Transmission.

The synchronization is brought about by what might be called a typical “Handshake” between the VT and the device.

A “Handshake” is the creation of synchronism between two intelligent inter-connected units. It implies the step-by-step execution of certain operations. The execution of each individual step is subject to reciprocal confirmations that, if not acknowledged by both parties, make it impossible to carry out the successive steps.

The synchronized recipe transmission function is directed by bit-organized handshake.

The cross-over confirmations between the terminal and the device connected thus occur as a function of the status of certain bits present in the data exchange areas which must of necessity have been defined in the user project.

The use or otherwise of the synchronized transmission option is at the discretion of the user.

⚠️ If the synchronized recipe transmission option is NOT enabled,
the VT will ALWAYS be able to operate the recipe transmission INDEPENDENTLY of whether the device is ready or not.

Example:

An plastic injection molding plant can press out 5 different details whose process parameters are controlled by 5 recipes. The plant has two levels: MANUAL and AUTOMATIC.

With the MANUAL level the plant preset can be operated before launching the working of a given detail.

With the AUTOMATIC level working on a previously preset detail can be started.

If the synchronized transmission option has been selected, the device can be programmed so as to prevent the reception of any recipe sent by the VT terminal while the productive process is in progress (AUTOMATIC).

If, on the other hand, the synchronized transmission option has been selected, it will STILL be possible (even in AUTOMATIC mode) to send a recipe from the VT to the device; this operation could prove somewhat dangerous as we are transferring process parameters that are completely incompatible with the detail currently being worked!!!

⚠️ It is entirely at the discretion of the programmer whether to define the type of transmission on the basis of the type of plant being controlled. When the synchronization option is not selected it is the responsibility of the programmer to prepare the device in such a way as to preclude the risk of inappropriate actions on the part of the user.

Example of the Handshake for operating the synchronized recipe transmission.
Example of synchronized transmission

- **STARTTX** = bit to start transmission at 1.
- Confirm **STARTTX** = command SINCORICETTA, bit to confirm start of recipe transmission at 1.
- **ENDTX** = bit to end recipe transmission to device at 1.
- Confirm **ENDTX** = command SINCORICETTA, bit to end recipe transmission to device at 1.

Synchronized transmission involves 6 phases, starting from the moment the VT gets ready to transfer a recipe to the device. (See relevant Hardware Manual to determine the number of bits involved.)

**Phase 1:**

The VT which is in recipe status area puts the bit to start transmission at 1.

**Phase 2:**

The device realizes that the VT is ready to transmit, sends the command Synchronize recipe to the VT and puts the bit confirming the
start recipe transmission at 1. The bit is in the word parameter 1.

Phase 3:

The VT is aware of the reply by the device and puts the command word at 0 and the bit to start transmission at 0.

Phase 4:

At the end of the transmission, the VT puts at 1 the bit to end recipe transmission to the device into the recipe status area.

Phase 5:

The device registers that the VT has finished transmitting, sends the command Synchronize recipe to the VT and puts the bit for ending the transmission of the recipe to the device at 1. This bit is to be found in the word called parameter 1.

Phase 6:

The VT registers that the device has received the recipe and puts the command word at 0 and the bit for ending the transmission of the recipe to the device at 0.

If the Handshake times set out in the previous table are not respected in the course of the transfer (phases 1 to 6), the VT puts the status of the bit for the synchronized recipe transfer time-out in the recipe status area at 1. The device responds with a command SINCORRICETTA, and status of the bit for the synchronized recipe transfer time-out is set at 1 in the word parameter 1; at this point the VT sets the status of the command word and the bit at 0. The transfer has NOT been carried out.

The recipe structures have related to them system variables; this means that the value is not related to the device but is contained within the terminal.

The variables are:

- Recipes written
- Recipes remaining
- Date recipe made
- Time recipe made

These variables can be introduced by introducing a Numerical, Dynamic, Bar-value field. (See "Chapter 4 -> Numerical field")
To create a recipe structure the following parameters must be defined.

Recipe management enable:

Used to manage the recipes.

Synchronized recipe transfer:

Used to define the type of transfer.

☐ Code and comment.

Variable:

Used to define which variable, internal or related to the device, shall contain the recipe code.

Number of characters in code:

Indicates the maximum length of the recipe codes.

Comment enabled:

Used to assign a comment to a recipe.

Number of characters in comment:

Indicates the maximum length of the recipe comment.

Variable comment:

Used to determine which variable, internal or related to the device, shall contain the comment.

☐ Items.

Items:

Used to list which variables shall be contained in the recipe.

☐ Infos.

Enable hour:

Used to determine which variable, internal or related to the device, shall be assigned to the given field. (The time given is that of the last transfer).
Enable date:

Used to determine which variable, internal or related to the device, shall be assigned to the given field. (The date given is that of the last transfer).

Enable Checksum:

Used to determine which variable, internal or related to the device, shall be assigned to the given field. (See also “Chapter 6 -> Example of Checksum calculation.”)

Enable No. of Items:

Used to determine which variable, internal or related to the device, shall be assigned to the given field.

**Public data**

Used to specify which variables in the context of an ESA-NET network must be shared with the other participants in the network. Both variables and memory areas can be made public.

**Windows**

**Horizontal arrangement**

With this the active windows can be displayed horizontally.

**Vertical arrangement**

With this the active windows can be displayed vertically.

**?**

**Index**

With this you can call up the index of all the topics dealt with in the Help on Line.

**Search for help on...**

With this you can call up a mask for looking for a particular topic.

**Information about VTWIN...**

With this you can call up a mask where you can get **System information** and **Installation control**, the former allowing you to have information on the machine where VTWIN is installed, the second allowing you to get information on VTWIN installation.
Chapter 7  Using VTWIN

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terminology used</td>
<td>7-2</td>
</tr>
<tr>
<td>Forms assumed by the mouse pointer</td>
<td>7-2</td>
</tr>
<tr>
<td>Meaning of the Configurator menu icons</td>
<td>7-3</td>
</tr>
<tr>
<td>Meaning of the Editor menu icons</td>
<td>7-4</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 8 pages.
Terminology used

We offer below an explanation of the operational terms used in the document.

Click: Press a key of the mouse once and then release it.
   (If not otherwise stated, this is the left key of the mouse.)

Double click: Press the left key of the mouse twice in rapid succession.
   (If not otherwise stated, this is the left key of the mouse)

Select: Move the pointer of the mouse so that it is over an object and click.

Drag: Select an object, press the left key of the mouse, keep it pressed down and move the object to the point desired, then release the key.

Forms assumed by the mouse pointer

The pointer of the mouse assumes various forms which depend on the operation being carried out.

- Normal form of the pointer.
- Pointer on “hold”: operation still being carried out.
- Operation in background: more than one operation going on at the same time.
The table lists all the icons of the menu together with their meanings. Some of the functions listed below only affect a field that has been selected.

Table 7.1: List of Configurator menu icons, respective pulldown menus and meanings

<table>
<thead>
<tr>
<th>Tools Bar</th>
<th>Pulldown Menu</th>
<th>Action</th>
<th>Selection Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; New</td>
<td>File &gt; New Menu</td>
<td>Creates a new project (configuration).</td>
<td>--</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td>File &gt; Open Menu</td>
<td>Opens an existing project (configuration).</td>
<td>--</td>
</tr>
<tr>
<td>File &gt; Save</td>
<td>File &gt; Save Menu</td>
<td>Saves a project (configuration) on disk.</td>
<td>--</td>
</tr>
<tr>
<td>Tools &gt; Print…</td>
<td>Tools &gt; Print… Menu</td>
<td>Prints the project.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Delete</td>
<td>Edit &gt; Delete Menu</td>
<td>Deletes object selected in configuration.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Property</td>
<td>Edit &gt; Property Menu</td>
<td>Modifies the property of a project (name and comment).</td>
<td>Yes</td>
</tr>
<tr>
<td>--</td>
<td>--</td>
<td>Used to connect a VT to an ESA-NET network.</td>
<td>Yes</td>
</tr>
<tr>
<td>--</td>
<td>--</td>
<td>Used to disconnect a VT from an ESA-NET network</td>
<td>Yes</td>
</tr>
<tr>
<td>? &gt; Summary and index</td>
<td>? &gt; Summary and index Menu</td>
<td>Calls up the Help on line.</td>
<td>--</td>
</tr>
</tbody>
</table>

-- Option not valid for this menu
Meaning of the Editor menu icons

The table lists all the icons of the menu together with their meanings.

Some of the functions listed below only affect a field that has been selected.

Table 7.2: List of Editor menu icons, respective pulldown menus and meanings (Part 1 of 4)

<table>
<thead>
<tr>
<th>Tools Bar</th>
<th>Pulldown Menu</th>
<th>Action</th>
<th>Selection Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Update</td>
<td></td>
<td>Saves project being displayed onto disk.</td>
<td>--</td>
</tr>
<tr>
<td>Tools &gt; Project compilation</td>
<td></td>
<td>Used to compile the project.</td>
<td>--</td>
</tr>
<tr>
<td>Tools &gt; Project transmission</td>
<td></td>
<td>Used to transfer the project to the panel.</td>
<td>--</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td></td>
<td>Saves a selection in the notes and deletes the object selected from the page.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td></td>
<td>Saves a selection in the notes.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td></td>
<td>Inserts a selection from the notes into the page.</td>
<td>No</td>
</tr>
<tr>
<td>Edit &gt; Delete</td>
<td></td>
<td>Deletes the object selected from the page.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Erase all</td>
<td></td>
<td>Deletes all the objects in the page.</td>
<td>No</td>
</tr>
<tr>
<td>Edit &gt; Duplicate</td>
<td></td>
<td>Duplicates the object selected.</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit &gt; Build library</td>
<td></td>
<td>Saves a selection in a file on disk.</td>
<td>Yes</td>
</tr>
<tr>
<td>Object &gt; library</td>
<td></td>
<td>Inserts a library in the page.</td>
<td>No</td>
</tr>
<tr>
<td>Edit &gt; Undo</td>
<td></td>
<td>Each keystroke undoes the last action performed.</td>
<td>No</td>
</tr>
<tr>
<td>Edit &gt; Redo</td>
<td></td>
<td>Each keystroke restores the action undone.</td>
<td>No</td>
</tr>
<tr>
<td>Edit &gt; Zoom up</td>
<td></td>
<td>Increases the degree of enlargement of the page displayed.</td>
<td>No</td>
</tr>
</tbody>
</table>

-- Option not valid for this menu
<table>
<thead>
<tr>
<th>Tools Bar</th>
<th>Pulldown Menu</th>
<th>Action</th>
<th>Selection Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>![icon]</td>
<td>Edit &gt; Zoom down</td>
<td>Decreases the degree of enlargement of the page displayed.</td>
<td>No</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Colors</td>
<td>Sets the colors of an object.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Grid</td>
<td>Assigns a given number of pixels as a minimum movement.</td>
<td>No</td>
</tr>
<tr>
<td>![icon]</td>
<td>? &gt; Index</td>
<td>Calls up the Help on line.</td>
<td>--</td>
</tr>
<tr>
<td>![icon]</td>
<td>? &gt; Search for help on…</td>
<td>Activates the “search for help” function of the help on line.</td>
<td>--</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Font choice</td>
<td>Permits a character font to be chosen from among those present in VTWIN.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Reverse</td>
<td>Displays a label in negative.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Dimension &gt; X1</td>
<td>Sets the font dimension as x1. Only for native fonts; not applicable to Windows-based fonts.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Dimension &gt; X2</td>
<td>Sets the font dimension as x2. Only for native fonts; not applicable to Windows-based fonts.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Dimension &gt; X4</td>
<td>Sets the font dimension as x4. Only for native fonts; not applicable to Windows-based fonts.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Level &gt; Top</td>
<td>Moves the object selected above any other objects.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Level &gt; Bottom</td>
<td>Moves the object selected below any other objects.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Level &gt; Up</td>
<td>Moves the object selected above the antecedent object.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Level &gt; Down</td>
<td>Moves the object selected below any preceding object.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Align &gt; Leftwards</td>
<td>Align the objects selected with the left border of the object furthest from the center of the selection.</td>
<td>Yes</td>
</tr>
<tr>
<td>![icon]</td>
<td>Edit &gt; Align &gt; Rightwards</td>
<td>Align the objects selected with the right border of the object furthest from the center of the selection.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

-- Option not valid for this menu
### Table 7.2: List of Editor menu icons, respective pulldown menus and meanings (Part 3 of 4)

<table>
<thead>
<tr>
<th>Action</th>
<th>Selection Required</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit &gt; Align &gt; Upwards</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Edit &gt; Align &gt; Downwards</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Edit &gt; Align &gt; Vertical center</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Edit &gt; Align &gt; Horizontal center</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Edit &gt; Mirror &gt; Vertical</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Edit &gt; Mirror &gt; Horizontal</strong></td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Object &gt; None</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Label</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Numeric</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Ascii</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Dynamic</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Bar</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Symbolic</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Mobile symbolic</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fields &gt; Date</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Field &gt; Trend</strong></td>
<td></td>
</tr>
</tbody>
</table>

**--** Option not valid for this menu
### Table 7.2: List of Editor menu icons, respective pulldown menus and meanings (Part 4 of 4)

<table>
<thead>
<tr>
<th>Tools Bar</th>
<th>Pulldown Menu</th>
<th>Action</th>
<th>Selection Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>🕵️‍♂️ Fields &gt; Touch button</td>
<td></td>
<td>Allows the insertion of a button.</td>
<td>--</td>
</tr>
<tr>
<td>✂️ Object &gt; Line</td>
<td></td>
<td>Permits the drawing of a line.</td>
<td>--</td>
</tr>
<tr>
<td>🕒 Object &gt; Rectangle</td>
<td></td>
<td>Permits the drawing of a rectangle and/or square.</td>
<td>--</td>
</tr>
<tr>
<td>⏰ Object &gt; Ellipse</td>
<td></td>
<td>Permits the drawing of an ellipse and/or circle.</td>
<td>--</td>
</tr>
<tr>
<td>🕒 Object &gt; Arc</td>
<td></td>
<td>Permits the drawing of an arc.</td>
<td>--</td>
</tr>
<tr>
<td>🕒 Object &gt; Bitmap image</td>
<td></td>
<td>Permits the drawing of a bitmap image.</td>
<td>--</td>
</tr>
</tbody>
</table>

-- Option not valid for this menu
Chapter 8  Creating a project with VTWIN

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating the project</td>
<td>8-3</td>
</tr>
<tr>
<td>Project information</td>
<td>8-6</td>
</tr>
<tr>
<td>Setting project languages</td>
<td>8-7</td>
</tr>
<tr>
<td>Project setup</td>
<td>8-10</td>
</tr>
<tr>
<td>Inserting variables</td>
<td>8-12</td>
</tr>
<tr>
<td>Inserting pages</td>
<td>8-13</td>
</tr>
<tr>
<td>Data exchange area</td>
<td>8-86</td>
</tr>
<tr>
<td>Information messages</td>
<td>8-87</td>
</tr>
<tr>
<td>Alarms</td>
<td>8-91</td>
</tr>
<tr>
<td>ESA-NET network</td>
<td>8-95</td>
</tr>
</tbody>
</table>

This chapter contains a total of 100 pages.
The first thing is to understand which functions the VT puts at the disposal of the user. At this point it is not necessary to know in depth how this works: it is enough to know that these functions exist.

It is extremely important to exploit the potential of the panel to the utmost, trying to avoid using the device to manage what the panel manages automatically (alarms, Start Page, etc.).

Although this seems obvious, often for a variety of reasons it is forgotten and what happens is that the operation of the VT is adapted to the project to be created, which is the worst thing that can happen.

A project must be structured and adapted to fit the VT.

This being clear, we can move on to creating the project. It is necessary to establish the graphical structure of the project, by which we mean the look of the pages and their contents, to know which variables to use and which alarms and/or messages (if any), which data exchange area to use (if necessary). It is necessary too to have defined the sequences (in the case of non-touch screen panels) and, in general, to have thought of all the elements to be included in the project.

Let us imagine that we wish to create a supervisory project for a wine producer, using a Touch Screen graphic panel connected to a SAIA PCD PLC device. Using the example of this plant, we will see how to control the temperatures and pressures; it will be necessary to control the fermentation process by means of a special page that gives complete control of the autoclaves; recipe pages will have to be created to manage the quantities of the various ingredients. There will be pages for setting temperature and pressure values for controlling the condition of the must, that is, for stopping spontaneous, “wild”, fermentation; other pages for controlling the preparation, that is the phase in which the must is prepared for fermentation. The plant will be monitored by means of alarms and messages. Passwords will be used to protect sensitive data, and the texts will be written in two languages.

Such an example will give us an opportunity of analyzing all the functions the panel offers.
Creating the project

Click on **File > New** (See “Chapter 5 -> New…“)

Select the icon Single VT.

Click on OK.

Select the icon on the Project side, then click on the **Tools>Convert**, and choose the VT you want from the list.

Confirm with OK.
CHAPTER 8
Creating a project with VTWIN

405.1200.038.2 - Rel.: 2.03 of 13/11/2000 - Only for VTWIN Ver. 3.xx

Once the parameters have been set, double-click on the VT icon on the Project side; the following mask then appears.

Rename the project by selecting the VT, then click on the Edit->Rename, and assign a new name as illustrated.

Select the device to be connected to the VT; drag it from the Device side to the MSP port on the Project side.

Select the MSP icon required, then click on the Edit->Property; the following mask then appears.

Set the communication parameters of the VT's serial port.

These must be the same as those of the device.

Click on the OK.

Once the parameters have been set, double-click on the VT icon on the Project side; the following mask then appears.
The project has now been opened.
CHAPTER 8
Creating a project with VTWIN

Project information

Click on Configure > Project information (See “Chapter 6 -> Project information”)

![Image of Project information dialog box]

Compile the required.

Click on OK.
Setting project languages

Define the languages for displaying the project on the VT panel; in this case the languages chosen are Italian (mother tongue) and English.

Click on **Configure > Project languages** (See “Chapter 6 -> Project language“)

Select the box **Language**, and insert the mother tongue of the project; digit Italian.

Click on **Add**.

Select the box **Language**, and insert the mother tongue of the project; digit Italian.

Click on **Add**.
At this point the fonts of the languages are set.

Select **Italian**.

Click on **Font...**

Select **ESA8X15 (ESA8X15)** in the Fonts available list.

Click on **Ok**.

Repeat the procedure selecting the **ESA8X15B (ESA8X15)**.

Select **ESA8X15 (ESA8X15)** from the Project fonts list.

Click on **Ok**.

Cliccare su **Ok**.
The project now contains information on the language. From now on all the masks containing comments or editable texts will be requested in translation.

Repeat this operation for English, but choose it as a Font of the language ESA8X15B(ESA8X15).

To activate the language settings, click on ☑ Ok.
Project setup

Click on `Configure > Project setup` (See “Chapter 6 - Project information”)

Fix the Edit mode idle timeout at 30 secs; the Start page will be set at 1, but first it must be generated, so we will return later to the subject of this box.

Compile as illustrated.

Click on Alarms.

Set parameters as illustrated.

Click on Messages; as in the previous mask we will set the parameters as illustrated.

To position the symbol signaling the presence of an alarm and/or message, click on ...
We will arbitrarily fix the position as illustrated.

Click on OK.

In this way all parts of the project is parameterized; now we can start to insert the elements that make up the project.
Inserting variables

You can proceed in two ways, inserting all the elements like variables, touch buttons, direct commands etc. and then inserting them in the pages, or inserting the pages and step by step creating whatever is needed.

We will choose a mixed procedure (See “Chapter 4 -> Variables”).

Select the Variables.

Click on the Add.

Assign a name to the variable so as to be able to recognize it easily in the list: TEMP.A1 Add a comment to the variable by clicking on Comment.

Click on OK, then parametrize as illustrated.

The comment should be as exhaustive as possible.

Click on Limits and Linear scaling.
Fix the input limits relating to the VT, set the linear scaling so as to be able to display the temperature correctly, converting it automatically from the value actually read.

Click on Ok.

Repeat the operations described above to insert all the variables necessary (See project offered as example).

**Inserting pages**

Select the Pages (See “Chapter 4 -> Page“).

Click on the Add.
Assign the number and name to the page, and set the Refresh delay.

Add a comment to the page by clicking on Comment.

Once the comment has been edited click on Ok. (A comment only in the mother tongue is envisaged).

To call up the window for translations click on
The text of the translations cannot be longer than the mother tongue text. If the translation should require more characters the mother tongue can be lengthened by adding spaces.

Inserting texts that need translation, this needs to be borne in mind.

Click on OK to accept the translation and turn back to the previous mask.

Given the simplicity of the function on this page no Help page exists, so all data is accepted by clicking on OK.
A blank page appears:

The various elements can be inserted at this point.
Table 8.1: Elements appearing in page no.1

<table>
<thead>
<tr>
<th>IMAGES (1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
</tr>
<tr>
<td>BOTTLE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TOUCH BUTTONS (2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPERATING MODE</td>
</tr>
<tr>
<td>EDIT</td>
</tr>
<tr>
<td>SETUP MODE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MULTILINGUAGUE LABELS (3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPUMANTIZZAZIONE PLANT</td>
</tr>
</tbody>
</table>

This page is seen when the VT is switched on and enables the user to call up the functions indicated by the buttons.
To begin with we insert the multilanguage label (See “Chapter 4 -> Multi-language label”). Click on and position the cursor on the page; edit the text and confirm.

![Translating screenshot]

Insert text and click on Ok to confirm.

The final positioning of the label takes place later.

Now the logo is put in as a bitmap image.

The image can be created with any image editor. The image must be of 16 DOS colors and not exceed the maximum dimensions of the display. It is moreover advisable to respect the display grid. (See relevant Hardware Manual).

Once the image ESA.BMP has been created, it has to be inserted into VTWIN.
To insert image, select the Images (See “Chapter 4 -> Images“).

Click on the Add.

Select image to insert and assign a name.

Click on OK.

No comment has been added given that the name is sufficiently clear.

Once the image is inserted in VTWIN, it can be inserted in the page.

Insert all the images in the list (See project offered as example).
Click on \[\text{Select image to insert in the page.}\] position pointer on the display area and click \[\text{OK}\].

Using the same method insert the image BOTTLE.

As in the case of the multilanguage label, the final positioning will be done later.

After inserting the images, insert the touch buttons (See “Chapter 4 -> Touch Button”). Click on \[\text{Add}\], position the pointer on the display area and click.
Compile the parameters as illustrated.

Click on Comment.

Edit the comment as illustrated.

Confirm with OK returning thereby to the previous mask.

Then browse the tab by clicking on Display.

Parameterize as illustrated to create a tab with a border.

Click on .
Define the colors as illustrated. Click on the Ok.

Parameterize as illustrated to create a with a border. Click on  

Insert the translation and confirm.
Using the same criteria, insert all the touch buttons (See project offered as example).

![Touch button field](image)

Select the □ that you wish to insert; in this case OPERATING MODE.

Click on □ Ok.

Using the same criteria, insert the □ EDIT and the □ SETTINGS.

When all the elements making up the page have been inserted, we can define their positions. When clicking on the element to be moved, it becomes framed by highlighted dotted line. Click on the object, keep the □ pressed down and drag the object.

To select several objects simultaneously click on the objects while holding down the □ Shift.

Continue with the insertion of page 2. Repeat the operations already described.
PAGE 2 -> Operating Page 1

This page is displayed by pressing the touch button “OPERATING MODE” in page 1 (see Page 8-17); it shows a representation of the lay-out of the production area and may be used to call up the page with the temperatures and pressures or the autoclave control page. From this page the user can return to the principal page.
To insert the clock click on ![clock icon] and, with the mouse, position the pointer somewhere in the display area and click (See “Chapter 4 -> Hour/Date field”).

Choosing to display the time in a 24 hour format, the seconds are also shown. Compile the parameters as illustrated.

Confirm with OK.

Return to the page being created. Using the method described before, move the clock to its definitive position.

From now on the definitive positioning of the object will be taken for granted and thus not mentioned again.

To insert the graphic click on ![draw icon] depending on what it is you want to draw, position the mouse on the display area, click and drag. (See “Chapter 4 -> Line” and “Chapter 4 -> Ellipse”).

Continue with inserting page 5. Pages 3 and 4 are not created but left as spares. Repeat the operations already described.
Page 5 -> Temp./Press. A1-2

This page is displayed by pressing the touch button marked “TEMP./PRESS.” in page 2; it shows the temperature and pressure values for autoclave 1 and 2, shown in numerical and bar data format. From this page the user can turn back to page 2 or to the similarly titled page related to autoclave 3 and 4.

<table>
<thead>
<tr>
<th>IMAGES</th>
<th>NUMERICAL DATA FIELD (2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
<td>TEMP. A1</td>
</tr>
<tr>
<td>TOUCH BUTTONS</td>
<td>PRESS. AUTOCLAVE 1</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 2</td>
<td>TEMP. A2</td>
</tr>
<tr>
<td>ARROW R -&gt; P6</td>
<td>PRESS. AUTOCLAVE 2</td>
</tr>
<tr>
<td>DATE/TIME FIELD</td>
<td>GRAPHIC</td>
</tr>
<tr>
<td>BAR DATA FIELD (1)</td>
<td>TEMP. A1+</td>
</tr>
<tr>
<td></td>
<td>TEMP. A1-</td>
</tr>
<tr>
<td></td>
<td>PRESS. AUTOCLAVE 1</td>
</tr>
<tr>
<td></td>
<td>TEMP. A2+</td>
</tr>
<tr>
<td></td>
<td>TEMP. A2-</td>
</tr>
<tr>
<td></td>
<td>PRESS. AUTOCLAVE 2</td>
</tr>
</tbody>
</table>
Before proceeding with further insertions, it need to make a brief aside: it will be noted that the bar data for the temperature is composed of two bars, one that runs from 0 to 40°C and the other that runs from 0 to -10°C. This is because we want to see the bar with zero as its origin with the temperature going up or down. Both bars are shown in a bottom to top direction, but the bar from 0 to -10°C is declared as a reverse bar. (See "Chapter 4 -> Bar field").

We can now proceed with the creation of the bar data from 0 to 40°C. The first thing to do is to determine what the excursion of the bar should be and draw the graduated scale with the help of the graphical functions.

Click now on , move the pointer to the 0 point on the graduated scale just drawn, click and hold down until you reach a value of 40. An arbitrary width of 12 pixels has been given.

The variable is TEMP. A1+ (See project offered as example). The setting is limited to a range running from 0 to 40°C and not the linear
scale; we therefore make use of the calculation converting from bit values from 0 to 1024 to temperature values.

Insert the negative bar at this point. Repeat the operations described above.

Assign a name to the data and the related comment.
The variable is TEMP. A1- (See project offered as example).
Only the setting is limited to from 0 to -10°C and not the linear scale; we therefore make use of the calculation converting from bit value from 0 to 1024 in temperature value.

Once this has been done, select negative bar data and declare it as reverse. To do this select the data and click on \( \text{R} \).

Now insert the pressure bar data.

The variable is PRESS. AUTOCLAVE 1 (See project offered as example).
Compile as illustrated and assign a comment.

After assigning the comment click on OK to confirm and return to the preceding figure; then browse the figure by clicking on Mode.
Once the data has been entered the colors for displaying them must be defined. Select the relevant data and click on \( \text{●} \). The following mask appears.

Now insert the numerical data. Click on \( \text{●} \), move the pointer onto the area of the display where the data is to appear. Click.
Compile as illustrated and assign the comment.

After assigning the comment click on OK to confirm and return to the preceding figure; then browse the ☰ by clicking on Mode.
Assign a Multilanguage label comment for °C; repeat this procedure for the pressure. Everything done in relation to autoclave 1 must be done for autoclave 2 as well.

Insert page 6. Two approaches are possible: repeating the operations described above, or, given the overwhelming similarity of the two pages, using the duplication function. This way a page with the same graphical content can be generated, taking advantage of the positions already assigned as well as the background graphic.

To continue duplicating go to this mask

Select as illustrated and click on Duplicate.
Thus the page is duplicated, but it is necessary to compile the comments and the page number desired. (When you duplicate the old comment is maintained and the page number is assigned by the system as the first free number, in this case the system assigns the number 3.)
This page is displayed by pressing the touch button “>” in page 5; it shows the temperature and pressure values for autoclaves 3 and 4, displayed in bar and numerical format. From this page it is possible to return to page 2 or to the similarly titled page for autoclaves 1 and 2.
PAGE 7 -> Autoclaves

Table 8.5: Elements in page no. 7

<table>
<thead>
<tr>
<th>IMAGES</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
</tr>
<tr>
<td>TOUCH BUTTONS</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 2</td>
</tr>
<tr>
<td>COMMANDS 1-2</td>
</tr>
<tr>
<td>COMMANDS 3-4</td>
</tr>
<tr>
<td>DATE/TIME FIELDS</td>
</tr>
<tr>
<td>SYMBOLIC FIELD (1)</td>
</tr>
<tr>
<td>AUTOCLAVE E/F</td>
</tr>
</tbody>
</table>

This page is displayed by pressing the touch button “AUTOCLAVES” in page 2; it gives an overview of the plant’s autoclaves and the operational status, whether or not it is automatic. In addition by pressing the touch buttons “1-2 COMMANDS” or “3-4 COMMANDS” you can go to the associated page, from which it will be possible to control the respective autoclaves. From this page it is possible to return to page 2.
Proceed inserting dynamic symbols (See “Chapter 4 -> Symbolic field”).

To do this you need to have created images and the variables to be assigned.

We take for granted that these operations have been done, given that the relevant procedure has already been described.

Go to this mask

Select as illustrated and click on Add.

Assign a name to the list.
The order of insertion is not random, but relates to the display desired: the first image is that displayed when the assigned bit is set at 0.

Insert all the lists of images (See project offered as example).
Turn to the page and click on ☐, move the pointer in the display area and click.

Compile as illustrated, then select the ☐ Type.
Compile as illustrated, then select the Mode.

Compile as illustrated. Click on OK.
Repeat the operation for all the lists of images and parametrize them as illustrated.

Complete the page with the elements that are lacking.
This page is displayed by pressing the touch button marked “1-2 COMMANDS” in page 7; using moving images, it shows the status of the autoclave.
Start with arranging the touch buttons. Once they have been arranged on the page edit the button functions, given that at the beginning they were all inserted as “Go to page”. Let us start with the touch button “INS”.

Double click on the button.

Click on □ Edit.

Choose the function from the list of functions as illustrated.
Insert the definition of the function.

Click on Add.

See “Chapter 4 -> Direct Commands”.
Insert all the Direct commands (See project offered as example).

Using the same procedure edit all the buttons in the page.

Insert the bar and numerical data as already shown. Note that the symbol ☐ is not a part of the font chosen when building the project, it must therefore be constructed (See “Chapter 12 -> Defining the fonts”).

Once created, the fonts CUST8X15 and CUST8X15B must substitute those originally selected (See Page 8-7).

Insert a multilanguage label then press the F12.
Edit the label and confirm with Ok.

Now insert the background image AUTOCLAVE BACKGROUND.

At this point we can complete image adding the parts lacking. These elements are not simple images but rather lists of dynamic images. Lists of images are used because these produce the impression of movement. To have the effect of movement a series of images in more or less rapid succession needs to be displayed. This flow of images must be managed by the connected device.
Insert the dynamic texts (See “Chapter 4 -> Dynamic Text Field”).

Click on 📚
Assign the variable related to the dynamic text, then browse the field by clicking on Type.

Insert dynamic text.
Click on Add
Assign the name and insert the first tab.

Once the name has been assigned, click on Add.
Insert all the dynamic texts (See project offered as example).

Complete the page with the touch buttons and the multilanguage labels necessary.

Insert the pages listed below.
Table 8.7: Elements in page no. 9

<table>
<thead>
<tr>
<th>IMAGES</th>
<th>COOL RIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOCLAVE - BACKGROUND</td>
<td>MIXER</td>
</tr>
<tr>
<td>TOUCH BUTTONS</td>
<td>HEATING</td>
</tr>
<tr>
<td>2 ENABLE</td>
<td>DYNAMIC FIELD</td>
</tr>
<tr>
<td>2 PREPARATION</td>
<td>AUTOCLAVE E/D</td>
</tr>
<tr>
<td>2 SPUMANTIZZA</td>
<td>AUTOCLAVE STATUS</td>
</tr>
<tr>
<td>2 CONDITIONING</td>
<td>BAR DATA FIELD</td>
</tr>
<tr>
<td>2 HEATING</td>
<td>TEMP. A2+</td>
</tr>
<tr>
<td>2 COOLING</td>
<td>TEMP. A2-</td>
</tr>
<tr>
<td>2 MIXER</td>
<td>PRESS. AUTOCLAVE 2</td>
</tr>
<tr>
<td>2 EXHAUST</td>
<td>NUMERICAL DATA FIELD</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 7</td>
<td>TEMP. A2</td>
</tr>
<tr>
<td>ARROW R -&gt; P10</td>
<td>PRESS. AUTOCLAVE 2</td>
</tr>
<tr>
<td>ARROW L -&gt; P8</td>
<td>SET TEMP. A2 PRE</td>
</tr>
<tr>
<td>SYMBOLIC FIELD</td>
<td>SET dT TEMP. A2 PRE</td>
</tr>
<tr>
<td>EXHAUST</td>
<td>SET PRES. A2 PRE</td>
</tr>
<tr>
<td>COOL LEFT</td>
<td>SET dP PRES. A2 PRE</td>
</tr>
</tbody>
</table>

As for page 8.
Table 8.8: Elements in page no. 10

<table>
<thead>
<tr>
<th>IMAGES</th>
<th>COOL RIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOCLAVE - BACKGROUND</td>
<td>MIXER</td>
</tr>
<tr>
<td>TOUCH BUTTONS</td>
<td>HEATING</td>
</tr>
<tr>
<td>3 ENABLE</td>
<td>DYNAMIC FIELDS</td>
</tr>
<tr>
<td>3 PREPARATION</td>
<td>AUTOCLAVE E/D</td>
</tr>
<tr>
<td>3 SPUMANTIZZA</td>
<td>AUTOCLAVE STATUS</td>
</tr>
<tr>
<td>3 CONDITIONING</td>
<td>BAR DATA FIELDS</td>
</tr>
<tr>
<td>3 HEATING</td>
<td>TEMP. A3+</td>
</tr>
<tr>
<td>3 COOLING</td>
<td>TEMP. A3-</td>
</tr>
<tr>
<td>3 MIXER</td>
<td>PRESS. AUTOCLAVE 3</td>
</tr>
<tr>
<td>3 EXHAUST</td>
<td>NUMERICAL DATA FIELDS</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 7</td>
<td>TEMP. A3</td>
</tr>
<tr>
<td>ARROW R -&gt; P11</td>
<td>PRESS. AUTOCLAVE 3</td>
</tr>
<tr>
<td>ARROW L -&gt; P9</td>
<td>SET TEMP. A3 PRE</td>
</tr>
<tr>
<td>SYMBOLIC FIELDS</td>
<td>SET dT TEMP. A3 PRE</td>
</tr>
<tr>
<td>EXHAUST</td>
<td>SET PRES. A3 PRE</td>
</tr>
<tr>
<td>COOL LEFT</td>
<td>SET dP PRES. A3 PRE</td>
</tr>
</tbody>
</table>

As for page 8.
PAGE 11 -> Autoclave 4 commands

Table 8.9: Elements in page no.11

<table>
<thead>
<tr>
<th>IMAGES</th>
<th>MIXER</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOCLAVE - BACKGROUND</td>
<td>HEATING</td>
</tr>
<tr>
<td>TOUCH BUTTONS</td>
<td>DYNAMIC FIELDS</td>
</tr>
<tr>
<td>4 ENABLE</td>
<td>AUTOCLAVE E/D</td>
</tr>
<tr>
<td>4 PREPARATION</td>
<td>AUTOCLAVE STATUS</td>
</tr>
<tr>
<td>4 SPUMANTIZZA</td>
<td>BAR DATA FIELDS</td>
</tr>
<tr>
<td>4 CONDITIONING</td>
<td>TEMP. A4+</td>
</tr>
<tr>
<td>4 HEATING</td>
<td>TEMP. A4-</td>
</tr>
<tr>
<td>4 COOLING</td>
<td>PRESS. AUTOCLAVE 4</td>
</tr>
<tr>
<td>4 MIXER</td>
<td>NUMERICAL DATA FIELDS</td>
</tr>
<tr>
<td>4 EXHAUST</td>
<td>TEMP. A4</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 7</td>
<td>PRESS. AUTOCLAVE 4</td>
</tr>
<tr>
<td>ARROW L -&gt; P10</td>
<td>SET TEMP. A4 PRE</td>
</tr>
<tr>
<td>SYMBOLIC FIELDS</td>
<td></td>
</tr>
<tr>
<td>EXHAUST</td>
<td>SET PRES. A4 PRE</td>
</tr>
<tr>
<td>COOL LEFT</td>
<td>SET dP PRES. A4 PRE</td>
</tr>
<tr>
<td>COOL RIGHT</td>
<td></td>
</tr>
</tbody>
</table>

As for page 8.
This page is displayed by pressing the touch button “EDIT” in page 1; it gives access to the pages for setting the parameters necessary for the production process.
PAGE 21 -> Autoclave Prepare

Table 8.11: Elements in page no. 21

<table>
<thead>
<tr>
<th>IMAGES</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUTTON 1 PRE</td>
</tr>
<tr>
<td>BUTTON 2 PRE</td>
</tr>
<tr>
<td>BUTTON 3 PRE</td>
</tr>
<tr>
<td>BUTTON 4 PRE</td>
</tr>
<tr>
<td>PREVIOUS MENU -&gt; 20</td>
</tr>
<tr>
<td>DATE/TIME FIELD</td>
</tr>
</tbody>
</table>

This page is displayed by pressing the touch button “PREPARE” in page 20; allows the user to choose which autoclave is to be parameterized.
PAGE 22 -> Autoclave 1 Prepare

This page is displayed by pressing the touch button “1” in page 21; it shows by means of bar and numerical data, both of which are settable, the temperature and pressure values necessary for the process.

Table 8.12: Elements in page no. 22

<table>
<thead>
<tr>
<th>IMAGES</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>PREVIOUS MENU -&gt; 21</td>
</tr>
<tr>
<td>NEXT</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BAR DATA FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>SET BAR TEMP. A1 PRE</td>
</tr>
<tr>
<td>SET BAR dT A1 PRE</td>
</tr>
<tr>
<td>SET BAR PRES. A1 PRE</td>
</tr>
<tr>
<td>SET BAR dP PRES. A1 PRE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NUMERICAL DATA FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>SET TEMP. A1 PRE</td>
</tr>
<tr>
<td>SET dT A1 PRE</td>
</tr>
<tr>
<td>SET PRES. A1 PRE</td>
</tr>
<tr>
<td>SET dP PRES. A1 PRE</td>
</tr>
</tbody>
</table>
The fact that the bar and numerical data are both settable means that the values can be attributed to the assigned variable using the VT.

Proceed as already described to insert the bar data.

Set as illustrated, then browse the data by clicking on Mode.

Compile as illustrated.

Click on OK.

Note that Input enabled box is active.

This applies to all bar and numerical data.
PAGE 23 -> Autoclave 2 Prepare

Table 8.13: Elements in page no. 23

<table>
<thead>
<tr>
<th>IMAGES</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESA</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>PREVIOUS MENU</td>
</tr>
<tr>
<td>NEXT</td>
</tr>
<tr>
<td>PREVIOUS</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BAR DATA FIELD</th>
</tr>
</thead>
<tbody>
<tr>
<td>SET BAR TEMP. A2 PRE</td>
</tr>
<tr>
<td>SET BAR dT A2 PRE</td>
</tr>
<tr>
<td>SET BAR PRES. A2 PRE</td>
</tr>
<tr>
<td>SET BAR dP PRES. A2 PRE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NUMERICAL DATA FIELD</th>
</tr>
</thead>
<tbody>
<tr>
<td>SET TEMP. A2 PRE</td>
</tr>
<tr>
<td>SET dT A2 PRE</td>
</tr>
<tr>
<td>SET PRES. A2 PRE</td>
</tr>
<tr>
<td>SET dP PRES. A2 PRE</td>
</tr>
</tbody>
</table>

This page is displayed by pressing the touch button marked “2” in page 21; it shows by means of bar and numerical data, both of which are settable, the temperature and pressure values necessary for the process.
This page is displayed by pressing the touch button marked “3” in page 21; it shows by means of bar and numerical data, both of which are settable, the temperature and pressure values necessary for the process.
PAGE 25 -> Autoclave 4 Prepare

Table 8.15: Elements in page no. 24

<table>
<thead>
<tr>
<th>IMAGES</th>
<th>ESA</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOUCH BUTTONS</td>
<td></td>
</tr>
<tr>
<td>PREVIOUS MENU</td>
<td>-&gt; 21</td>
</tr>
<tr>
<td>PREVIOUS</td>
<td></td>
</tr>
<tr>
<td>BAR DATA FIELDS</td>
<td></td>
</tr>
<tr>
<td>SET BAR TEMP. A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET BAR dT A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET BAR PRES. A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET BAR dP PRES. A4 PRE</td>
<td></td>
</tr>
<tr>
<td>NUMERICAL DATA FIELDS</td>
<td></td>
</tr>
<tr>
<td>SET TEMP. A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET dT A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET PRES. A4 PRE</td>
<td></td>
</tr>
<tr>
<td>SET dP PRES. A4 PRE</td>
<td></td>
</tr>
</tbody>
</table>

This page is displayed by pressing the touch button marked “4” in page 21; it shows by means of bar and numerical data, both of which are settable, the temperature and pressure values necessary for the process.
This page is displayed by pressing the touch button marked “CONDITIONING” in page 20; it allows you to select which autoclave is to be parameterized.
PAGE 27 -> Autoclave 1 conditioning

This page is displayed by pressing touch button “1” in page 26; it shows by means of bar and numerical data, both of which are settable, the temperature values necessary for the process.
This page is displayed by pressing the touch button marked “2” in page 26; it shows by means of bar and numerical data, both of which are settable, the temperature values necessary for the process.
This page is displayed by pressing the touch button marked “3” in page 26; it shows by means of bar and numerical data, both of which are settable, the temperature values necessary for the process.
PAGE 30 -> Autoclave 4 conditioning

This page is displayed by pressing the touch button marked “4” in page 26; it shows by means of bar and numerical data, both of which are settable, the temperature values necessary for the process.

Table 8.20: Elements in page no. 30

<table>
<thead>
<tr>
<th>IMAGES</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ESA</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>PREVIOUS MENU</td>
<td>-&gt; 26</td>
</tr>
<tr>
<td>PREVIOUS</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BAR DATA FIELDS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>SET BAR TEMP. A4</td>
<td>CON</td>
</tr>
<tr>
<td>SET BAR (dT) A4</td>
<td>CON</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NUMERICAL DATA FIELDS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>SET TEMP. A4 CON</td>
<td></td>
</tr>
<tr>
<td>SET (dT) A4 CON</td>
<td></td>
</tr>
</tbody>
</table>
This page is displayed by pressing the touch button marked “SPUMANTIZZA” in page 20; it allows the user to select which autoclave needs to be parameterized.
This page is displayed by pressing the touch button marked “PROJECT LANGUAGE” in page 40; This shows the languages in which the project can be displayed on the VT.
This page is displayed by pressing the touch button marked “Info” in page 1; it shows a page for information purposes composed exclusively of multilanguage labels.
This page is displayed by pressing the touch button marked “ABBREVIATIONS” in page 50; It shows a page for information purposes composed exclusively of multilanguage labels.
This page is displayed by pressing the touch button marked “ALARM” in page 40; it shows a series of buttons to simulate alarms, given that in reality there is no functioning plant.
This page is displayed by pressing the touch button marked “????” in alarm display mode; it shows an example of supplementary help to explain the alarm.

Table 8.26: Elements in page no. 65

| TOUCH BUTTONS     | PREVIOUS MENU -> 60 |
---|-------------------|

---
This page is displayed by pressing the touch button marked “SPUMANTIZZA” in page 20; it shows a series of commands for managing the recipes needed to control the process.
The first thing is to declare which variables will be needed to compose the recipe (See “Chapter 6 -> Data memory structure”).

Click on **Configure > Data memory structure** and the following mask appears on screen:

![Data memory structure](image1)

Set the parameters as illustrated.

Select the **Options**.

⚠️ The length of the code and the comment depend on the number of characters declared in the variable.
Identify the variables that must be inserted in the recipe, then select them.

Set the parameters as illustrated.

Select the Information.

The variables “recipe code” and “recipe comment” do not need to be inserted because they are not part of the options of the recipe (See “Chapter 6 -> Data memory structure”).

The information shown in the figure is contained only in the VT.

Set the parameters as illustrated.

Click on Ok.

Once all the variables that comprise the recipe have been defined insert the code and the comment in the page. Click on , put the cursor in the page and click.
Set the parameters as illustrated.

Select the Mode

Set the parameters as illustrated.

Click on Ok.

Insert the variable recipe comment using the same procedure. (See project offered as example).
This page is displayed by pressing the touch button “<<” in page 70; it shows the first part of the recipe needed to control the process.
This page is displayed by pressing the touch button in page 71; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button " " in page 72; it shows the next part of the recipe needed to control the process.
Table 8.31: Elements in page no. 74

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECIPE - MENU</td>
</tr>
<tr>
<td>PAGE DOWN 1</td>
</tr>
<tr>
<td>PAGE UP 1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DYNAMIC TEXT FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPU DATA 09 F01</td>
</tr>
<tr>
<td>SPU DATA 10 F01</td>
</tr>
<tr>
<td>SPU DATA 11 F01</td>
</tr>
<tr>
<td>SPU DATA 12 F01</td>
</tr>
<tr>
<td>SPU DATA 13 F01</td>
</tr>
<tr>
<td>SPU DATA 14 F01</td>
</tr>
<tr>
<td>SPU DATA 15 F01</td>
</tr>
<tr>
<td>SPU DATA 16 F01</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ASCII FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECIPE CODE</td>
</tr>
<tr>
<td>RECIPE COMMENT</td>
</tr>
</tbody>
</table>

This page is displayed by pressing the touch button marked “” in page 73; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button marked “” in page 74; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button marked “” in page 75; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button marked “Page 7” in page 76; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button marked “…” in page 77; it shows the next part of the recipe needed to control the process.
CHAPTER 8
Creating a project with VTWIN

PAGE 79 -> Recipe - Page 9

Table 8.36: Elements in page no. 79

<table>
<thead>
<tr>
<th>TOUCH BUTTONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECIPE - MENU</td>
</tr>
<tr>
<td>PAGE DOWN 1</td>
</tr>
<tr>
<td>PAGE UP 1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NUMERICAL FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPU DATA 01 F04</td>
</tr>
<tr>
<td>SPU DATA 02 F04</td>
</tr>
<tr>
<td>SPU DATA 03 F04</td>
</tr>
<tr>
<td>SPU DATA 04 F04</td>
</tr>
<tr>
<td>SPU DATA 05 F04</td>
</tr>
<tr>
<td>SPU DATA 06 F04</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DYNAMIC TEXT FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPU DATA 05 F04</td>
</tr>
<tr>
<td>SPU DATA 06 F04</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ASCII FIELDS</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECIPE CODE</td>
</tr>
<tr>
<td>RECIPE COMMENT</td>
</tr>
</tbody>
</table>

| MULTILINGUOUS LABEL    |

This page is displayed by pressing the touch button marked “**” in page 78; it shows the next part of the recipe needed to control the process.
This page is displayed by pressing the touch button marked “ ” in page 79; it shows the next part of the recipe needed to control the process.
Once all the pages have inserted, the user must assign to the touch buttons with the “Go to page” function the appropriate page associations, given that in the phase of creating the project almost all have been associated to page 1.

**Data exchange area**

Given the need to define the information messages, the alarms and the commands to be exchanged with the connected device, it is essential that this area be defined.

Select the Data exchange area (See “Chapter 4 -> Exchange areas”).

![Data exchange area screenshot](image1)

Click on Add.

![Data exchange area screenshot](image2)

Set parameters as illustrated

Click on Add.
Using the same method, insert all the memory areas necessary (See project offered as example).

**Information messages**

In the example the need arises to inform the operator who is to use the VT that certain operations are not possible under certain conditions (See “Chapter 4 -> Information Messages”).

Set parameters as illustrated.

Click on OK.

Select the required.

Click on the Add.
Insert the bit number to which the message must be assigned; assign the name to the message and edit the text.

The comment is not assigned, because further information is not needed to explain the function of the message.

Then browse the by clicking on Message field.
Given that there are no particular values and/or information on the variable related to the al message, so do not use this function.

Click on Help message.

Click on Edit to insert the help message.
Edit the text then click on Italian to insert the translation.

Insert the text and click on OK to accept; you will return to the previous mask, click again on OK.

Using the same procedure insert all the messages (See project offered as example).
Alarms

Proceed to insert the alarms (See “Chapter 4 -> Alarms”).

Select the Alarms.

Click on Add.
Insert the bit number to which to assign the alarm; assign a name to the alarm and edit the text.

The comment is not assigned because no further information is needed to explain the function of the alarm.

Then choose the dimensions of the text for displaying the alarm. Once this has been done, click on the Alarm field.

Click on Add.
Compile as illustrated and click on OK.

The mask thus compiled is displayed.

Select the Alarm help.
Insert text as illustrated and click on Alarm help button.

Compile as illustrated, assigning the translation too.

Click on OK to accept the settings.
Now insert all the alarms the project needs. (See project offered as example).

The single VT project is now complete and must be compiled (See “Chapter 9 -> Compiling and transferring a project”); once it has been compiled without errors, the project must be saved.

Given that we need to create a project for an ESA-NET network, we must duplicate the single VT project and name it “SPUM565 for saia pcd (remote control).vts”

At this point, in order to create a network project, click on the "File > New" (See “Chapter 5 -> New…”)

Select the icon "ESA_NET network." Click on the "OK."
Select the icon on the Project side, then click on the Tools>Import... and choose the project “spum565 for saia pcd.vts” for the list. Confirm with OK.

Repeat the operation and choose the project “spum565 for saia pcd (remote control).vts” from the list. Confirm with OK.
As illustrated, select \texttt{PLC\textunderscore 1}, then click on \texttt{Edit}\textunderscore Delete to remove the device. Confirm with OK.

As illustrated, select the ASP port and click on \texttt{asp}. In this way the connection with the ESA-NET network is established. Repeat the operation for the ASP port of the other project too. Confirm with OK.
Select as illustrated, then click on the Edit-Property... The following window is displayed.

Select as illustrated, then change the Public address to 2.
The network project has now been created; click on **File > Save** to confirm the settings.

Open the project highlighted in the figure above to carry out changes needed to work in an ESA-NET network context; once the project has been opened, click on **Configure > Public data** to have the following mask appear.
To know which variables must be declared as public, see the project offered as an example.

The project is now complete and ready to function in an ESA-NET network context. It remains only to compile and transfer it (See "Chapter 9 -> Compiling and transferring a project").

Make any necessary changes to the other project too (See project offered as example) then compile and transfer.

The project is now finished.
# Chapter 9

## Compiling and transferring a project

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiling a project</td>
<td>9-2</td>
</tr>
<tr>
<td>Transferring the project</td>
<td>9-3</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 4 pages.
Compiling a project

Compilation is a method of creating a file automatically in a format the VT panel can recognize.

During the compilation there is a control phase that makes it possible to detect any errors introduced while the project was being built. If an error is detected during compilation, it is highlighted by the text in the compilation window being colored red and at the same time the errors being displayed.

To start compiling click on *Tools > Project compilation*.

Compilation can be configured as follows.

Stop at first error:

The compilation can be stopped at the first error encountered in the project.

No stop:

Even if an error is encountered, compilation will not stop but proceed possibly finding other errors.

Stop after N. errors:

The user can decide the number of errors to detect before stopping the compilation.

Display warnings:

The user can decide whether to display warnings too during compilation. The warnings are not considered errors, so compilation proceeds, but they advise the operator that a part of the project has omitted and/or not completely compiled.

Output:

Shows how the compilation is proceeding. The information displayed can be saved in a file by pressing the Save output.
Transferring the project

Once the project has been correctly compiled it must be transferred to the operator terminal. To do this click on **Tools > Project transfer.** If the project has not been compiled yet, the system automatically proposes the compilation window with the above listed parameters; otherwise the transfer window used for selecting the parameters for communication between the PC and the VT comes up.

⚠️ **If there are adapters connected to the terminal (see Hardware Manual), the project must be transferred first to the VT and then to the adapter.**

⚠️ **What has been explained relates exclusively to VT projects and not for ADT projects. For ADT projects, it is the user application package that is used for the transfer** (see “Chapter 14 -> User application package”).

To prepare the VT for transferring the project, see the relevant Hardware Manual.

The parameters for transferring the project must be compiled; these are listed below.

Communication port:

Use this to choose the communication port used by the PC.

Baud rate:

Use this to select the speed of data transfer.

Update terminal:

Allows you to enable the transfer of the project to the terminal. This is activated automatically.

Update terminal Fw:

Use this to specify whether, during the transfer, the VT firmware is also to be transferred.

This allows you to force the loading of the firmware. When VTWIN becomes aware that the firmware available is more recent than that contained in the VT, it automatically updates it. Normally this is not activated because, for one thing, the transfer times become much longer. It can be activated in the event that there are doubts as to whether the VT is functioning correctly.
Update adapters:

Allows you to enable the transfer of the project to the adapter. This is activated automatically.

Update adapters Fw:

Use this to specify whether, during the transfer, the adapter firmware is also to be transferred. This allows you to force the loading of the firmware. When VTWIN becomes aware that the firmware available is more recent than that contained in the adapter, it automatically updates it. Normally this is not activated because, for one thing, the transfer times become much longer. It can be activated in the event that there are doubts as to whether the adapter is functioning correctly.
Chapter 10  Creating and printing documentation

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importance of documentation</td>
<td>10-2</td>
</tr>
<tr>
<td>Print the project</td>
<td>10-2</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 4 pages.
Importance of documentation

The creation of documentation is an important phase in the development of a project.

It is possible at any time to consult, re-elaborate or simply re-check what has been created. At the termination of a project this assumes an even greater importance where problems are detected after a period of time; not least, in the event of data being lost, it is possible to get back to what was originally elaborated.

The type of documentation created is settable by the user and makes it possible to prepare print patterns that can be used as the needs of the moment dictate.

Print the project

To print documentation the following steps must be followed. Click on Tools > Print...

The print program is activated with the following parameters to compile and/or select.

The print program is activated; this contains a series of allowing the definition of all the necessary print parameters, which are then compiled and/or selected.

VTWIN simply uses the drivers of the printers that are selected, without adding any particular control operation; print on file, print front/back etc. depend, therefore, exclusively on the printer selected.

Name of printer:

Used to specify which printer to choose from those available (installed on the personal computer) to print the project. Click on Settings....

Printer Port:

Display the port or path of the printer selected.

Name of format:

Used to select which print format to use from those available.

Description of format:

Shows what is needed for the format displayed and/or chosen to be printed.
Preview:

By clicking on Preview a special function is accessed allowing you to see what is to be printed and how which will vary according to the model selected. This contains in its turn two menus:

**Control**

Allows you to browse the print preview.

**View**

Allows you to select the Layout (1 or 2 pages) of the print preview.

Edit:

By clicking on Edit you call up a mask containing all the parameters needed for the print pattern. This mask consists of several described below.

**Name:**

Name of pattern in edit phase; also the name can be edited.

**Optional sections:**

This allows the type of information to be changed that you intend to print (e.g., only pages or only variables or variables and pages etc.). The order in which these items of information are to be printed can also be modified. (Print order is the order in which the information is inserted in the list.)

**Sections available:**

This is the list of items of information that can be printed.

**Sections selected:**

This is the list of items of information to be printed. By selecting the one at a time and clicking on Configure you specify the elements to be printed from the

⚠️ **If when the is selected, the Configure is not activated, this means that no customizing is possible. (E.g. when Variables is selected the is not activated, meaning**
that the variables will be printed in the mode as planned and that in VTWIN they not modifiable by the user).

 bahwa variables akan dikenakan dalam mode yang diatur dan di VTWIN tidak bisa diubah oleh pengguna.

Global settings:

Used to make global settings for the various types of documents to be printed (cover, index etc.).

Include cover:

Allows the user to define whether a cover is required or not. If so, it can be chosen from the list, assuming that at least one cover has been created. To do this click on New...

Index:

Define whether an index is required.

Project information:

Define whether to have project information.

Comments in all sections:

Defines whether to have comments in all sections.

Page settings:

Used to define the Layout of the page. (Applicable to all pages).

Margins:

Used to define the page margins.

Header:

Allows the user to write a header line and decide whether to print it or not.

Footer:

Allows the user to write a footer line and decide whether to print it or not.

Page numbers:

Determines where to put the page number.
Chapter 11

Creating a back-up of the project

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importance of a Back-up</td>
<td>11-2</td>
</tr>
<tr>
<td>How to create a Back-up</td>
<td>11-2</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 2 pages.
Importance of a Back-up

This operation that only takes a few seconds protects the user from any accidental losses of data.

It is a good habit every so often to make for reasons of safety a back-up copy of what you have created and/or edited.

It is important to save the .VTS file (Single VT project) or .VTN file (ESA-NET network project); all the files necessary for the project itself can be obtained from this file.

⚠️ If you lose the source project (.VTS or .VTN), the information contained in it will be lost definitively; a possible recover from the VT panel or the possession of the compiled files alone permit the project to be transferred to another terminal comparable to the one for which the project had been created, but it will not be possible to edit the project in any way.

How to create a Back-up

To create a copy of the project, click on File > Save as... (see “Chapter 5 -> Save as…”). Use a support medium other than the hard disk and if possible put it in a safe place.
Chapter 12  Defining the fonts

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meaning of the icons used in the menus</td>
<td>12-3</td>
</tr>
<tr>
<td>Personalizing a Font</td>
<td>12-4</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 6 pages.
VTWIN contains a program allowing the character fonts to be edited and/or created.

In the case of text panels 7 characters (from 1 to 7) can be redefined. This is because the display used contains a predefined non-modifiable set of characters. Different fonts can be created, but for every font created there are always 7 characters (from 1 to 7) that can be modified.

In the case of graphic panels 255 characters (from 1 to 255) can be modified.

When a font is used it is saved along with the project; this makes it possible to transfer the project to other PCs without encountering any problems related to representation. This is true both for text panels and for graphic panels.

To call up the program click on **Tools > Font Editor** or click on **Start > Programs > VTWIN > Font Editor**; the main mask appears.

1) Displays the fonts currently operational.

2) Displays the dimensions of the font in operation.

3) Shows how the character is displayed in various enlargements.

4) Shows the currently active number of the character in the table. The image of the mouse with the left button is blue indicates that the character is editable.
The table shows all the icons of the menus together with their meanings.

Table 12.1: List of icons used in VTWIN Font Editor, menu attribution and meaning.

<table>
<thead>
<tr>
<th>Tool Bar</th>
<th>Pulldown menu</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File &gt; New</td>
<td>Creates a new font.</td>
</tr>
<tr>
<td></td>
<td>File &gt; Open font</td>
<td>Opens an already existing font.</td>
</tr>
<tr>
<td></td>
<td>File &gt; Save font</td>
<td>Save a font on disk.</td>
</tr>
<tr>
<td></td>
<td>Grid &gt; Clear</td>
<td>Deletes the content of the grid.</td>
</tr>
<tr>
<td></td>
<td>Grid &gt; Invert</td>
<td>Inverts the content of the grid. (White becomes black and vice versa).</td>
</tr>
<tr>
<td></td>
<td>Language</td>
<td>Allows the language of the program to be selected.</td>
</tr>
<tr>
<td></td>
<td>?</td>
<td>Calls up the Font Help.</td>
</tr>
</tbody>
</table>
Below is an example of personalizing a project font by generating a new one, the font CUST6X8.fon.

Click on \textit{File > Open font}

Select the font as illustrated.

Click on \textit{OK}.
Click on **File > Save font**

![Image of font editor](image)

Assign a name as illustrated.

**Click on OK.**

This operation saves the initial font which, in the event of some error, is not ruined. After this operation the new font is automatically loaded.
Select a pixel at a time and click till the character desired is obtained.

Once the character has been completed, click on File > Save.
Chapter 13 Free terminal

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transfer of free terminal</td>
<td>13-2</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 2 pages.
This allows the user to activate the transfer mode of the Free terminal communication protocol. (See Hardware Manual.)

Transfer of Free terminal

Click on Start > Programs > VTWIN > Free terminal; a list of the terminals supporting it appears. When one of these is selected and the user clicks on Transfer, the following mask appears:

The mask shows all the parameters needed for establishing the connection between the VT terminal and the PC used for the programming.
Chapter 14  ActiveX

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>User application package</td>
<td>14-2</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 2 pages.
When it becomes necessary to connect a device directly to a personal computer or check data of many VTs connected to each other in a network, this can be done by using an adapter (see Hardware Manual) with the related project (see “Introduction -> What is a project?” and/or “Chapter 5 -> Project for Single VT:“) and by utilizing the capabilities of ActiveX (see HoL for further details).

The User application package to be employed on a personal computer must be created in a development environment (outside VTWIN) that supports the OLE Automation technology. The User application package (e.g. Supervisor) is interfaced with the VTWIN project using the capabilities offered by ActiveX components.

⚠️ The user application package takes care of transferring the ADT project (file .OBJ and .FW, see “Introduction -> Files generated by an ADT project“) to the adapter.

For all necessary details and information relating to the capabilities of ActiveX see HoL.

To make this easier to understand, you will find some application packages included for illustration purposes in the ActiveX Samples folder.
Chapter 15  Technical support

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>National Customer Care</td>
<td>15-2</td>
</tr>
<tr>
<td>National Product Returns</td>
<td>15-2</td>
</tr>
<tr>
<td>International Customer Care</td>
<td>15-4</td>
</tr>
<tr>
<td>International Product Returns</td>
<td>15-4</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 6 pages.
Problems related to the use of ESA VT terminals should be referred to our Customer Care service. The department is contactable on week days in office hours.

The National Customer Care service can be contacted by:

**National Customer Care**

Telephone: ++44 (0) 1203 386550

Fax: ++44 (0) 1203 386551

E-Mail: esahmi@esauk.ltd.uk

Web site: [http://www.esahmi.it](http://www.esahmi.it)

**National Product Returns**

If it is necessary to return the VT terminal for repair:

- Contact our National Customer Care service to authorize the return.
- Fill in all parts of the form to accompany the product.

Our National Customer Care service will supply all the necessary information for returning an item.

!!! IMPORTANT NOTE !!!

**ESA (UK) LIMITED will accept:**

- goods carriage free / freight prepaid (transport at customer’s cost).
- goods carriage forward / freight collect (transport paid by ESA) **only with the prior authorization of the company.**

**ESA (UK) LIMITED will reject:**

- any returned goods carriage forward where there has been no prior authorization.

It is not necessary to send connectors, cables and accessories (unless they are thought to be linked to the problem indicated).

Thank you for your kind co-operation.
Returned goods code: ............................................

Product: ............................................    S/N: ............................................

<table>
<thead>
<tr>
<th>Customer details (must be filled in)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiled by: ..........................................................</td>
</tr>
<tr>
<td>Company: .............................................................</td>
</tr>
<tr>
<td>Full address: ..........................................................</td>
</tr>
<tr>
<td>Tel. no.: ............................................................ Fax: ........................................</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Contact person (where different from above)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: .............................................................</td>
</tr>
<tr>
<td>Tel. no.: ........................................................ Fax: ........................................</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Information regarding problem (must be filled in)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device connected: ...........................................</td>
</tr>
<tr>
<td>Detailed description of the problem and the circumstances under which it occurs: ...........................................</td>
</tr>
<tr>
<td>Notes: .............................................................</td>
</tr>
</tbody>
</table>

Customer Care worker contacted: .............................................................

Date of compilation: ........./......../....... Signature: .............................................................
The International Customer Care service can be contacted by:

Telephone: ++39-031757400

Fax: ++39-031751777

E-Mail: esahotln@esahmi.it

Web site: http://www.esahmi.it

Should it be necessary to return the VT terminal for repair:

• Contact our International Customer Care service to authorize the return.
• Fill in all parts of the form to accompany the product.

Our International Customer Care service will supply all the necessary information for returning an item.

!!! IMPORTANT NOTE !!!

**ESA elettronica S.p.A. will accept:**
• goods carriage free / freight prepaid (transport at customer’s cost).
• goods carriage forward / freight collect (transport paid by ESA) **only with the prior authorization of the company.**

**ESA elettronica S.p.A. will reject:**
• any returned goods carriage forward where there has been no prior authorization.

It is not necessary to send connectors, cables and accessories (unless they are thought to be linked to the problem indicated).

Thank you for your kind co-operation.
Returned goods code: ............................................

**Product:** .............................................  **S/N:** .............................................

<table>
<thead>
<tr>
<th>Customer details (must be filled in)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiled by: ..........................................................</td>
</tr>
<tr>
<td>Company: ...............................................................</td>
</tr>
<tr>
<td>Full address: .........................................................  Post Code: .......................</td>
</tr>
<tr>
<td>Town: ......................................................  County: ........................................</td>
</tr>
<tr>
<td>Tel. no.: ..................................................  Fax: ........................................</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Contact person (where different from above)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: .............................................................</td>
</tr>
<tr>
<td>Tel. no.: ..................................................  Fax: ........................................</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Information regarding problem (must be filled in)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device connected: ..................................................</td>
</tr>
<tr>
<td>Detailed description of the problem and the circumstances under which it occurs:</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>Notes: ..............................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
<tr>
<td>........................................................................................................</td>
</tr>
</tbody>
</table>

Customer Care worker contacted: ..........................................................

Date of compilation: ....../....../......  Signature: ..........................................................
Appendix A

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project images - Graphic</td>
<td>AA-2</td>
</tr>
</tbody>
</table>

This chapter consists of a total of 4 pages.
The tables below show the contents of the DEMO project.

**Table A.1: Project images - Graphic (Part 1 of 3)**

<table>
<thead>
<tr>
<th>Bottle</th>
<th>Esa</th>
<th>Arrow right</th>
<th>Arrow left</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Bottle Image" /></td>
<td><img src="image" alt="Esa Image" /></td>
<td><img src="image" alt="Arrow Right Image" /></td>
<td><img src="image" alt="Arrow Left Image" /></td>
</tr>
<tr>
<td>Arrow right short</td>
<td>Arrow left short</td>
<td>Previous menu 1</td>
<td>Previous menu 2</td>
</tr>
<tr>
<td><img src="image" alt="Arrow Right Short Image" /></td>
<td><img src="image" alt="Arrow Left Short Image" /></td>
<td><img src="image" alt="Previous Menu 1 Image" /></td>
<td><img src="image" alt="Previous Menu 2 Image" /></td>
</tr>
<tr>
<td>Previous menu 3</td>
<td>Mixer 1</td>
<td>Mixer 2</td>
<td>Mixer 3</td>
</tr>
<tr>
<td><img src="image" alt="Previous Menu 3 Image" /></td>
<td><img src="image" alt="Mixer 1 Image" /></td>
<td><img src="image" alt="Mixer 2 Image" /></td>
<td><img src="image" alt="Mixer 3 Image" /></td>
</tr>
<tr>
<td>Mixer 4</td>
<td>Mixer 5</td>
<td>Mixer 6</td>
<td>Mixer 7</td>
</tr>
<tr>
<td><img src="image" alt="Mixer 4 Image" /></td>
<td><img src="image" alt="Mixer 5 Image" /></td>
<td><img src="image" alt="Mixer 6 Image" /></td>
<td><img src="image" alt="Mixer 7 Image" /></td>
</tr>
</tbody>
</table>
Table A.1: Project images - Graphic (Part 2 of 3)

<table>
<thead>
<tr>
<th>Mixer 9</th>
<th>Mixer 10</th>
<th>Mixer 11</th>
<th>Mixer 12</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Mixer 13</th>
<th>Mixer 14</th>
<th>Mixer 15</th>
<th>Mixer 16</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td><img src="image6.png" alt="Image" /></td>
<td><img src="image7.png" alt="Image" /></td>
<td><img src="image8.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cool right 1</th>
<th>Cool right 2</th>
<th>Cool right 3</th>
<th>Cool right 4</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td><img src="image10.png" alt="Image" /></td>
<td><img src="image11.png" alt="Image" /></td>
<td><img src="image12.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cool right 5</th>
<th>Cool right 6</th>
<th>Cool right 7</th>
<th>Cool left 1</th>
</tr>
</thead>
</table>
### Table A.1: Project images - Graphic (Part 3 of 3)

<table>
<thead>
<tr>
<th>Cool left 2</th>
<th>Cool left 3</th>
<th>Cool left 4</th>
<th>Heat 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Cool left 2" /></td>
<td><img src="image2.png" alt="Cool left 3" /></td>
<td><img src="image3.png" alt="Cool left 4" /></td>
<td><img src="image4.png" alt="Heat 1" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Heat 2</th>
<th>Heat 3</th>
<th>Heat 1</th>
<th>Heat 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5.png" alt="Heat 2" /></td>
<td><img src="image6.png" alt="Heat 3" /></td>
<td><img src="image4.png" alt="Heat 1" /></td>
<td><img src="image7.png" alt="Heat 2" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Heat 3</th>
<th>Heat 4</th>
<th>Autoclave empty</th>
<th>Autoclave full</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image8.png" alt="Heat 3" /></td>
<td><img src="image9.png" alt="Heat 4" /></td>
<td><img src="image10.png" alt="Autoclave empty" /></td>
<td><img src="image11.png" alt="Autoclave full" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Autoclave background</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image12.png" alt="Autoclave background" /></td>
</tr>
</tbody>
</table>
Index

Symbols

?, 5-11, 6-26
? > Index, 7-5
? > Search for help on..., 7-5
? > Summary and index, 7-3

A

About..., 5-11
ActiveX, 14-1
Adapter project, 5-6
ADD Command, 4-68
Address
memory area, 4-42
variable, 4-37
Alarm, 4-56
Alarm field, 4-57
Alarm help, 4-57
Alarm signal position, 6-14
Alarms, 4-55, 8-91
AND Command, 4-68
Arc, 4-33
ASCII field, 4-14
Assigned to a single bit of a given variable, 4-17
Assigned to the bit group of a given variable, 4-18
Assigned to the numerical value of a given variable, 4-17
Automatic change of context
Alarms, 6-13
Messages, 6-14
Automatic scrolling
Alarms, 6-13
Messages, 6-14
Autoscroll delay
Alarms, 6-13
Axes origin, 6-5

B

Background
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-20
Numerical field, 4-13
touch buttons, 4-61
Background image of touch buttons, 4-60
Backup/Restore, 6-2
Bar field, 4-21
Baud rate, 9-3
BCD, 4-37
Beep on new alarms
Alarms, 6-13
Beep when screen/key is pressed, 6-13
Bit, 4-70
Bit number
alarms, 4-56
ASCII field, 4-16
bar field, 4-22
direct command, 4-70
dynamic text field, 4-20
information messages, 4-53
Mobile symbolic field, 4-26
Numerical field, 4-12
symbolic field, 4-25
Bitmap Image, 4-33
Bit-structured Direct Commands, 4-68
Bit-wise protection
ASCII field, 4-15
bar field, 4-22
dynamic text field, 4-20
Mobile symbolic field, 4-26
Numerical field, 4-11
symbolic field, 4-24
Block of sampling on command, 4-88
Border
touch buttons, 4-59
Button label
alarms, 4-57
information messages, 4-55
touch buttons, 4-60

C

Channels, 4-30
Close, 6-2
Code, 6-25
Columns per Page
header and footer, 4-85
print page, 4-83
Command area, 4-44
Command response area, 4-51
COMMAND 17 SETDATE, 4-46
Comment
alarms, 4-56
ASCII field, 4-14
bar field, 4-21
direct commands, 4-70
dynamic text field, 4-19
information messages, 4-53
lists of image, 4-72
macro, 4-78
memory area, 4-42
Mobile symbolic field, 4-25
Numerical field, 4-6
page sequences, 4-40
pipeline, 4-81
project images, 4-76
report, 4-87
symbolic field, 4-23
text lists, 4-71
touch button, 4-32
touch buttons, 4-59
trend, 4-30
variable, 4-36
Comment enabled, 6-25
Comments in all sections, 10-4
Communication port, 9-3
Compile project, 6-2
Compiling a project, 9-2
Compiling and transferring a project, 9-1
Configurator menu, 3-2
Configurator menu in detail, 5-1
Configure, 6-6
Contents, 5-11
Continuous read
ASCII field, 4-15
bar field, 4-22
dynamic text field, 4-19
Mobile symbolic field, 4-26
Numerical field, 4-10
symbolic field, 4-24
Control, 10-3
Convert..., 5-10
Copy to clipboard, 6-5
Create macro field, 6-4
Creating and printing documentation, 10-1
Creating the project, 8-3
Currently active number, 12-2

D

Data area
memory area, 4-42
variable, 4-36
Data exchange area, 8-86
Data memory structure, 6-16
Date, 4-26
Date format
Alarms, 6-14
INDEX

Messages, 6-14
Day of the week, 4-28
Defining the fonts, 12-1
Definition of function
touch buttons, 4-59
Delete, 5-10
Delete owner macro field, 6-4
Description of format, 10-2
Devices, 5-11
Dimension
arms, 4-57
information messages, 4-54
Direct Commands, 4-67
Directories
project images, 4-76
Disable
touch buttons, 4-61
Disable key, 4-61
Display warnings, 9-2
Displayed, 12-2
Download project, 6-2
Drive
project images, 4-76
Dynamic Text Field, 4-16

E

Edit, 5-10, 6-4, 10-3
Edit > Align > Downwards, 7-6
Edit > Align > Horizontal center, 7-6
Edit > Align > Leftwards, 7-5
Edit > Align > Rightwards, 7-5
Edit > Align > Upwards, 7-6
Edit > Align > Vertical center, 7-6
Edit > Build library, 7-4
Edit > Colors, 7-5
Edit > Copy, 7-4
Edit > Cut, 7-4
Edit > Delete, 7-3, 7-4
Edit > Dimension > X1, 7-5
Edit > Dimension > X2, 7-5
Edit > Dimension > X4, 7-5
Edit > Duplicate, 7-4
Edit > Erase all, 7-4
Edit > Font choice, 7-5
Edit > Grid, 7-5
Edit > Level > Bottom, 7-5
Edit > Level > Down, 7-5
Edit > Level > Top, 7-5
Edit > Level > Up, 7-5
Edit > Mirror > Horizontal, 7-6
Edit > Mirror > Vertical, 7-6
Edit > Paste, 7-4
Edit > Property, 7-3
Edit > Redo, 7-4
Edit > Reverse, 7-5
Edit > Undo, 7-4
Edit > Zoom down, 7-5
Edit > zoom up, 7-4
Edit mode, 4-3
Edit-mode idle timeout, 6-12
Edit menu, 3-8
Edit menu in detail, 6-1
Elements of the group
variable groups, 4-39
Ellipse, 4-33
Enable Checksum, 6-26
Enable date, 6-26
Enable hour, 6-25
Enable No. of Items, 6-26
Enable screen saver, 6-13
Enabled
exchange area, 4-52
ESA-NET, 8-95
Example of Checksum
calculation, 6-19
Exchange area
alarms, 4-56
information messages, 4-53
Exchange areas, 4-42
Exit, 5-10
Export translations, 6-3
Export..., 5-11
External keys definition, 6-5
External keys global definition, 6-7
External leds command area
(blinking light), 4-44
External leds command area (fixed light), 4-44

F

Field > Trend, 7-6
Field and Variable, 2-2
Field Index
Mobile symbolic field, 4-26
Field index
ASCII field, 4-15
bar field, 4-22
dynamic text field, 4-19
Numerical field, 4-9
symbolic field, 4-24
Fields, 6-3
Fields > Ascii, 7-6
Fields > Bar, 7-6
Fields > Date, 7-6
Fields > Dynamic, 7-6
Fields > Label, 7-6
Fields > Mobile symbolic, 7-6
Fields > Numeric, 7-6
Fields > Symbolic, 7-6
Fields > Touch button, 7-7
FIFO (First In - First Out), 4-89
trend buffer, 4-89
trend buffer, 4-89
File, 5-2
File > New, 7-3
File > Open, 7-3
File > Save, 7-3
File > Update, 7-4
File architecture, 1-4
File Name
project images, 4-76
Files generated by a VT project, 1-2
Files generated by an ADT
project, 1-3
First bit
dynamic text field, 4-19
Mobile symbolic field, 4-26
symbolic field, 4-24
Fit button
touch buttons, 4-60
Font, 12-2
alarms, 4-57
information messages, 4-54
Font dimensions, 12-2
Font editor, 6-2
Font utilizzabili correlati alla
revisione hardware del
terminale VT., 6-9
Footer, 10-4
report, 4-88
Foreground
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-20
Numerical field, 4-13
touch buttons, 4-60
Format
ASCII field, 4-15
Numerical field, 4-8
Format 1, 4-29
Forms assumed by the mouse
pointer, 7-2
Free terminal, 13-1
Function
macro, 4-78
touch buttons, 4-59
Function command area, 4-45
Function list
macro, 4-78
Function specification
macro, 4-78
Funzioni grafiche correlate alla
revisione hardware del
terminale VT., 4-77

G

Global settings, 10-4
Go to page, 4-62
Go to page number
alarm, 4-57
information messages, 4-55

H

Header, 10-4
report, 4-88
Header and footer, 4-84

405.1200.038.2 - Rel.: 2.03 of 13/11/2000 - Only for VTWIN Ver. 3.xx
Height
  touch buttons, 4-59
Help message
  information messages, 4-54
Hide
  touch buttons, 4-61
Horizontal arrangement, 6-26
Hour/Date field, 4-27
How to create a Back-up, 11-2
HW requirements
  ideal specifications, 1-2
  minimum specifications, 1-2

I
  Ignore exceeding samples
    trend buffer, 4-89
  Image list
    Mobile symbolic field, 4-26
  Image memory area, 6-7
  Image selected
    lists of image, 4-72
  Images, 4-72
    lists of image, 4-72
  Import translations, 6-3
  Import...
    5-10
  Import/Export, 6-15
  Importance of a Back-up, 11-2
  Importance of documentation, 10-2
  Include cover, 10-4
  Index, 6-26, 10-4
  Information about VTWIN...
    6-26
  Information message field
    information messages, 4-54
  Information Messages, 4-53
  Information messages, 8-87
  Input limits
    variable, 4-37
  Insert in history buffer
    alarms, 4-58
  Inserting pages, 8-13
  Inserting variables, 8-12
  Installation procedure, 1-2
  Internal Command
    Change language, 4-63
    Clear trend buffer, 4-63
    Delete recipe, 4-65
    Display page directory, 4-63
    Display project information, 4-63
    Display recipe directory, 4-65
    Display sequence directory, 4-63
    Hardcopy, 4-63
    Load recipe from memory, 4-65
    Login password, 4-62
    Logout password, 4-62
    Modify password, 4-62
    Next Page, 4-63
    Page Help, 4-64
    Previous Page, 4-64
    Print alarm history, 4-63
  Printer form feed, 4-63
  Put total sheet number to 0, 4-63
  Quit project, 4-64
  Read trend block, 4-64
  Read trend sample, 4-64
  Run pipeline, 4-62
  Save recipe from device in data
    memory, 4-66
  Save recipe from device in the
    video buffer, 4-66
  Save recipe in data memory, 4-66
  Send recipe from video buffer to
devices, 4-66
  Send recipe to device, 4-65
  Service Page, 4-64
  Show alarms history, 4-64
  Start trend, 4-64
  Stop trend, 4-65
  Internal functions, 4-61
    Internal green leds command area
      (blinking light), 4-45
    Internal green leds command area
      (fixed light), 4-44
  Internal keys definition, 6-5
  Internal keys global definition, 6-7
  Internal red leds command area
    (blinking light), 4-44
  Internal red leds command area
    (fixed light), 4-44
  International Customer Care, 15-4
  International Product returns, 15-4
  Items, 6-25
  
  Language, 6-12
  Language fonts, 6-12
  Last bit
    dynamic text field, 4-19
  Mobile symbolic field, 4-26
  symbolic field, 4-24
  Leading zeros
    Numerical field, 4-6
  Left Margin
    header and footer, 4-85
    print page, 4-83
  Length
    ASCII field, 4-15
    memory area, 4-42
    variable, 4-37
  Line, 4-32
  Linear scaling
    variable, 4-37
  List file of type
    project images, 4-76
  List labels, 5-11
  List of functions, 2-4
  List of images
    symbolic field, 4-24
  List of texts selected
  
  text lists, 4-71
  Lists of images, 4-71
  Logout page/sequence, 6-6
  Logout timeout, 6-6
  Lower limit
    trend, 4-30

M
  Macro, 4-62, 4-78
  Margins, 10-4
  Marker type
    trend, 4-30
  Meaning of the Configurator menu
    icons, 7-3
  Meaning of the Editor menu
    icons, 7-4
  Meaning of the icons used in the
    menus, 12-3
  Memory area
    exchange area, 4-53
    Memory areas, 4-41
  Message
    information messages, 4-54
  Message area, 4-43
  Message signal position, 6-14
  Mobile symbolic field, 4-25
  Modify field enabled
    ASCII field, 4-15
    bar field, 4-22
    dynamic text field, 4-20
    Mobile symbolic field, 4-26
    Numerical field, 4-11
    symbolic field, 4-24
    Monday Format, 4-29
  Movement directions
    Mobile symbolic field, 4-27
    Multi-language definition, 6-4
    Multilanguage label, 4-4
    Multilanguage text, 4-4
  
  Name, 10-3
  alarms, 4-56
  ASCII field, 4-14
  bar field, 4-21
direct commands, 4-69
dynamic text field, 4-19
exchange area, 4-52
header and footer, 4-84
information messages, 4-53
lists of image, 4-71
macro, 4-78
memory area, 4-41
Mobile symbolic field, 4-25
Numerical field, 4-6
page sequences, 4-40
password, 6-6
pipeline, 4-81
print page, 4-83
project images, 4-76
report, 4-87
symbolic field, 4-23
text lists, 4-71
touch button, 4-32
touch buttons, 4-59
trend, 4-29
trend buffer, 4-90
variable, 4-36
variable groups, 4-39
Name of format, 10-2
Name of page, 4-3
Name of printer, 10-2
National Customer Care, 15-2
National Product returns, 15-2
New..., 5-2
No stop, 9-2
None, 4-61
Number
page sequences, 4-40
pipeline, 4-81
print page, 4-83
report, 4-87
trend buffer, 4-90
Number of characters in code, 6-25
Number of characters in comment, 6-25
Number of samples
trend, 4-30
trend buffer, 4-90
Numerical field, 4-5
Numerical format
Numerical field, 4-7
Object, 6-3
macro, 4-79
touch buttons, 4-60
Object > Arc, 7-7
Object > Bitmap image, 7-7
Object > Ellipse, 7-7
Object > library, 7-4
Object > Line, 7-7
Object > None, 7-6
Object > Rectangle, 7-7
One-shot read
ASCII field, 4-15
bar field, 4-22
dynamic text field, 4-20
Mobile symbolic field, 4-26
Numerical field, 4-11
symbolic field, 4-24
Open..., 5-9
Operation
direct command, 4-70
Optional sections, 10-3
Options, 5-11
OR Command, 4-69
Ordering alarm buffer starting from most recent alarm, 6-13
Output, 9-2
P
Page, 4-3, 6-4
Page help, 4-3
Page number, 4-3
Page numbers, 10-4
Page Selected
page sequences, 4-41
Page selected report, 4-87
Page sequences, 4-39
Page settings, 10-4
PAGE 1 - Start page, 8-17
Pages data, 6-4
Password, 6-6
ASCII field, 4-16
bar field, 4-22
dynamic text field, 4-20
Mobile symbolic field, 4-26
Numerical field, 4-12
symbolic field, 4-25
touch buttons, 4-59
Password levels, 6-6
Personalizing a Font, 12-4
Pipelines, 4-79
Polling rate
trend buffer, 4-91
Polling time, 4-82
Positioning a field within the page, 2-3
Preview, 10-3
alarms, 4-57, 4-58
ASCII field, 4-15
information messages, 4-54, 4-55
lists of image, 4-72
Numerical field, 4-9
project images, 4-76
touch buttons, 4-59
Print
header and footer, 4-85
Print alarm
alarms, 4-58
Print attribute
print page, 4-83
Print message
information messages, 4-55
Print page, 4-82
Print settings, 6-14
Print the project, 10-2
Print..., 5-10
Printer Port, 10-2
Printer status area, 4-51
Programming functions, 2-1
Project, 6-2
Project fonts, 6-12
Project for Single VT, 5-2
Project image, 4-34
Project images - Graphic (Part 1 of 3), AA-2
Project information, 6-7, 8-6, 10-4
Project language, 6-8
Project settings, 6-12
Project setup, 8-10
Project touch buttons
touch button, 4-32
Properties..., 5-10
Public data, 6-26
Q
Queue type
trend buffer, 4-91
R
Random Sequence
page sequences, 4-41
report, 4-87
Read and write by command, 4-81
Read and write by polling, 4-80
Read by polling and write with each change, 4-80
Read/write, 4-82
Recipe management enable, 6-25
Rectangle, 4-33
Refresh time, 4-3
exchange area, 4-52
Relationship between exchange area and memory area, 2-4
Relationship between fields and variables, 2-4
Rename, 5-10
Report, 4-86
Requirements for displaying the Help on Line, I-1
Reverse, 4-4
Rows per Page
header and footer, 4-85
print page, 4-83
S
Sampling mode
trend buffer, 4-91
Save, 5-9
Save as..., 5-10
Screen
bar field, 4-22
Screen saver delay, 6-13
Search for help on..., 6-26
Search Help For..., 5-11
Sections available, 10-3
Sections selected, 10-3
Select owner macro field, 6-4
Send Form-feed at the end of the page/footer report, 4-88
Sequence, 4-61
SET Command, 4-69
Setting, 6-4
Setting project languages, 8-7
Significance of the files generated by a project, I-2
Single sampling on command, 4-88
Single sampling on polling, 4-88
Source
ASCII field, 4-15
bar field, 4-21
direct command, 4-70
dynamic text field, 4-19
exchange area, 4-52
memory area, 4-42
Mobile symbolic field, 4-25
Numerical field, 4-6
symbolic field, 4-24
trend buffer, 4-90
variable, 4-36
Source (destination variable)
pipeline, 4-81
Source (Horizontal variable)
Mobile symbolic field, 4-27
Source (source variable)
pipeline, 4-81
Source (Vertical variable)
Mobile symbolic field, 4-27
Start Page
page sequences, 4-41
Start page, 6-13
report, 4-87
Start up sequence, 6-12
Start/Stop Sequence
page sequences, 4-41
report, 4-87
Status area, 4-47
Status area for external keys, 4-49
Status area for external keys (Real
Time), 4-50
Status area for external LEDs, 4-48
Status area for internal keys, 4-49
Status area for internal keys (Real
Time), 4-50
Status area for internal LEDs, 4-48
Status area for recipes, 4-49
Status area of terminal, 4-47
Status bar, 5-11
Stop after N. errors, 9-2
Stop at first error, 9-2
Stop Page
page sequences, 4-41
Stop page
report, 4-87
SUBTRACT Command, 4-68
Switch-on led
page sequences, 4-41
Symbolic field, 4-23
Synchronized recipe transfer, 6-25
Synchronized recipe transmission, 6-21
System messages, 6-7
T
Terminology used, 7-2
Text list
dynamic text field, 4-19
Text lists, 4-70
Texts
text lists, 4-71
Threshold
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-20
Numerical field, 4-13
touch buttons, 4-60
Threshold image
touch buttons, 4-61
Threshold preview
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-21
Numerical field, 4-14
touch buttons, 4-61
Threshold source
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-20
Numerical field, 4-13
touch buttons, 4-60
Threshold variable
touch buttons, 4-60
Threshold variable
ASCII field, 4-16
bar field, 4-23
dynamic text field, 4-20
Numerical field, 4-13
Time format
Alarms, 6-14
Messages, 6-14
Time long, 4-28
Time short, 4-28
Tools, 5-10, 6-2
Tools > Print..., 7-3
Tools > Project compilation, 7-4
Tools > Project transmission, 7-4
Touch Button, 4-32
Touch button, 4-58
Transfer of free terminal, 13-2
Transferring the project, 9-3
Trend, 4-29
Trend buffer, 4-88
trend, 4-30
Trend color
Lower limit, 4-31
Marker type, 4-30
Upper limit, 4-30
Trend status area
exchange area, 4-51
Truncated digits
Numerical field, 4-8
Type
dynamic text field, 4-19
Mobile symbolic field, 4-26
symbolic field, 4-24
variable, 4-36
Type of data area
exchange area, 4-52
Type of project, I-2
U
Update, 6-2
Update adapters, 9-4
Update adapters Fw, 9-4
Update and close, 6-2
Update Public data, 6-2
Update terminal, 9-3
Update terminal Fw, 9-3
Upper limit
trend, 4-30
Use predefined parameters
header and footer, 4-85
Use predefined settings
report, 4-88
User application package, 14-2
Uses predefined parameters
print page, 4-83
Using VTWIN, 7-1
V
Value
direct command, 4-70
Values
lists of image, 4-72
text lists, 4-71
Value-structured Direct Commands, 4-68
Variable
ASCII field, 4-15
bar field, 4-22
direct command, 4-70
dynamic text field, 4-19
Mobile symbolic field, 4-25
Numerical field, 4-6
symbolic field, 4-24
trend buffer, 4-90
Variable (destination variable)
pipeline, 4-81
Variable (Horizontal variable)
  Mobile symbolic field, 4-27
Variable (source variable)
  pipeline, 4-81
Variable (Vertical variable)
  Mobile symbolic field, 4-27
Variable comment, 6-25
Variable groups, 4-38
Variables, 4-34
Vertical arrangement, 6-26
View, 5-11, 10-3
Visible digits
  Numerical field, 4-6
VTWIN Language, 5-11
VTWIN menus, 3-1

W

What is a project?, I-1
What is VTWIN?, I-1
Width
  touch buttons, 4-59
Windows, 6-26
With sign
  variable, 4-37

X

XOR Command, 4-69